Grub reparieren

Probleme bei der Installation von Hardware unter Manjaro Linux? Hier wird geholfen.</span
Benutzeravatar

Themen Author
Borrtux
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 77
Registriert: Samstag 18. Juli 2020, 09:50
CPU: 4x Intel Core i5-6200 CPU @ 2.30GHz
GPU: NVIDIA GeForce 930M
Kernel: 5.4.64-1-MANJARO
DE: KDE Plasma 5.19.4
GPU Treiber: Mesa Intel® HD Graphics 520
Has thanked: 14 times
Been thanked: 4 times

Grub reparieren

#1

#1 Beitrag von Borrtux »

Hallo Gemeinde,
Nach einer Aktualisierung in Linux Mint (auch ein neuer Kernel) startete mein Manjaro nicht mehr.
Manjaro wurde als letztes installiert und dem gehörte der grub.
Jetzt nach der Aktualisierung sieht grub wieder aus wie von Mint.
Manjaro startete nicht. Nach vielem hin und her konnte ich Manjaro im recovery-mode mit Kernel 5.6.19 starten.
Habe in beiden Systemen mehrfach sudo update-grub ausgeführt - keine Änderung.
Dann Kernel 5.7.9 deinstalliert - beide Systeme wieder sudo ubdate-grub Neustarts - keine Änderung.
Wieder 5.7.9 installiert - sudo ubdate-grub - keine Änderung.
Im Bootmenü werden die Änderungen aufgezeigt - also 5.7.9 wird nach Installation ezeigt und man kann es auswählen, aber es startet nicht.
Bis jetzt lässt sich WIN10 - Linux Mint starten, aber Manjaro nach wie vor nur im recovery-mode mit Kernel 5.6.19.
Bin erst mal mit meinem Latain am Ende.
Habt ihr einen Tip?
borrtux@borrtux-P7641-MD60398:~$ cat /boot/grub/grub.cfg
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
set have_grubenv=true
load_env
fi
if [ "${initrdfail}" = 2 ]; then
set initrdfail=
elif [ "${initrdfail}" = 1 ]; then
set next_entry="${prev_entry}"
set prev_entry=
save_env prev_entry
if [ "${next_entry}" ]; then
set initrdfail=2
fi
fi
if [ "${next_entry}" ] ; then
set default="${next_entry}"
set next_entry=
save_env next_entry
set boot_once=true
else
set default="2"
fi

if [ x"${feature_menuentry_id}" = xy ]; then
menuentry_id_option="--id"
else
menuentry_id_option=""
fi

export menuentry_id_option

if [ "${prev_saved_entry}" ]; then
set saved_entry="${prev_saved_entry}"
save_env saved_entry
set prev_saved_entry=
save_env prev_saved_entry
set boot_once=true
fi

function savedefault {
if [ -z "${boot_once}" ]; then
saved_entry="${chosen}"
save_env saved_entry
fi
}
function initrdfail {
if [ -n "${have_grubenv}" ]; then if [ -n "${partuuid}" ]; then
if [ -z "${initrdfail}" ]; then
set initrdfail=1
if [ -n "${boot_once}" ]; then
set prev_entry="${default}"
save_env prev_entry
fi
fi
save_env initrdfail
fi; fi
}
function recordfail {
set recordfail=1
if [ -n "${have_grubenv}" ]; then if [ -z "${boot_once}" ]; then save_env recordfail; fi; fi
}
function load_video {
if [ x$feature_all_video_module = xy ]; then
insmod all_video
else
insmod efi_gop
insmod efi_uga
insmod ieee1275_fb
insmod vbe
insmod vga
insmod video_bochs
insmod video_cirrus
fi
}

if [ x$feature_default_font_path = xy ] ; then
font=unicode
else
insmod part_gpt
insmod ext2
set root='hd0,gpt3'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt3 --hint-efi=hd0,gpt3 --hint-baremetal=ahci0,gpt3 196aa8ca-2b7a-4b8f-8686-2418ceb13adf
else
search --no-floppy --fs-uuid --set=root 196aa8ca-2b7a-4b8f-8686-2418ceb13adf
fi
font="/usr/share/grub/unicode.pf2"
fi

if loadfont $font ; then
set gfxmode=auto
load_video
insmod gfxterm
set locale_dir=$prefix/locale
set lang=de_DE
insmod gettext
fi
terminal_output gfxterm
if [ "${recordfail}" = 1 ] ; then
set timeout=30
else
if [ x$feature_timeout_style = xy ] ; then
set timeout_style=hidden
set timeout=3
# Fallback hidden-timeout code in case the timeout_style feature is
# unavailable.
elif sleep --interruptible 3 ; then
set timeout=0
fi
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
function gfxmode {
set gfxpayload="${1}"
if [ "${1}" = "keep" ]; then
set vt_handoff=vt.handoff=7
else
set vt_handoff=
fi
}
if [ "${recordfail}" != 1 ]; then
if [ -e ${prefix}/gfxblacklist.txt ]; then
if hwmatch ${prefix}/gfxblacklist.txt 3; then
if [ ${match} = 0 ]; then
set linux_gfx_mode=keep
else
set linux_gfx_mode=text
fi
else
set linux_gfx_mode=text
fi
else
set linux_gfx_mode=keep
fi
else
set linux_gfx_mode=text
fi
export linux_gfx_mode
menuentry 'Linux Mint 20 Cinnamon' --class linuxmint --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-196aa8ca-2b7a-4b8f-8686-2418ceb13adf' {
recordfail
load_video
gfxmode $linux_gfx_mode
insmod gzio
if [ x$grub_platform = xxen ]; then insmod xzio; insmod lzopio; fi
insmod part_gpt
insmod ext2
set root='hd0,gpt3'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt3 --hint-efi=hd0,gpt3 --hint-baremetal=ahci0,gpt3 196aa8ca-2b7a-4b8f-8686-2418ceb13adf
else
search --no-floppy --fs-uuid --set=root 196aa8ca-2b7a-4b8f-8686-2418ceb13adf
fi
linux /boot/vmlinuz-5.4.0-42-generic root=UUID=196aa8ca-2b7a-4b8f-8686-2418ceb13adf ro quiet splash
initrd /boot/initrd.img-5.4.0-42-generic
}
submenu 'Erweiterte Optionen für Linux Mint 20 Cinnamon' $menuentry_id_option 'gnulinux-advanced-196aa8ca-2b7a-4b8f-8686-2418ceb13adf' {
menuentry 'Linux Mint 20 Cinnamon, mit Linux 5.4.0-42-generic' --class linuxmint --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-5.4.0-42-generic-advanced-196aa8ca-2b7a-4b8f-8686-2418ceb13adf' {
recordfail
load_video
gfxmode $linux_gfx_mode
insmod gzio
if [ x$grub_platform = xxen ]; then insmod xzio; insmod lzopio; fi
insmod part_gpt
insmod ext2
set root='hd0,gpt3'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt3 --hint-efi=hd0,gpt3 --hint-baremetal=ahci0,gpt3 196aa8ca-2b7a-4b8f-8686-2418ceb13adf
else
search --no-floppy --fs-uuid --set=root 196aa8ca-2b7a-4b8f-8686-2418ceb13adf
fi
echo 'Linux 5.4.0-42-generic wird geladen …'
linux /boot/vmlinuz-5.4.0-42-generic root=UUID=196aa8ca-2b7a-4b8f-8686-2418ceb13adf ro quiet splash
echo 'Initiale Ramdisk wird geladen …'
initrd /boot/initrd.img-5.4.0-42-generic
}
menuentry 'Linux Mint 20 Cinnamon, mit Linux 5.4.0-42-generic (recovery mode)' --class linuxmint --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-5.4.0-42-generic-recovery-196aa8ca-2b7a-4b8f-8686-2418ceb13adf' {
recordfail
load_video
insmod gzio
if [ x$grub_platform = xxen ]; then insmod xzio; insmod lzopio; fi
insmod part_gpt
insmod ext2
set root='hd0,gpt3'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt3 --hint-efi=hd0,gpt3 --hint-baremetal=ahci0,gpt3 196aa8ca-2b7a-4b8f-8686-2418ceb13adf
else
search --no-floppy --fs-uuid --set=root 196aa8ca-2b7a-4b8f-8686-2418ceb13adf
fi
echo 'Linux 5.4.0-42-generic wird geladen …'
linux /boot/vmlinuz-5.4.0-42-generic root=UUID=196aa8ca-2b7a-4b8f-8686-2418ceb13adf ro recovery nomodeset
echo 'Initiale Ramdisk wird geladen …'
initrd /boot/initrd.img-5.4.0-42-generic
}
menuentry 'Linux Mint 20 Cinnamon, mit Linux 5.4.0-40-generic' --class linuxmint --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-5.4.0-40-generic-advanced-196aa8ca-2b7a-4b8f-8686-2418ceb13adf' {
recordfail
load_video
gfxmode $linux_gfx_mode
insmod gzio
if [ x$grub_platform = xxen ]; then insmod xzio; insmod lzopio; fi
insmod part_gpt
insmod ext2
set root='hd0,gpt3'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt3 --hint-efi=hd0,gpt3 --hint-baremetal=ahci0,gpt3 196aa8ca-2b7a-4b8f-8686-2418ceb13adf
else
search --no-floppy --fs-uuid --set=root 196aa8ca-2b7a-4b8f-8686-2418ceb13adf
fi
echo 'Linux 5.4.0-40-generic wird geladen …'
linux /boot/vmlinuz-5.4.0-40-generic root=UUID=196aa8ca-2b7a-4b8f-8686-2418ceb13adf ro quiet splash
echo 'Initiale Ramdisk wird geladen …'
initrd /boot/initrd.img-5.4.0-40-generic
}
menuentry 'Linux Mint 20 Cinnamon, mit Linux 5.4.0-40-generic (recovery mode)' --class linuxmint --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-5.4.0-40-generic-recovery-196aa8ca-2b7a-4b8f-8686-2418ceb13adf' {
recordfail
load_video
insmod gzio
if [ x$grub_platform = xxen ]; then insmod xzio; insmod lzopio; fi
insmod part_gpt
insmod ext2
set root='hd0,gpt3'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt3 --hint-efi=hd0,gpt3 --hint-baremetal=ahci0,gpt3 196aa8ca-2b7a-4b8f-8686-2418ceb13adf
else
search --no-floppy --fs-uuid --set=root 196aa8ca-2b7a-4b8f-8686-2418ceb13adf
fi
echo 'Linux 5.4.0-40-generic wird geladen …'
linux /boot/vmlinuz-5.4.0-40-generic root=UUID=196aa8ca-2b7a-4b8f-8686-2418ceb13adf ro recovery nomodeset
echo 'Initiale Ramdisk wird geladen …'
initrd /boot/initrd.img-5.4.0-40-generic
}
}

### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/10_linux_zfs ###
### END /etc/grub.d/10_linux_zfs ###

### BEGIN /etc/grub.d/20_linux_xen ###

### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry 'Manjaro Linux (20.0.3) (auf /dev/sda4)' --class manjarolinux --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-simple-030467c8-ad63-473d-8580-29212bb65827' {
insmod part_gpt
insmod ext2
set root='hd0,gpt4'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt4 --hint-efi=hd0,gpt4 --hint-baremetal=ahci0,gpt4 030467c8-ad63-473d-8580-29212bb65827
else
search --no-floppy --fs-uuid --set=root 030467c8-ad63-473d-8580-29212bb65827
fi
linux /boot/vmlinuz-5.7-x86_64 root=UUID=030467c8-ad63-473d-8580-29212bb65827 rw quiet apparmor=1 security=apparmor udev.log_priority=3
initrd /boot/intel-ucode.img
}
submenu 'Erweiterte Optionen für Manjaro Linux (20.0.3) (auf /dev/sda4)' $menuentry_id_option 'osprober-gnulinux-advanced-030467c8-ad63-473d-8580-29212bb65827' {
menuentry 'Manjaro Linux (auf /dev/sda4)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-/boot/vmlinuz-5.7-x86_64--030467c8-ad63-473d-8580-29212bb65827' {
insmod part_gpt
insmod ext2
set root='hd0,gpt4'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt4 --hint-efi=hd0,gpt4 --hint-baremetal=ahci0,gpt4 030467c8-ad63-473d-8580-29212bb65827
else
search --no-floppy --fs-uuid --set=root 030467c8-ad63-473d-8580-29212bb65827
fi
linux /boot/vmlinuz-5.7-x86_64 root=UUID=030467c8-ad63-473d-8580-29212bb65827 rw quiet apparmor=1 security=apparmor udev.log_priority=3
initrd /boot/intel-ucode.img
}
menuentry 'Manjaro Linux (Kernel 5.7.9-1-MANJARO x64) (auf /dev/sda4)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-/boot/vmlinuz-5.7-x86_64--030467c8-ad63-473d-8580-29212bb65827' {
insmod part_gpt
insmod ext2
set root='hd0,gpt4'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt4 --hint-efi=hd0,gpt4 --hint-baremetal=ahci0,gpt4 030467c8-ad63-473d-8580-29212bb65827
else
search --no-floppy --fs-uuid --set=root 030467c8-ad63-473d-8580-29212bb65827
fi
linux /boot/vmlinuz-5.7-x86_64 root=UUID=030467c8-ad63-473d-8580-29212bb65827 rw quiet apparmor=1 security=apparmor udev.log_priority=3
initrd /boot/intel-ucode.img
}
menuentry 'Manjaro Linux (Kernel 5.7.9-1-MANJARO x64 - fallback initramfs) (auf /dev/sda4)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-/boot/vmlinuz-5.7-x86_64--030467c8-ad63-473d-8580-29212bb65827' {
insmod part_gpt
insmod ext2
set root='hd0,gpt4'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt4 --hint-efi=hd0,gpt4 --hint-baremetal=ahci0,gpt4 030467c8-ad63-473d-8580-29212bb65827
else
search --no-floppy --fs-uuid --set=root 030467c8-ad63-473d-8580-29212bb65827
fi
linux /boot/vmlinuz-5.7-x86_64 root=UUID=030467c8-ad63-473d-8580-29212bb65827 rw quiet apparmor=1 security=apparmor udev.log_priority=3
initrd /boot/initramfs-5.7-x86_64-fallback.img
}
menuentry 'Manjaro Linux (Kernel 5.6.19-2-MANJARO x64) (auf /dev/sda4)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-/boot/vmlinuz-5.6-x86_64--030467c8-ad63-473d-8580-29212bb65827' {
insmod part_gpt
insmod ext2
set root='hd0,gpt4'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt4 --hint-efi=hd0,gpt4 --hint-baremetal=ahci0,gpt4 030467c8-ad63-473d-8580-29212bb65827
else
search --no-floppy --fs-uuid --set=root 030467c8-ad63-473d-8580-29212bb65827
fi
linux /boot/vmlinuz-5.6-x86_64 root=UUID=030467c8-ad63-473d-8580-29212bb65827 rw quiet apparmor=1 security=apparmor udev.log_priority=3
initrd /boot/intel-ucode.img
}
menuentry 'Manjaro Linux (Kernel 5.6.19-2-MANJARO x64 - fallback initramfs) (auf /dev/sda4)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-/boot/vmlinuz-5.6-x86_64--030467c8-ad63-473d-8580-29212bb65827' {
insmod part_gpt
insmod ext2
set root='hd0,gpt4'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt4 --hint-efi=hd0,gpt4 --hint-baremetal=ahci0,gpt4 030467c8-ad63-473d-8580-29212bb65827
else
search --no-floppy --fs-uuid --set=root 030467c8-ad63-473d-8580-29212bb65827
fi
linux /boot/vmlinuz-5.6-x86_64 root=UUID=030467c8-ad63-473d-8580-29212bb65827 rw quiet apparmor=1 security=apparmor udev.log_priority=3
initrd /boot/initramfs-5.6-x86_64-fallback.img
}
}

menuentry 'Windows Boot Manager (auf /dev/sdb1)' --class windows --class os $menuentry_id_option 'osprober-efi-68B2-D6D8' {
insmod part_gpt
insmod fat
set root='hd1,gpt1'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-bios=hd1,gpt1 --hint-efi=hd1,gpt1 --hint-baremetal=ahci1,gpt1 68B2-D6D8
else
search --no-floppy --fs-uuid --set=root 68B2-D6D8
fi
chainloader /EFI/Microsoft/Boot/bootmgfw.efi
}
set timeout_style=menu
if [ "${timeout}" = 0 ]; then
set timeout=10
fi
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/30_uefi-firmware ###
menuentry 'UEFI Firmware Settings' $menuentry_id_option 'uefi-firmware' {
fwsetup
}
### END /etc/grub.d/30_uefi-firmware ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries. Simply type the
# menu entries you want to add after this comment. Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f ${config_directory}/custom.cfg ]; then
source ${config_directory}/custom.cfg
elif [ -z "${config_directory}" -a -f $prefix/custom.cfg ]; then
source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###
borrtux@borrtux-P7641-MD60398:~$
Das hier ist aus Linux Mint erstellt
Es grüßt euch borrtux
Benutzeravatar

Themen Author
Borrtux
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 77
Registriert: Samstag 18. Juli 2020, 09:50
CPU: 4x Intel Core i5-6200 CPU @ 2.30GHz
GPU: NVIDIA GeForce 930M
Kernel: 5.4.64-1-MANJARO
DE: KDE Plasma 5.19.4
GPU Treiber: Mesa Intel® HD Graphics 520
Has thanked: 14 times
Been thanked: 4 times

Re: Grub reparieren

#2

#2 Beitrag von Borrtux »

Wollte heute aus Manjaro heraus grub neu installieren.
Ergebnis:

Code: Alles auswählen

[borrtux@borrtux-p7641md60398 ~]$ sudo grub-setup /dev/sda
[sudo] Passwort für borrtux: 
sudo: grub-setup: Befehl nicht gefunden
[borrtux@borrtux-p7641md60398 ~]$ sudo grub-setup/dey/sda
sudo: grub-setup/dey/sda: Befehl nicht gefunden
[borrtux@borrtux-p7641md60398 ~]$ sudo grub-install/dev/sda
sudo: grub-install/dev/sda: Befehl nicht gefunden
[borrtux@borrtux-p7641md60398 ~]$ grub-install /dev/sda
x86_64-efi wird für Ihre Plattform installiert.
grub-install: Warnung: Platte existiert nicht, ersatzweise wird Partition des Geräts /dev/sdb1 verwendet.
grub-install: Warnung: Platte existiert nicht, ersatzweise wird Partition des Geräts /dev/sdb1 verwendet.
grub-install: Warnung: Platte existiert nicht, ersatzweise wird Partition des Geräts /dev/sdb1 verwendet.
grub-install: Fehler: Laufwerk »hostdisk//dev/sdb1« wurde nicht gefunden..
[borrtux@borrtux-p7641md60398 ~]$ cd sdb1
bash: cd: sdb1: Datei oder Verzeichnis nicht gefunden
Schon erstaunlich, da in der Partitionsverwaltung sdb1 eindeutig als efi-Partition gekennzeichnet ist.
komisch

Code: Alles auswählen

[borrtux@borrtux-p7641md60398 ~]$ sudo parted -l
[sudo] Passwort für borrtux: 
Modell: ATA TOSHIBA MQ01ABD1 (scsi)
Festplatte  /dev/sda:  1000GB
Sektorgröße (logisch/physisch): 512B/4096B
Partitionstabelle: gpt
Disk-Flags: 

Nummer  Anfang  Ende    Größe   Dateisystem  Name                  Flags
 1      1049kB  800GB   800GB   ntfs         Basic data partition  msftdata
 4      800GB   863GB   63,5GB  ext4
 3      863GB   968GB   105GB   ext4         LinuxCinnamon
 2      968GB   1000GB  32,2GB  ntfs         Basic data partition  msftdata


Modell: ATA S11-256G-PHISON- (scsi)
Festplatte  /dev/sdb:  256GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: gpt
Disk-Flags: 

Nummer  Anfang  Ende   Größe   Dateisystem  Name                          Flags
 1      1049kB  106MB  105MB   fat32        EFI system partition          boot, esp
 2      106MB   123MB  16,8MB               Microsoft reserved partition  msftres
 3      123MB   253GB  253GB   ntfs         Basic data partition          msftdata
 4      253GB   254GB  635MB   ntfs                                       versteckt, diag
 5      254GB   255GB  974MB   ntfs                                       versteckt, diag
 6      255GB   256GB  1074MB  fat32        Basic data partition          versteckt

Es grüßt euch borrtux
Benutzeravatar

LaGGGer
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 26
Registriert: Freitag 26. Juni 2020, 18:53
CPU: AMD Ryzen 7 1700X
GPU: NVIDIA GP106 [GeForce GTX 1060 6GB]
Kernel: 5.6
DE: XFCE
GPU Treiber: nouveau
Has thanked: 3 times
Been thanked: 3 times

Re: Grub reparieren

#3

#3 Beitrag von LaGGGer »

Hallo

du hast im ersten Post gefragt:
Habt ihr einen Tip?
Ja, den habe ich. Ich glaube zwar nicht das du es tun wirst, aber möglicherweise doch. Es ist nämlich mit Anschaffungskosten verbunden, aber todsicher. So ein Problem wie bei dir jetzt wird es nicht mehr geben.

Meine Betriebssysteme die ich zur Zeit Nutze oder Teste:
Windows 10 : Kann ich leider nicht drauf verzichten, nutze das ausschliesslich zum Zocken & Twitch.
Linux: LinuxMint 20 Cinnamon, LinuxMint 18.3 Mate, XUbuntu 20, Manjaro XFCE 20.

Einige Systeme sind nur zum ausprobieren, Manjaro nutze ich im Moment dauerhaft.
Jedes Sytem hat seine eigene Festplatte, 30-60GB SSD's bekommt man unter 30€ Die Win10 SSD plus einer Daten SSD sind fest verbaut, die Linux Systeme nicht. Die Linux SSD's werden natürlich beschriftet + ordentlich aufbewahrt ^^

Hardwareanschaffung Nr.1: Sharkoon SATA Quick Port
Hiermit kann ich die verschiedenen Systeme ausprobieren, hat ein 3,5" Einschub und einen 2,5" Einschub

Hardwareanschaffung Nr.2 : Power Switch für Festplatten
Damit schalte ich die fest verbaute Win10 SSD und die Daten SSD aus. Gibts für alle möglichen Einbauschächte

Ich wollte damit erreichen das sich Windows und Linux sich nie sehen, was ja auch so ist. Jedes System hat seine eigene Bootroutine, bei mir gibts keine zwei Linux Systeme auf einer SSD.

Beispiel:
Windows & Daten SSD sind, wenn ich Linux fahre, immer ausgeschaltet. Hätte ich grade Manjaro am laufen und möchte etwas mit XUbuntu testen .. System runterfahren, Manjro SSD raus, XUbuntu SSD rein .. starten ... fertig.

Und natürlich umgekehrt: Der Quick Port für die Linux SSD's ist ausgeschaltet, die fest verbauten Win10 + Daten SSD's werden eingeschaltet .. Windows fährt hoch und bekommt nichts von Linux mit.

Ein anderer Vorteil ist bei der Installation. Wenn 3 oder 4 SSDs / HD's aktiv im System sind muss man höllisch aufpassen das man auf der richtigen Festplatte / Partition installiert. ich hab da mal einen Fehler gemacht und eine Menge Daten waren weg. Vielleicht kennt das der eine oder andere von euch auch ^^
Passiert mir jetzt auch nicht mehr, ausschliesslich ist beim Installieren die Festplatte eingeschaltet die gebraucht wird, alle anderen sind aus.

So ist mein System aufgebaut, die Anschaffungskosten sind nicht grade billig, für die Hardware und 2 SSD's sind ~120€ fällig. Aber PC Technik und Software sind mein Hobby, das musste eben sein.
Wenn jemand das Geld übrig hat kann er sich das ja einmal überlegen, ich habs nicht bereut.
°°
MfG LaGGGer
Benutzeravatar

Themen Author
Borrtux
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 77
Registriert: Samstag 18. Juli 2020, 09:50
CPU: 4x Intel Core i5-6200 CPU @ 2.30GHz
GPU: NVIDIA GeForce 930M
Kernel: 5.4.64-1-MANJARO
DE: KDE Plasma 5.19.4
GPU Treiber: Mesa Intel® HD Graphics 520
Has thanked: 14 times
Been thanked: 4 times

Re: Grub reparieren

#4

#4 Beitrag von Borrtux »

Hallo LaGGGer,
vielen Dank für deine Antwort. :)
Hast recht - das kommt für mich nicht infrage.
LaGGGer hat geschrieben: Freitag 31. Juli 2020, 11:51 Hallo

du hast im ersten Post gefragt:
Habt ihr einen Tip?
Ja, den habe ich. Ich glaube zwar nicht das du es tun wirst, aber möglicherweise doch. Es ist nämlich mit Anschaffungskosten verbunden, aber todsicher. So ein Problem wie bei dir jetzt wird es nicht mehr geben.


Hardwareanschaffung Nr.1: Sharkoon SATA Quick Port
Hiermit kann ich die verschiedenen Systeme ausprobieren, hat ein 3,5" Einschub und einen 2,5" Einschub
Es handelt sich bei mir um ein Laptop - da kommt das nicht in Frage
Hardwareanschaffung Nr.2 : Power Switch für Festplatten
Damit schalte ich die fest verbaute Win10 SSD und die Daten SSD aus. Gibts für alle möglichen Einbauschächte
Der Link ist derselbe, wie der erste

Trotzdem vielen Dank für deine Ausführungen und der damit verbundenen Mühe.
Ich habe jetzt auch schon boot repair versucht - fruchtet aber nicht.
Aber irgendwie müsste das doch gerade zu biegen sein. Kommt Zeit - kommt Rat.
Es grüßt euch borrtux
Benutzeravatar

LaGGGer
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 26
Registriert: Freitag 26. Juni 2020, 18:53
CPU: AMD Ryzen 7 1700X
GPU: NVIDIA GP106 [GeForce GTX 1060 6GB]
Kernel: 5.6
DE: XFCE
GPU Treiber: nouveau
Has thanked: 3 times
Been thanked: 3 times

Re: Grub reparieren

#5

#5 Beitrag von LaGGGer »

Hallo
Sorry, habe nicht gemerkt das es hier um ein Laptop geht. Könnte man zu einem Punkt im Profil machen. Ok, möglicherweise sieht man das auch an der GPU.
Aber kein Problem, mein Beitrag ist möglicherweise ein Anregung für andere Forenmitglieder.

Leider kann ich meinen Beitrag nicht mehr editieren, habs nicht gemerkt das ich den verkehrten Link eingetragen habe.
Ich korrigier das mal hier:
Power Switch für Festplatten
°°
MfG LaGGGer
Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 1299
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.19
DE: Openbox
GPU Treiber: i915
Has thanked: 7 times
Been thanked: 209 times

Re: Grub reparieren

#6

#6 Beitrag von gosia »

Hallo Borrtux,
ist das eine Fortsetzung von diesem Thread?
https://www.manjaro-forum.de/viewtopic. ... 5c6#p17154
LaGGGer hat geschrieben: Freitag 31. Juli 2020, 11:51 Wollte heute aus Manjaro heraus grub neu installieren.
Da empfehle ich dir unbedingt manjaro-chroot
https://wiki.manjaro.org/index.php/Rest ... Bootloader
das erspart dir auch etliche Vertipper.
Borrtux hat geschrieben: Freitag 31. Juli 2020, 09:16

Code: Alles auswählen

cd sdb1
bash: cd: sdb1: Datei oder Verzeichnis nicht gefunden
Schon erstaunlich, da in der Partitionsverwaltung sdb1 eindeutig als efi-Partition gekennzeichnet ist.
Da ist nichts erstaunliches dran, cd wechselt in ein Vezeichnis und sdb1 ist eine Partition, das sind riesige Unterschiede.
Wenn deine Verwunderung aber von dieser Meldung kommt
Borrtux hat geschrieben: Freitag 31. Juli 2020, 09:16

Code: Alles auswählen

Fehler: Laufwerk »hostdisk//dev/sdb1« wurde nicht gefunden..
Tja, hast Du denn sdb1 gemountet, wie es sein soll? Ich sehe in deinen Meldungen nichts davon.

viele Grüße gosia
Benutzeravatar

Themen Author
Borrtux
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 77
Registriert: Samstag 18. Juli 2020, 09:50
CPU: 4x Intel Core i5-6200 CPU @ 2.30GHz
GPU: NVIDIA GeForce 930M
Kernel: 5.4.64-1-MANJARO
DE: KDE Plasma 5.19.4
GPU Treiber: Mesa Intel® HD Graphics 520
Has thanked: 14 times
Been thanked: 4 times

Re: Grub reparieren

#7

#7 Beitrag von Borrtux »

gosia hat geschrieben: Freitag 31. Juli 2020, 14:15 Hallo Borrtux,
ist das eine Fortsetzung von diesem Thread?
https://www.manjaro-forum.de/viewtopic. ... 5c6#p17154
LaGGGer hat geschrieben: Freitag 31. Juli 2020, 11:51 Wollte heute aus Manjaro heraus grub neu installieren.
Da empfehle ich dir unbedingt manjaro-chroot
https://wiki.manjaro.org/index.php/Rest ... Bootloader
das erspart dir auch etliche Vertipper.
Nein der andere Thread (XFCE-Installation mit Fehlermeldung abgebrochen) bezieht sich auf meinen Desktopcomputer.
Dieser Thread (Grub reparieren) bezieht sich auf mein Laptop.
Es grüßt euch borrtux
Benutzeravatar

Themen Author
Borrtux
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 77
Registriert: Samstag 18. Juli 2020, 09:50
CPU: 4x Intel Core i5-6200 CPU @ 2.30GHz
GPU: NVIDIA GeForce 930M
Kernel: 5.4.64-1-MANJARO
DE: KDE Plasma 5.19.4
GPU Treiber: Mesa Intel® HD Graphics 520
Has thanked: 14 times
Been thanked: 4 times

Re: Grub reparieren

#8

#8 Beitrag von Borrtux »

Ich weiß auch gar nicht, ob das Thema hier noch passt.
Grub funktioniert eigentlich - ich kann Linux Mint auswählen - starten - OK
ich kann WIN10 auswählen - starten - OK
Nur bei Manjaro klappt das nicht. Ich habe noch einen 3. Kernel (4.15) installiert, und kann bei allen 3 nur über recovery-mode starten (allerdings sehe ich beim gestarteten OS keinen Unterschied zum "normalen" Modus). Der Start dauert evtl. etwas länger.

(PS: Das Problem am Desktop will ich eigentlich erst angehen, wenn dieses hier erledigt ist).

Bringt mich das hier weiter?

Code: Alles auswählen

[borrtux@borrtux-p7641md60398 ~]$ sudo su
[sudo] Passwort für borrtux: 
[borrtux-p7641md60398 borrtux]# lsblk -f
NAME   FSTYPE FSVER LABEL   UUID                                 FSAVAIL FSUSE% MOUNTPOINT
sda                                                                             
├─sda1 ntfs         Data    D0AE4BE4AE4BC228                                    
├─sda2 ntfs         Recover CEF64E66F64E4F41                                    
├─sda3 ext4   1.0           196aa8ca-2b7a-4b8f-8686-2418ceb13adf                
└─sda4 ext4   1.0           030467c8-ad63-473d-8580-29212bb65827   20,3G    60% /run/timeshift/backup
sdb                                                                             
├─sdb1 vfat   FAT32         68B2-D6D8                              60,1M    37% /boot/efi
├─sdb2                                                                          
├─sdb3 ntfs         Boot    8842B18B42B17E8E                                    
├─sdb4 ntfs                 9AA0664FA06631C5                                    
├─sdb5 ntfs                 C45073A650739DBC                                    
└─sdb6 vfat   FAT32 PRC_RP  E2FB-7379                                           
sr0                                                                             
[borrtux-p7641md60398 borrtux]# sudo blkid -o list -c /dev/nul
device                    fs_type    label       mount point                   UUID
--------------------------------------------------------------------------------------------------------------------
/dev/sda1                 ntfs       Data        (nicht eingehängt)           D0AE4BE4AE4BC228
/dev/sda2                 ntfs       Recover     (nicht eingehängt)           CEF64E66F64E4F41
/dev/sda3                 ext4                   (nicht eingehängt)           196aa8ca-2b7a-4b8f-8686-2418ceb13adf
/dev/sda4                 ext4                   /                             030467c8-ad63-473d-8580-29212bb65827
/dev/sdb1                 vfat                   /boot/efi                     68B2-D6D8
/dev/sdb2                                        (nicht eingehängt)           
/dev/sdb3                 ntfs       Boot        (nicht eingehängt)           8842B18B42B17E8E
/dev/sdb4                 ntfs                   (nicht eingehängt)           9AA0664FA06631C5
/dev/sdb5                 ntfs                   (nicht eingehängt)           C45073A650739DBC
/dev/sdb6                 vfat       PRC_RP      (nicht eingehängt)           E2FB-7379
[borrtux-p7641md60398 borrtux]# 
sdb1 ist boot und efi
sdb3 ist auch als Boot deklariert.
Ob das richtig ist weiß ich leider (noch) nicht.
sda4 ist Manjaro
Es grüßt euch borrtux
Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 1299
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.19
DE: Openbox
GPU Treiber: i915
Has thanked: 7 times
Been thanked: 209 times

Re: Grub reparieren

#9

#9 Beitrag von gosia »

Hallo Borrtux,
Borrtux hat geschrieben: Freitag 31. Juli 2020, 19:25 Ich weiß auch gar nicht, ob das Thema hier noch passt.
Passt schon.
Borrtux hat geschrieben: Freitag 31. Juli 2020, 19:25 Grub funktioniert eigentlich
Ist das der Grub von Mint oder Manjaro?
Aber wie dem auch sei, Du könntest auch das versuchen mit Hilfe von manjaro-chroot zu reparieren. Es geht natülich auch von Hand.
Einige Unklarheiten habe ich trotzdem:
Borrtux hat geschrieben: Freitag 31. Juli 2020, 19:25 sda4 ist Manjaro
Einmal sehe ich da "nur" Timeschift

Code: Alles auswählen

└─sda4 ext4   1.0           030467c8-ad63-473d-8580-29212bb65827   20,3G    60% /run/timeshift/backup
und dann das Wurzelverzeichnis von Linux (wird wohl Manjaro sein)

Code: Alles auswählen

/dev/sda4                 ext4                   /                             030467c8-ad63-473d-8580-29212bb65827
Borrtux hat geschrieben: Freitag 31. Juli 2020, 19:25 sdb3 ist auch als Boot deklariert.
Ob das richtig ist weiß ich leider (noch) nicht.
Naja, genaugenommen hat sdb3 nur das Label "Boot", aber ein Linux-Boot ist es sicher nicht, schon wegen ntfs. Gehört also wohl zu Windows.

viele Grüße gosia
Benutzeravatar

Themen Author
Borrtux
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 77
Registriert: Samstag 18. Juli 2020, 09:50
CPU: 4x Intel Core i5-6200 CPU @ 2.30GHz
GPU: NVIDIA GeForce 930M
Kernel: 5.4.64-1-MANJARO
DE: KDE Plasma 5.19.4
GPU Treiber: Mesa Intel® HD Graphics 520
Has thanked: 14 times
Been thanked: 4 times

Re: Grub reparieren

#10

#10 Beitrag von Borrtux »

Es ist wohl das grub von Mint.
Wenn ich "sudo update-grub" bei Manjaro ausführe kommt auch z.B. Theme od. Hintergrund von manjaro grub gefunden (sinngemäß). Ist aber beim booten nicht u sehen. Also beim booten kriege ich das grub von Manjaro nicht zu sehen.
sda3 ist Linux Mint
sda4 ist Manjaro incl. Timeshift
Alles andere ist Windows

Stellt sich die Frage: wo ist grub Manjaro installiert?
Wo ist grub Linux Mint installiert?
Eigentlich wähle ich bei der Installation immer die efi-Partition aus, (ist in der Regel sda - in diesem Fall wohl sdb1) inzwischen weiß ich gar nicht mehr was ich gemacht habe.
Das Theater ging los, nachdem bei Linux Mint ein neuer Kernel installiert wurde.
Es grüßt euch borrtux
Benutzeravatar

Themen Author
Borrtux
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 77
Registriert: Samstag 18. Juli 2020, 09:50
CPU: 4x Intel Core i5-6200 CPU @ 2.30GHz
GPU: NVIDIA GeForce 930M
Kernel: 5.4.64-1-MANJARO
DE: KDE Plasma 5.19.4
GPU Treiber: Mesa Intel® HD Graphics 520
Has thanked: 14 times
Been thanked: 4 times

Re: Grub reparieren

#11

#11 Beitrag von Borrtux »

Wollte heute aus Manjaro heraus grub neu installieren.
Da empfehle ich dir unbedingt manjaro-chroot
https://wiki.manjaro.org/index.php/Rest ... Bootloader
das erspart dir auch etliche Vertipper.
Das wird viel Fleißarbeit.
Muß ich mir erst mühselig übersetzen.
Es grüßt euch borrtux
Benutzeravatar

Themen Author
Borrtux
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 77
Registriert: Samstag 18. Juli 2020, 09:50
CPU: 4x Intel Core i5-6200 CPU @ 2.30GHz
GPU: NVIDIA GeForce 930M
Kernel: 5.4.64-1-MANJARO
DE: KDE Plasma 5.19.4
GPU Treiber: Mesa Intel® HD Graphics 520
Has thanked: 14 times
Been thanked: 4 times

Re: Grub reparieren

#12

#12 Beitrag von Borrtux »

So, bin dabei.
Leider einige Probleme
Im Schritt: For UEFI-Systems kam folgende Fehlermeldung:

Code: Alles auswählen

Disk identifier: D4D028A6-74E6-4B41-A392-065B31A8E630

Device          Start        End    Sectors   Size Type
/dev/sda1        2048 1561774715 1561772668 744.7G Microsoft basic data
/dev/sda2  1890609152 1953523711   62914560    30G Microsoft basic data
/dev/sda3  1685809152 1890609151  204800000  97.7G Linux filesystem
/dev/sda4  1561774717 1685809151  124034435  59.1G Linux filesystem

Partition 4 does not start on physical sector boundary.
Partition table entries are not in disk order.
Google übersetzt das so:
Partition 4 startet nicht an der physischen Sektorgrenze.
Partitionstabelleneinträge sind nicht in Datenträgerreihenfolge.
Da wird der Fehler liegen. Weiß aber nicht, wie ich das richten kann.
Muß an dieser Stelle erst mal kapitulieren.
Es grüßt euch borrtux
Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 1299
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.19
DE: Openbox
GPU Treiber: i915
Has thanked: 7 times
Been thanked: 209 times

Re: Grub reparieren

#13

#13 Beitrag von gosia »

Hallo Borrtux,
genau weiss ich nicht, an welcher Stelle Du dich befindest, aber egal. Erstens ist das nur eine Warnung, oder besser gesagt, zwei Warnungen:
Borrtux hat geschrieben: Samstag 1. August 2020, 14:16 Partition 4 does not start on physical sector boundary.
Das kommt vor, kann aber in der Regel ignoriert werden, weil es sich, wenn überhaupt, bestenfalls auf die Lese- und Schreibgeschwindigkeit auswirkt, das aber selten. Beheben kann man das wohl nur, wenn Du Backup aller Daten machst und die Platte mit gparted so neu formatierst daß sie bei einem 4096-Byte-Sektor beginnt, dies kann durch das Setzen der Startgrenze auf 1 MiB erreicht werden. So könnte man es machen, rate aber dringend davon ab, Aufwand und Nutzen stehen in keinem vernünftigen Verhältnis. Also ignorieren.
Borrtux hat geschrieben: Samstag 1. August 2020, 14:16 Partition table entries are not in disk order.
Beim Löschen und Neuanlegen von Partitionen kommt dies vor und ist relativ normal. Kann mit fdisk und dem Kommando f relativ gefahrlos beseitigt werden (trotzdem vorher Backup), ist aber in der Regel auch nicht notwendig.
Vor allem auch, weil deine wichtige /boot/efi nicht auf sda sondern sdb1 liegt. Wenn Du also chroot gemacht hast, wäre also der nächste Schritt das mounten

Code: Alles auswählen

sudo mount /dev/sdb1 /boot/efi
Aber bitte nicht blind nachmachen sonden nochmals alles genau kontrollieren.

viele Grüße gosia
Benutzeravatar

oldmcsam
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 89
Registriert: Mittwoch 18. Mai 2016, 08:22
Wohnort: Berlin-Tiergarten (Mitte)
CPU: Intel Core i5 3320M
GPU: Intel 3nd Generation
Kernel: 5.7
DE: xfce
GPU Treiber: i915
Has thanked: 3 times
Been thanked: 4 times

Re: Grub reparieren

#14

#14 Beitrag von oldmcsam »

Hallo Borrtuxx,
ich habe auf meinem Laptop auch WIN 10, Manjaro, Mint, MX linux, Puppy und Android.
Mint (Ubuntu und alle Derivate) erzeugen für Manjaro einen fehlerhaften Grub.
Deswegen habe ich Manjaro gestattet, auf dem Masterboot Grub zu erstellen.
Alle anderen Distris erstellen den Grub auf ihrer eigenen Partition.(/)
In Deinem Fall würde ich den Grubeintrag der Manjarodistri in dem Grubeintrag von Mint ersetzen und damit den Eintrag von Mint löschen.
Auf lange Sicht wäre es besser, wenn Manjaro den Grubeintrag generiert würde.
Um dies zu tun benutze ich folgenden Befehl: sudo geany /boot/grub/grub.cfg
Dateianhänge
Bildschirmfoto_2020-08-01_23-57-23.png
Bildschirmfoto_2020-08-01_23-57-23.png (62.47 KiB) 1020 mal betrachtet
Benutzeravatar

Themen Author
Borrtux
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 77
Registriert: Samstag 18. Juli 2020, 09:50
CPU: 4x Intel Core i5-6200 CPU @ 2.30GHz
GPU: NVIDIA GeForce 930M
Kernel: 5.4.64-1-MANJARO
DE: KDE Plasma 5.19.4
GPU Treiber: Mesa Intel® HD Graphics 520
Has thanked: 14 times
Been thanked: 4 times

Re: Grub reparieren

#15

#15 Beitrag von Borrtux »

Hallo Gosia/oldmcsam
Ich habe wieder stundenlang rumgedoktert.
Habe mir die Befehle für's reparieren rausgeschrieben/kopiert. Auf Stick mit Libreoffice gesichert, um dann festzustellen, dass ich das auf einem Manjaro Livestick XFCE und KDE nicht lesen kann. Dann wieder das ganze zu PDF exportiert. Kann ich unter XFCE zwar lesen aber nicht den Text kopieren. Wieder KDE (musste mir die Sticks erstellen), hier konnte ich dann den Text kopieren, aber durch das PDF-Format hatte ich an den falschen Stellen "blancs" (Leerzeichen).
Jedenfalls ist das Projekt an der Stelle gescheitert. (Könnte hier noch stundenlang berichten).
Kurze Rede langer Sinn letztendlich habe ich aus dem laufenden System heraus Grub neu installiert mit
sudo grub-install /dev/sdb1
Das ist die Bootpartition. Seit dem läuft es wieder.
Wenn ich den Post von oldmcsam lese, wird es so wohl nur bleiben, bis Mint einen neuen Kernel installiert.
Leider habe ich den Post erst nach der Aktion gelesen.
Warten wir mal ab. Wie ich den Tip von umsetzen kann ist mir noch nicht ganz klar.
Erst mal euch beiden vielen Dank für eure Mühe und Zeit, die ihr aufgebracht habt.
PS: wie bekomme ich denn den Screenshot so klein, dass ich ihn hier posten kann?
Es grüßt euch borrtux
Antworten