Veracrypt-USB-Volume trennt sich plötzlich von selbst Thema ist als GELÖST markiert

Probleme bei der Installation von Hardware unter Manjaro Linux? Hier wird geholfen.</span
Antworten

Themen Author
Clemens
Forum Kenner
Forum Kenner
Beiträge: 163
Registriert: Donnerstag 9. Januar 2020, 18:16
Wohnort: Rottweil
CPU: Intel i5-7400
GPU: nVidia GTX 1650
Kernel: 5.5.19
DE: FXCE
GPU Treiber: Linux / nVidia free
Hat sich bedankt: 44 Mal
Danksagung erhalten: 1 Mal
Kontaktdaten:

Veracrypt-USB-Volume trennt sich plötzlich von selbst

#1

#1 Beitrag von Clemens »

Seit ich auf Linux umgestiegen bin (von Win-7), also seit über 1 Jahr, benutze ich für alle sensiblen Daten (DSGVO, AO, usw.) eine mit Veracrypt voll verschlüsselte USB-Festplatte (USB-3.0 SATA 2,5" HDD über USB-3 stromversorgt). Die gestattet auch den Zugriff aus meinen Win-7- VM und hat zudem den Charme, dass ich sie an den jeweiligen Arbeitsort mitnehmen kann und keine sensiblen Daten einer Cloud anvertrauen muss. Diese Lösung hat unter Xubuntu über 1 Jahr stabil funktioniert und hat seit dem Umstieg auf Manjaro ebenfalls stabil gearbeitet. – Bis jetzt. Das einzige, was sich bis in den zurück liegenden Tagen geändert hat, ist dass die Veracrypt-Software auf rel 4 upgedatet wurde (über RollingRelease / Pacman). Vor dem Update hat noch alles prima funktioniert.

Soeben ist der Fehler zum zweiten Mal aufgetreten, nachdem ich zwei Tage lang ohne Probleme damit arbeiten konnte:
Es war nur Veracrypt und Thunderbird auf meinem PC gestartet. Das Thunderbird-Profil liegt auf der Veracrypt-Platte. Nur wenige Minuten nach Start schloss sich plötzlich das Thundebrird-Fenster ohne dass eine Fehlermeldung gezeigt wurde. Ich ahnte, dass es wieder der Fehler mit der USB-Platte oder Veracrypt selbst sein könnte und versuchte, per Dateimanager auf die Veracrypt-Platte zuzugreifen. Dies misslang, weil sie offensichtlich nicht mehr gemountet war. Die LED der Festplatte im Gehäuse leuchtet aber und über Gparted konnte ich das Volume sehen – natürlich nicht gemountet.
Veracrypt zeigte in seinem Programmfenster Normalität eines gemounteten Volumes, das ich dort auch dismounten konnte, ohne dass es zu Fehlermeldungen kam. Nach einem Neustart von Veracrypt konnte ich das USB-Volume problemlos mounten und über den Dateimanager zugreifen, als wäre nichts geschehen.

Vor und während der Disconnect auftrat, habe ich die Platte und das USB-Kabel nicht berührt, bewegt usw. Sie wird an dem USB-Anschluss betrieben, wo ich sie schon seit über 1 Jahr dran habe. An diesem Anschluss hatte ich ab und zu auch mal andere Platten angesteckt und nie Probleme gehabt. Auch andere USB-Geräte machen an diesem PC keine Schwierigkeiten, sodass ich die Hardware (vor etwas über 1 Jahr von mir selbst zusammen gebaut) als zuverlässig sehen darf. – Ebenfalls sind am System keine gravierenden Änderungen vorgenommen worden, die mit dem Veracrypt / Disconnect-Problem in Verbindung gebracht werden können.

Mein Verdacht ist, dass der Fehler durch IO-Zugriffe auf das Volume provoziert wird, während der Disconnect auch über Stunden hinweg nicht vorkam, wenn kein Programm darauf zugriff, das Volume aber gemountet war.

Da ich mich als Linux-Anfänger sehe, kenne ich zur Fehleranalyse lediglich die Möglichkeit, die beobachteten Vorgänge über dmesg nachzuprüfen. Da nach dem Mounten des Volume bis zum Crash / Disconnect nur sehr wenig zeit vergangen ist, ist der Inhalt von dmesg überschaubar und gut eingrenzbar. Ich habe die entscheidende Passage heraus kopiert und hänge sie hier an.

Fragen:
Sollte ich mal einen Versuch machen, und auf Veracrypt rel 3 downgraden? – Und wenn ja, wie mache ich das?
Wenn ich bei Veracrypt rel 4 bleibe, wie kann ich dann am besten den Fehler finden?
Dateianhänge
Veracrypt-Disconnecting.txt.tar.gz
(2.47 KiB) 33-mal heruntergeladen
Was haben Windows und ein U-Boot gemeinsam? – Sobald man auch nur ein Fenster öffnet, gehen die Probleme los.


Daemon
Forum Gott
Forum Gott
Beiträge: 341
Registriert: Freitag 22. Dezember 2017, 14:17
CPU: 6082
GPU: wtf
Kernel: pre-linux
DE: pre-linux
GPU Treiber: hab keine
Hat sich bedankt: 2 Mal
Danksagung erhalten: 25 Mal

Re: Veracrypt-USB-Volume trennt sich plötzlich von selbst

#2

#2 Beitrag von Daemon »

Hi!

VeraCrypt brauchst du nicht zu downgraden, liegt nicht daran.

Anhand dieser Meldung

Code: Alles auswählen

xhci_hcd 0000:00:14.0: WARN Set TR Deq Ptr cmd failed due to incorrect slot or ep state
wurde ich beim Kernel Bugzilla fündig.
Es ist also ein Kernel Problem, welches schon seit Kernel 4.20.x besteht.

Um das zu umgehen, musst du auf 4.19.X runter.


Themen Author
Clemens
Forum Kenner
Forum Kenner
Beiträge: 163
Registriert: Donnerstag 9. Januar 2020, 18:16
Wohnort: Rottweil
CPU: Intel i5-7400
GPU: nVidia GTX 1650
Kernel: 5.5.19
DE: FXCE
GPU Treiber: Linux / nVidia free
Hat sich bedankt: 44 Mal
Danksagung erhalten: 1 Mal
Kontaktdaten:

Re: Veracrypt-USB-Volume trennt sich plötzlich von selbst

#3

#3 Beitrag von Clemens »

WOW !!! Da wäre ich nie drauf gekommen! Ich danke dir herzlich.

Aber einfach den Kernel downgraden... das zieht einen ganzen Rattenschwanz an Problemen nach sich: Zum Beispiel sind die Oracle VirtualBox Komponenten sehr sensibel und müssen passend zum Kernel installiert sein.

Nachdem endlich alles mit VB läuft, möchte ich da ungern eingreifen. Ich hab zwei Windows-Programme, die bemerkt haben, dass sich der Host (oder die VB-Version) geändert hat und eine neue Lizenzierung forderten. Zudem glaube ich, dass VB nicht das einzige Programm sein wird, dass durch ein Kernel Downgrade Zicken machen wird.
Und schließlich: Die jetzige wegen des Kernel-Problems problematisch gewordene System-Struktur habe ich zusätzlich zum Desktop-PC auch noch auf zwei Laptops, die ich dringend benötige. Auch diese Laptops benötigen den Zugriff auf das USB-Volume und auch diese haben VirtualBox mit Win-7.

Und endlich: Obwohl ich die Veracrypt-Platte schon zig Stunden in meiner Praxis am Laptop laufen hatte, trat dieser Fehler dort noch nie auf. Am Desktop in relativ kurzer Zeit jedoch zwei Mal und zwar seit dem Update von Veracrypt auf rel. 4 – Wenn's der Kernel ist, wieso tritt der Fehler dann am Laptop (bisher) nicht auf?

Ich fand durch Google gerade diesen alten Thread hier: https://bbs.archlinux.org/viewtopic.php?id=230764
Dort trat eine gleiche Fehlermeldung schon mal auf. Und irgendwie hatten die dann eine Lösung dafür. Das Problem tritt in Verbindung mit dem USB-3-Anschluss und dem Treiber xhci_hd auf.
Kann ich nicht einen Parameter setzen, durch den evtl. USB-3 eingeschränkt wird, aber noch funktionsfähig bleibt?
Was haben Windows und ein U-Boot gemeinsam? – Sobald man auch nur ein Fenster öffnet, gehen die Probleme los.


Daemon
Forum Gott
Forum Gott
Beiträge: 341
Registriert: Freitag 22. Dezember 2017, 14:17
CPU: 6082
GPU: wtf
Kernel: pre-linux
DE: pre-linux
GPU Treiber: hab keine
Hat sich bedankt: 2 Mal
Danksagung erhalten: 25 Mal

Re: Veracrypt-USB-Volume trennt sich plötzlich von selbst

#4

#4 Beitrag von Daemon »

Warum der Fehler erst nach einem Update von VeraCrypt auftrat kann dir glaub ich keiner sagen. Evtl. haben die den "Zugriff" auf den Container geändert.
Ich habe den Thread in den betreffenden Bugzilla gelesen, und anscheinend kann man den Fehler weder reproduzieren noch sonstiges.
Bei manchen funktioniert weder WLAN Stick noch normaler USB Stick, bei anderen nur sporadisch irgendwas, dann läuft es mal tagelang, dann geht wieder nichts. Irgendwie ist das alles sehr verzwickt. Kommt auch auf die verbaute Hardware an. Nachvollziehbar ist es aber anscheinend nicht.

Was angeblich funktionieren soll, ist, wenn man an eine USB2 Buchse geht.

Kernel downgrade würde ich nicht machen, eben wegen den angesprochenen "Problemen" die entstehen können, wie z.B. VBox usw.

Dann lieber in den sauren Apfel beissen und erneut mounten, auch wenn es nervt.


Themen Author
Clemens
Forum Kenner
Forum Kenner
Beiträge: 163
Registriert: Donnerstag 9. Januar 2020, 18:16
Wohnort: Rottweil
CPU: Intel i5-7400
GPU: nVidia GTX 1650
Kernel: 5.5.19
DE: FXCE
GPU Treiber: Linux / nVidia free
Hat sich bedankt: 44 Mal
Danksagung erhalten: 1 Mal
Kontaktdaten:

Re: Veracrypt-USB-Volume trennt sich plötzlich von selbst

#5

#5 Beitrag von Clemens »

Habe gerade noch mal streng nachgedacht, ob es einen Unterschied gibt zwischen meinem Laptop und dem Desktop. Und ja, es gibt einen: Um die Anschlüsse des Laptop zu schonen, habe ich dort sämtliche USB-Geräte an einem 7-fach-Hub angeschlossen (USB-3 mit Netzteil), der dann wiederum an einem USB-3-Anschluss des Laptop hängt.

Das wiederum bringt mich auf die Idee, jetzt meine Veracrypt-Platte über einen noch hier herum liegenden USB-3-Hub (mit Netzteil) wahlweise an einen USB-3 oder einen USB-2-Anschluss des Desktop anzuschließen. USB-2 und dessen Langsamkeit wären hier irrelevant, da durch die Verschlüsselung eh nur eine relativ geringe Transferrate erreicht wird.

Meine in zwei anderen Threads diskutierte Lösung, meine Backups auf einer USB-HDD zu erstellen, ist somit auch von diesem Bug betroffen, sodass die Erstellung und die Rücksicherung von Backups über USB-3 unzuverlässig sind!

Ich finde, das ist der HAMMER, dass ein solcher Bug, der elementare Dinge wie die USB-3-Funktion betrifft, auch nach über einem Jahr noch nicht gefixt sind! Es ist nur ein kleiner Trost, dass offensichtlich alle Linux-Distris davon betroffen sind, sofern sie Kernel ab 4.20 einsetzen.


Ein Veracrypt-Volume so unsicher anzubinden, bedeutet ein enormes Risiko. Da brauchen nur paar Bits zu kippen und ich bekomme das Ganze nie wieder entschlüsselt. Und nach jeder Veränderung auf dieser Platte ein Backup zu fahren mit rund 500GB Daten ist auch nicht witzig, zumal dieses Backup dann ebenfalls sicher verschlüsselt sein müsste.


Hab gerade über den 3-er Hub auf USB-3 die Vercrypt-Platte gemountet. dmesg liefert daraufhin:

Code: Alles auswählen

[13847.753403] usb 2-3: new SuperSpeed Gen 1 USB device number 6 using xhci_hcd
[13848.009141] usb 2-3: New USB device found, idVendor=2109, idProduct=8110, bcdDevice=90.91
[13848.009148] usb 2-3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[13848.009151] usb 2-3:[highlight=yellow] Product: USB3.0 Hub [/highlight]            
[13848.009155] usb 2-3: Manufacturer: VIA Labs, Inc.         
[13848.012010] hub 2-3:1.0: USB hub found
[13848.012260] hub 2-3:1.0: 4 ports detected
[13848.129908] usb 1-3: new high-speed USB device number 6 using xhci_hcd
[13848.151729] usb 1-3: New USB device found, idVendor=2109, idProduct=2811, bcdDevice=90.90
[13848.151731] usb 1-3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[13848.151732] usb 1-3: [highlight=yellow]Product: USB2.0 Hub [/highlight]            
[13848.151733] usb 1-3: Manufacturer: VIA Labs, Inc.         
[13848.152728] hub 1-3:1.0: USB hub found
[13848.152915] hub 1-3:1.0: 4 ports detected
[13848.393421] usb 2-3.4: [highlight=yellow]new SuperSpeed Gen 1 USB device number 7 using xhci_hcd[/highlight]
[13848.420001] usb 2-3.4: New USB device found, idVendor=174c, idProduct=5106, bcdDevice=80.00
[13848.420003] usb 2-3.4: New USB device strings: Mfr=2, Product=3, SerialNumber=1
[13848.420005] usb 2-3.4: Product: StoreJet Transcend
[13848.420006] usb 2-3.4: Manufacturer: StoreJet Transcend
[13848.420007] usb 2-3.4: SerialNumber: S318J9EF222271      
[highlight=yellow][13848.421885] usb-storage 2-3.4:1.0:[/highlight] USB Mass Storage device detected
[13848.422090] scsi host7: usb-storage 2-3.4:1.0
[13849.449895] scsi 7:0:0:0: Direct-Access     StoreJet Transcend        0    PQ: 0 ANSI: 6
[13849.450560] sd 7:0:0:0: Attached scsi generic sg8 type 0
[13849.450876] sd 7:0:0:0: [sdh] 1953525168 512-byte logical blocks: (1.00 TB/932 GiB)
[13849.451123] sd 7:0:0:0: [sdh] Write Protect is off
[13849.451128] sd 7:0:0:0: [sdh] Mode Sense: 43 00 00 00
[13849.451385] sd 7:0:0:0: [sdh] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[13849.752924]  sdh: sdh1
[13849.754545] sd 7:0:0:0: [sdh] Attached SCSI disk
[14004.996374] audit: type=1100 audit(1581350204.803:126): pid=10021 uid=1000 auid=1000 ses=2 subj==unconfined msg='op=PAM:authentication grantors=pam_unix,pam_permit acct="clemens" exe="/usr/bin/sudo" hostname=? addr=? terminal=? res=success'
Frage: Ist meine USB-Platte (Transcend) nun über den Hub mit USB-2 oder mit USB-3 angeschlossen?
Was haben Windows und ein U-Boot gemeinsam? – Sobald man auch nur ein Fenster öffnet, gehen die Probleme los.


Themen Author
Clemens
Forum Kenner
Forum Kenner
Beiträge: 163
Registriert: Donnerstag 9. Januar 2020, 18:16
Wohnort: Rottweil
CPU: Intel i5-7400
GPU: nVidia GTX 1650
Kernel: 5.5.19
DE: FXCE
GPU Treiber: Linux / nVidia free
Hat sich bedankt: 44 Mal
Danksagung erhalten: 1 Mal
Kontaktdaten:

Re: Veracrypt-USB-Volume trennt sich plötzlich von selbst

#6

#6 Beitrag von Clemens »

Seit 2 Tagen habe ich meine Veracrypt-Platte und auch weitere USB-Platten über meinen Hub an einen der USB-3-Anschlüsse meines PC angeschlossen und bisher keine Probleme mehr gehabt. Vielleicht verändert der Hub die Timing-Abfolge mancher Signale auf den USB-Leitungen oder aber er kann ein gewisses Timing vorab handhaben, welches sonst von der fehlerhaften Software nicht gelingt.

Dass es ein Timing-Problem sein könnte, wird derzeit im Entwicklerforum diskutiert.

Leider tritt der Fehler des unbeabsichtigten Disconnect ja nur sehr sporadisch auf, weswegen die zuständigen Programmierer ja auch erhebliche Schwierigkeiten haben, ihn zu finden und zu beheben. Ich werde hier aber wieder schreiben, falls das Disconnect trotz Hub nochmal wieder auftritt. In diesem Fall würde ich, um meine verschlüsselten Daten nicht zu gefährden, den USB-3-Hub auf einen USB-2-Anschluss am PC stecken und müsste mit dem niedrigen Datendurchsatz leben zu Gunsten der dann sicher gestellten Stabilität.
Was haben Windows und ein U-Boot gemeinsam? – Sobald man auch nur ein Fenster öffnet, gehen die Probleme los.

Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 1255
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.19
DE: Openbox
GPU Treiber: i915
Hat sich bedankt: 6 Mal
Danksagung erhalten: 200 Mal

Re: Veracrypt-USB-Volume trennt sich plötzlich von selbst

#7

#7 Beitrag von gosia »

Hallo Clemens,
keine Ahnung, ob es was zur Klärung beiträgt oder nicht, also nur zur Kenntnisnahme:
Ich habe ähnliche Probleme mit zwei USB-Ports, allerdings USB-2. Manchmal fällt der eine Port sporadisch aus, das merke ich daran, daß der Mauszeiger sich nicht mehr bewegt, oder wenn ich einen verschlüsselten USB-Stick dran hängen habe, daß ich plötzlich das Passwort neu eingeben muss, so als ob ich den Stick neu eingesteckt hätte. Da dies aber unabhängig von Manjaro passiert (ich benutze hauptsächlich MX-Linux und Artix) habe ich eher an einen Hardwarefehler gedacht, zumal ich einen sehr "preiswerten" Laptop Packard Bell Easy Note TE benutze, also kein 2000 € Gerät wie bei dir ;)
Das kuriose ist eben, daß es manchmal eine Woche lang keine Probleme gibt und dann funktioniert es plötzlich wieder nicht. Also denkt auch mal an Hardware-Probleme, da weiss ich aber nicht, wie man das messen könnte.

viele Grüße gosia


Themen Author
Clemens
Forum Kenner
Forum Kenner
Beiträge: 163
Registriert: Donnerstag 9. Januar 2020, 18:16
Wohnort: Rottweil
CPU: Intel i5-7400
GPU: nVidia GTX 1650
Kernel: 5.5.19
DE: FXCE
GPU Treiber: Linux / nVidia free
Hat sich bedankt: 44 Mal
Danksagung erhalten: 1 Mal
Kontaktdaten:

Re: Veracrypt-USB-Volume trennt sich plötzlich von selbst

#8

#8 Beitrag von Clemens »

Die Schwierigkeiten bei dir müssen dann aber eine andere Ursache haben. Denn der Fehler, der zwischen Kernel und USB-Treiber liegt, bezieht sich bisher nur auf USB-3 und wurde seit 1 Jahr auch so diskutiert.

Auch habe ich keine 2.000 Euro-Maschine, sondern z.B. ein altes Medion Laptop und der Fujitsu ist noch älter.

Du könntest evtl. mal eine USB-Erweiterungskarte einsetzen, die sind relativ günstig. Und dann schauen, ob damit das Problem noch weiterhin auftritt.
Was haben Windows und ein U-Boot gemeinsam? – Sobald man auch nur ein Fenster öffnet, gehen die Probleme los.

Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 1255
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.19
DE: Openbox
GPU Treiber: i915
Hat sich bedankt: 6 Mal
Danksagung erhalten: 200 Mal

Re: Veracrypt-USB-Volume trennt sich plötzlich von selbst

#9

#9 Beitrag von gosia »

Hallo Clemens,
vielen Dank für die Rückmeldung. Aber ich denke auch, daß es bei mir eher ein Hardwareproblem ist. Mein Laptop hat drei USB-Anschlüsse (alle USB-2) und der eine ist ständig mit einem aktiven 5fach-Hub belegt (zumindest zu Hause) und hat keinerlei Probleme. Die anderen zwei wechseln sich immer ab, mal funktionieren alle beide, mal nur der eine und der andere nicht. Merkwürdigerweise auch unterschiedlich, es kommt vor daß ein Anschluss überhaupt kein Gerät mehr erkennt und nach vier Tagen wieder anfängt ordentlich zu arbeiten oder der Anschluss sich eben nur kurzzeitig verabschiedet und nach einer Minute wieder läuft.
Da ich aber nur eine Maus und manchmal einen USB-Stick anschliesse ist das Problem zwar manchmal lästig aber nicht weiter kritisch. Meine Backup-USB-FP hängt, wenn gebraucht immer am 5fach-Hub.
Insofern muss ich mit meinem Mini-Problem nicht noch deinen Thread aufblähen.

viele Grüße gosia


Themen Author
Clemens
Forum Kenner
Forum Kenner
Beiträge: 163
Registriert: Donnerstag 9. Januar 2020, 18:16
Wohnort: Rottweil
CPU: Intel i5-7400
GPU: nVidia GTX 1650
Kernel: 5.5.19
DE: FXCE
GPU Treiber: Linux / nVidia free
Hat sich bedankt: 44 Mal
Danksagung erhalten: 1 Mal
Kontaktdaten:

Re: Veracrypt-USB-Volume trennt sich plötzlich von selbst

#10

#10 Beitrag von Clemens »

Oh, ich hatte nicht zur Kenntnis genommen, dass du einen Laptop hast. Da greift der Tipp mit der Erweiterungskarte natürlich nicht. Aber mit dem Hub hast du ja bereits eine gute Lösung gefunden. Das hätte ich ebenfalls so gelöst.
Ich hatte mal einen alten HP Compaq geschenkt bekommen. Der hatte ebenfalls an den USB-Buchsen Probleme. Vom Vorbesitzer erfuhr ich, dass man eine 5 1/4" Platte mit einem Y-Kabel angeschlossen hatte, statt mit einem Zusatznetzteil. Und dabei muss wohl zumindest ein Anschluss beschädigt worden sein. Und der andere war mechanisch beschädigt durch Haarriss auf der Leiterplatte. Hab ich nachgelötet und dann war's wieder gut. Solche mechanische Beschädigungen können auch temperaturabhängig auftreten, sodass dies eine mögliche Erklärung für die zeitweiligen Ausfälle an deinem Anschluss wäre.

Freundliche Grüße
Clemens
Was haben Windows und ein U-Boot gemeinsam? – Sobald man auch nur ein Fenster öffnet, gehen die Probleme los.


Themen Author
Clemens
Forum Kenner
Forum Kenner
Beiträge: 163
Registriert: Donnerstag 9. Januar 2020, 18:16
Wohnort: Rottweil
CPU: Intel i5-7400
GPU: nVidia GTX 1650
Kernel: 5.5.19
DE: FXCE
GPU Treiber: Linux / nVidia free
Hat sich bedankt: 44 Mal
Danksagung erhalten: 1 Mal
Kontaktdaten:

Re: Veracrypt-USB-Volume trennt sich plötzlich von selbst

#11

#11 Beitrag von Clemens »

Wichtiger Tipp für das USB-Problem:
Seit nunmehr über 10 Tagen habe ich kein Problem mehr mit dem fehlerhaften Trennen eines USB-3 Laufwerks, seitdem ich immer einen USB-3-Hub dazwischen schalte.
Wer also ähnliche Schwierigkeiten hat, hätte hier wahrscheinlich eine Lösung!

Weiterer Hinweis für Experimente:
Ich habe mit einer USB-3 Festplatte experimentiert, deren Controller mit Sicherheit das UASP-Protokoll unterstützt. Bisher hatte ich damit auch keine Trennung, selbst wenn ich sie direkt an den USB-3-Anschluss angesteckt hatte.
Was haben Windows und ein U-Boot gemeinsam? – Sobald man auch nur ein Fenster öffnet, gehen die Probleme los.

Antworten