Wie sieht es eigentlich mit Wayland aus?

Die Manjaro Gnome Edition ist hier die Diskussionsplattform
Antworten
Benutzeravatar

Themen Author
Leon
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 37
Registriert: Donnerstag 20. Dezember 2018, 22:11
CPU: Intel Core i7-7820X
GPU: GeForce GTX 1080 Ti
Kernel: x86_64 Linux 4.19.8-2-MANJARO
DE: KDE 5.52.0 / Plasma 5.14.4
GPU Treiber: Nvidia Driver 415.22
Danksagung erhalten: 2 Mal

Wie sieht es eigentlich mit Wayland aus?

#1

#1 Beitrag von Leon » Sonntag 11. August 2019, 16:05

Guten Tag, und zwar wollte ich mal fragen ob das Manjaro gnome 3.32 mit
Wayland kompatible ist und ob man sich das wirklich installieren sollte?

Wenn Ja, kennst jemand eine gute Anleitung?

liebe gürße

Benutzeravatar

Blueriver
Moderator
Moderator
Beiträge: 1995
Registriert: Donnerstag 19. Mai 2016, 15:49
CPU: AMD Quad Core A8 3,6GHz
GPU: AMD/ATI Radeon R7
Kernel: 5.0
DE: LXQT und XFCE Stable, Testing, Unstable
GPU Treiber: Free
Hat sich bedankt: 6 Mal
Danksagung erhalten: 61 Mal

Re: Wie sieht es eigentlich mit Wayland aus?

#2

#2 Beitrag von Blueriver » Sonntag 11. August 2019, 19:53

Ob Du Wayland nutzen solltest kann/will ich gar nicht sagen, das mußt du am besten selber herausfinden.
Antergos hatte es Standartmäßig, Manjaro hat Standartmäßig X11.


Das Du im Moment X11 nutzt kannst Du mit folgenden Befehl sehen.

Code: Alles auswählen

echo $XDG_SESSION_TYPE
Aber auf Wayland umstellen ist nicht schwer.
Terminal öffnen

Code: Alles auswählen

sudo nano /etc/gdm/custom.conf
eingeben.
Folgende Zeile von

Code: Alles auswählen

WaylandEnable=false
in

Code: Alles auswählen

#WaylandEnable=false
ändern.

Speichern=o
Beenden=x

System neu starten.

Nun kannst Du wieder mit dem Befehl

Code: Alles auswählen

echo $XDG_SESSION_TYPE
sehen das du nun Wayland nutzt.

Benutzeravatar

Themen Author
Leon
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 37
Registriert: Donnerstag 20. Dezember 2018, 22:11
CPU: Intel Core i7-7820X
GPU: GeForce GTX 1080 Ti
Kernel: x86_64 Linux 4.19.8-2-MANJARO
DE: KDE 5.52.0 / Plasma 5.14.4
GPU Treiber: Nvidia Driver 415.22
Danksagung erhalten: 2 Mal

Re: Wie sieht es eigentlich mit Wayland aus?

#3

#3 Beitrag von Leon » Montag 12. August 2019, 14:32

Vielen Dank, allerdings ändert sich nichts, ich habe in beiden fällen + den wert auf true gestellt immernoch x11 stehen

Benutzeravatar

Blueriver
Moderator
Moderator
Beiträge: 1995
Registriert: Donnerstag 19. Mai 2016, 15:49
CPU: AMD Quad Core A8 3,6GHz
GPU: AMD/ATI Radeon R7
Kernel: 5.0
DE: LXQT und XFCE Stable, Testing, Unstable
GPU Treiber: Free
Hat sich bedankt: 6 Mal
Danksagung erhalten: 61 Mal

Re: Wie sieht es eigentlich mit Wayland aus?

#4

#4 Beitrag von Blueriver » Montag 12. August 2019, 14:51

Du brauch nur eine # vorsetzen.
So sollte es dann aussehen.

Code: Alles auswählen

#WaylandEnable=false
Speichern und neu starten.


Falls es immer noch nicht geht poste mal die Ausgabe von

Code: Alles auswählen

cat /etc/gdm/custom.conf

Benutzeravatar

Themen Author
Leon
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 37
Registriert: Donnerstag 20. Dezember 2018, 22:11
CPU: Intel Core i7-7820X
GPU: GeForce GTX 1080 Ti
Kernel: x86_64 Linux 4.19.8-2-MANJARO
DE: KDE 5.52.0 / Plasma 5.14.4
GPU Treiber: Nvidia Driver 415.22
Danksagung erhalten: 2 Mal

Re: Wie sieht es eigentlich mit Wayland aus?

#5

#5 Beitrag von Leon » Montag 12. August 2019, 18:29

Geht ja leider trotzdem nicht.

Code: Alles auswählen

# GDM configuration storage

[daemon]
AutomaticLogin=leon
AutomaticLoginEnable=False
# Uncoment the line below to force the login screen to use Xorg
#WaylandEnable=false

[security]

[xdmcp]

[chooser]

[debug]
# Uncomment the line below to turn on debugging
#Enable=true



Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 850
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.15
DE: Openbox
GPU Treiber: i915
Hat sich bedankt: 6 Mal
Danksagung erhalten: 100 Mal

Re: Wie sieht es eigentlich mit Wayland aus?

#6

#6 Beitrag von gosia » Montag 12. August 2019, 18:53

Hallo Blueriver,
Blueriver hat geschrieben:
Montag 12. August 2019, 14:51
Du brauch nur eine # vorsetzen.
So sollte es dann aussehen.

Code: Alles auswählen

#WaylandEnable=false
Vielleicht habe ich das falsch in der Erinnerung, aber musste man nicht ausdrücklich auf true setzen?

Code: Alles auswählen

WaylandEnable=true
viele Grüße gosia

Benutzeravatar

Blueriver
Moderator
Moderator
Beiträge: 1995
Registriert: Donnerstag 19. Mai 2016, 15:49
CPU: AMD Quad Core A8 3,6GHz
GPU: AMD/ATI Radeon R7
Kernel: 5.0
DE: LXQT und XFCE Stable, Testing, Unstable
GPU Treiber: Free
Hat sich bedankt: 6 Mal
Danksagung erhalten: 61 Mal

Re: Wie sieht es eigentlich mit Wayland aus?

#7

#7 Beitrag von Blueriver » Montag 12. August 2019, 19:16

gosia hat geschrieben:
Montag 12. August 2019, 18:53
Vielleicht habe ich das falsch in der Erinnerung, aber musste man nicht ausdrücklich auf true setzen?

Code: Alles auswählen

WaylandEnable=true
Bei mir funktioniert es auch nur mit der #.
Dateianhänge
1.png
1.png (111.08 KiB) 131 mal betrachtet

Benutzeravatar

Themen Author
Leon
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 37
Registriert: Donnerstag 20. Dezember 2018, 22:11
CPU: Intel Core i7-7820X
GPU: GeForce GTX 1080 Ti
Kernel: x86_64 Linux 4.19.8-2-MANJARO
DE: KDE 5.52.0 / Plasma 5.14.4
GPU Treiber: Nvidia Driver 415.22
Danksagung erhalten: 2 Mal

Re: Wie sieht es eigentlich mit Wayland aus?

#8

#8 Beitrag von Leon » Montag 12. August 2019, 20:22

Ich habe es mit # Auskommentiert, ich habe auf true gesetzt, geht leider nicht.

Liegt das vielleicht daran das ich eine Nvidia Grafikkarte habe?

Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 850
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.15
DE: Openbox
GPU Treiber: i915
Hat sich bedankt: 6 Mal
Danksagung erhalten: 100 Mal

Re: Wie sieht es eigentlich mit Wayland aus?

#9

#9 Beitrag von gosia » Montag 12. August 2019, 21:51

Hallo Leon,
ich habe es jetzt mal in einer VM ausprobiert. Leider habe ich dort nur Plasma, kann also nur dazu was sagen.
Ich habe plasma-wayland-session installiert und hatte dann im Displaymanager SDDM die Wahl, ob ich mit X11 oder Wayland starten wollte. Das hat auch funktioniert, ohne daß ich irgendwas in einer conf-Datei ändern musste.
Nun kannst Du für Gnome kein plasma-wayland-session installieren, aber es gibt auch ein Paket xorg-server-xwayland, kannst Du ja mal ausprobieren.

viele Grüße gosia

Benutzeravatar

Themen Author
Leon
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 37
Registriert: Donnerstag 20. Dezember 2018, 22:11
CPU: Intel Core i7-7820X
GPU: GeForce GTX 1080 Ti
Kernel: x86_64 Linux 4.19.8-2-MANJARO
DE: KDE 5.52.0 / Plasma 5.14.4
GPU Treiber: Nvidia Driver 415.22
Danksagung erhalten: 2 Mal

Re: Wie sieht es eigentlich mit Wayland aus?

#10

#10 Beitrag von Leon » Freitag 16. August 2019, 15:03

Also der xorg-server-xwayland ist bereits installiert, ich frage mich was ich echt falsch gemacht habe.
Auf einer VM läuft der ganze spuck ja, selbst auf mein NAS Server läuft Wayland ohne weiteres.

Das Problem scheint echt mit Nvidia zu sein.

Nachtrag:
Ich habe gelesen das man noch in der datei /usr/lib/udev/rules.d/64-gdm.rules
den Eintrag DRIVER==nvidia auskommentieren soll, nur auch das hilft leider nicht wirklich.

NVIDIA (WAYLAND)
https://rpmfusion.org/Howto/NVIDIA#Wayland

Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 850
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.15
DE: Openbox
GPU Treiber: i915
Hat sich bedankt: 6 Mal
Danksagung erhalten: 100 Mal

Re: Wie sieht es eigentlich mit Wayland aus?

#11

#11 Beitrag von gosia » Freitag 16. August 2019, 15:39

Hallo Leon,
Leon hat geschrieben:
Freitag 16. August 2019, 15:03
Das Problem scheint echt mit Nvidia zu sein.
Nun ja, es läuft schon mit NVIDIA, aber es braucht zusätzlich EGLStreams-API,
https://wiki.archlinux.org/index.php/Wa ... quirements
Und wenn ich das richtig verstehe, handelt es sich dabei um das Paket egl-wayland.

viele Grüße gosia

Antworten