WLan unzuverlässige Anbindung

Support rund um die Manjaro KDE Edition findet man in dieser Kategorie!
Antworten

Themen Author
Benutzer 797 gelöscht

WLan unzuverlässige Anbindung

#1

#1 Beitrag von Benutzer 797 gelöscht » Sonntag 20. Januar 2019, 18:44

Hallo alle,

(m)einen schließe ich über Wlan ans I-Net. Auf meinem ist das aktuelle Manjaro Stable installiert. Eben mal testweise meinen Dell Latitude E5430 gestartet und Wlan blieb stumm. Ich klicke auf Wlan in der Taskleiste und mein Wlan ist gelistet. Ich klicke auf verbinden und auch nach dem zweiten Anlauf kein Wlan. Klicke ich erneut auf verbinden, wird nach dem Passwort gefragt. Da ich mir noch nicht anders behelfen kann, starte ich den Läppi neu. Danach klappt es meistens automatische nach dem dritten "Einwählversuch". Dann muss ich ca. 30(?) Sekunden warten, bis ich surfen kann. Selten aber passiert auch, dauert es vielleicht 10 Sekunden und ich kann loslegen.

Bei der Einrichtung habe ich nur meine Zugangsdaten eingeben. Noch darauf geachtet, dass der Verkehr auf WPA2 läuft. Was geht da (nicht) ab?

Danke für Tipps

snoojo

Benutzeravatar

Blueriver
Moderator
Moderator
Beiträge: 1847
Registriert: Donnerstag 19. Mai 2016, 15:49
CPU: AMD Quad Core A8 3,6GHz
GPU: AMD/ATI Radeon R7
Kernel: 5.0
DE: LXQT und XFCE Stable, Testing, Unstable
GPU Treiber: Free
Hat sich bedankt: 3 Mal
Danksagung erhalten: 47 Mal

Re: WLan unzuverlässige Anbindung

#2

#2 Beitrag von Blueriver » Sonntag 20. Januar 2019, 19:07

Du kannst es ja mal mit wicd probieren.
Wicd funktioniert etwa so wie der NetworkManager und startet zudem meist schneller.

Wicd installieren

Code: Alles auswählen

sudo pacman -S wicd wicd-gtk
NetworkManager stoppen und deaktivieren

Code: Alles auswählen

sudo systemctl stop NetworkManager
sudo systemctl disable NetworkManager
Wicd aktivieren und starten.

Code: Alles auswählen

sudo systemctl enable wicd
sudo systemctl start wicd
Nun sollte Wicd im Menü zu sehen, evtl. PC neu starten.
Wicd öffnen und dein WLAN-Netzwerk auswählen und wo Schlüssel steht dein Netzwerkschlüssel eingeben.


Falls es nicht hilft oder es dir nicht gefällst kannst du ja ganz schnell wieder zum NetworkManager wechseln.

Code: Alles auswählen

sudo systemctl stop wicd
sudo systemctl disable wicd
sudo systemctl enable NetworkManager
sudo systemctl start NetworkManager


Themen Author
Benutzer 797 gelöscht

Re: WLan unzuverlässige Anbindung

#3

#3 Beitrag von Benutzer 797 gelöscht » Dienstag 22. Januar 2019, 16:47

Jetzt erst mal von mir ein schriftliches: Danke!

Momentan läuft KDEs Networker bestens und ich muss ein KDE-Fanboy sein. Darum probiere ich es weiterhin mit dem eingebauten; und wenn der dann meine Schmerzgrenze austestet, teste ich deine Lösung aus.

Grüße

snoojo


Themen Author
Benutzer 797 gelöscht

Re: WLan unzuverlässige Anbindung

#4

#4 Beitrag von Benutzer 797 gelöscht » Samstag 26. Januar 2019, 11:50

So, wicd installiert, gestartet und … durchgefallen. Auch mit wicd tauchen dieselben Probleme auf. Immerhin gibt wicd zwischendurch Meldungen aus, was es macht oder auch nicht. Auch unter wicd dauert die Legitimierung teilweise sehr lange (30 Sekunden, 1 Minute?) und anschließend heißt es falsches Passwort. Mal klappt auch mit wicd die Anmeldung, mal halt nicht. Das Passwort hatte ich für wicd aus dem Networkmanager mit C&P übernommen. Am Passwort liegt's also net.

Wie nun weiter?

snoojo

P.s.: Trotz artigem Abarbeitens obiger Befehle ist auch der Networkmanager aktiv.

Benutzeravatar

Blueriver
Moderator
Moderator
Beiträge: 1847
Registriert: Donnerstag 19. Mai 2016, 15:49
CPU: AMD Quad Core A8 3,6GHz
GPU: AMD/ATI Radeon R7
Kernel: 5.0
DE: LXQT und XFCE Stable, Testing, Unstable
GPU Treiber: Free
Hat sich bedankt: 3 Mal
Danksagung erhalten: 47 Mal

Re: WLan unzuverlässige Anbindung

#5

#5 Beitrag von Blueriver » Samstag 26. Januar 2019, 16:00

snoojo hat geschrieben:
Samstag 26. Januar 2019, 11:50
P.s.: Trotz artigem Abarbeitens obiger Befehle ist auch der Networkmanager aktiv.
Du meinst sicher das das Applet noch in der Leiste zu sehen ist. Das Applet bleibt auch wenn der NetworkManager nicht mehr aktiviert ist.
Entweder entfernst du es in der Leisteneinstellung oder entfernst einfach das Paket

Code: Alles auswählen

network-manager-applet

Oder meinst du wirklich das die Netzwerkverbindung noch über den NetworkManager geht?


Themen Author
Benutzer 797 gelöscht

Re: WLan unzuverlässige Anbindung

#6

#6 Beitrag von Benutzer 797 gelöscht » Samstag 26. Januar 2019, 16:15

Richtig, das Applet bleibt in der Leiste und nimmt auch seine Arbeit auf, bis wicd gestartet wird, den Networkmanager ausschaltet und anschließend es vielleicht schafft, selbst die WLAN-Vwebindung herzustellen.

Bisher gehe ich davon aus, dass es ein Softwareproblem auf meinem Läppi, Dell e5430, ist. Mit meinem P9 klappt es bestens.

snoojo

Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 761
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.15
DE: Openbox
GPU Treiber: i915
Hat sich bedankt: 5 Mal
Danksagung erhalten: 78 Mal

Re: WLan unzuverlässige Anbindung

#7

#7 Beitrag von gosia » Samstag 26. Januar 2019, 16:28

Hallo snoojo,
snoojo hat geschrieben:
Samstag 26. Januar 2019, 16:15
das Applet bleibt in der Leiste und nimmt auch seine Arbeit auf, bis wicd gestartet wird, den Networkmanager ausschaltet
Du solltest auf jeden Fall den Networkmanager abschalten, oder noch besser ganz deinstallierien, sonst gibt es Ärger
"Warning: Running multiple network managers will cause problems, so it is important to disable all other network management daemons."
https://wiki.archlinux.org/index.php/wi ... ng_started

viele Grüße gosia


Themen Author
Benutzer 797 gelöscht

Re: WLan unzuverlässige Anbindung

#8

#8 Beitrag von Benutzer 797 gelöscht » Samstag 26. Januar 2019, 16:47

O.k., muss ich wohl probieren. Bisher scheint wicd dasselbe Problem wie der Networkmanager zu haben.

snoojo

Benutzeravatar

LQ
Forum Kenner
Forum Kenner
Beiträge: 172
Registriert: Donnerstag 5. Januar 2017, 05:43
GPU:
Kernel:
DE:
GPU Treiber:
Hat sich bedankt: 2 Mal
Danksagung erhalten: 20 Mal

Re: WLan unzuverlässige Anbindung

#9

#9 Beitrag von LQ » Samstag 26. Januar 2019, 23:25

snoojo hat geschrieben:
Samstag 26. Januar 2019, 16:47
O.k., muss ich wohl probieren. Bisher scheint wicd dasselbe Problem wie der Networkmanager zu haben.
Wenn du immer noch Probleme hast;
siehe WLAN Hintergründe und die Kommentare dazu.

MfG


Themen Author
Benutzer 797 gelöscht

Re: WLan unzuverlässige Anbindung

#10

#10 Beitrag von Benutzer 797 gelöscht » Sonntag 27. Januar 2019, 07:43

@LQ,

das las sich interessant. Beim Einrichten meiner 7490 schaute ich mir die Kanalbelegung an und freute mich, dass ich auf das 5 GHz Band ausweichen konnte.

Unter wicd bekam ich den Hinweis, dass auch dort die Legimitation nach langen Warten scheitert, weil das Passwort falsch sein soll. Spätestens am Tag darauf klappt das Anmelden beim ersten Versuch und geht schnell dazu.

snoojo

P.s.: In diesem BLog heißt es, dass ein Router erstmal hört, ob auf seinem Kanal andere senden oder nicht. Was nun, wenn ich oder andere auf diesem Kanal GB saugen?

Antworten