Kein Compositor nach letztem Update Thema ist als GELÖST markiert

Support rund um die Manjaro KDE Edition findet man in dieser Kategorie!
Antworten
Benutzeravatar

Themen Author
steffen
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 11
Registriert: Mittwoch 18. Mai 2016, 17:09
Wohnort: Oberfranken
CPU: unterschiedlich
GPU: unterschiedlich
Kernel: LTS
Desktop-Variante: KDE
GPU Treiber: freier Treiber
Hat sich bedankt: 2 Mal

Kein Compositor nach letztem Update

#1

Beitrag von steffen »

Hallo,

beim letzten Update des Systems hat es bei KDE etwas zerschossen.
Zunächst hängte sich der Rechner beim Aktualisieren eines Programms auf. Es gab keine Reaktionen auf Maus oder Tastatur, ich musste den Rechner hart abschalten. Beim Neustart das befürchtete Bild, keine Kernel gefunden. Das Problem konnte ich mit einem Installationsstick und chroot -a usw. reparieren. Aber nach dem Anmelden das nächste Problem: KDE hat keine Fensterrahmen mehr. Wenn ich in die Einstellungen gehe, kommt bei Virtuelle Arbeitsflächen die Meldung im Anhang.

Gibt es eine Möglichkeit, Compositor wieder zu installieren.
Ausgabe von inxi -F

Code: Alles auswählen

System:
  Host: igelchen2 Kernel: 6.1.62-1-MANJARO arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.27.9 Distro: Manjaro Linux
Machine:
  Type: Laptop System: Acer product: Swift SF113-31 v: V1.08
    serial: <superuser required>
  Mobo: APL model: ASAHI_AP_S v: V1.08 serial: <superuser required>
    UEFI: INSYDE v: 1.08 date: 11/22/2017
Battery:
  ID-1: BAT0 charge: 40.6 Wh (99.0%) condition: 41.0/43.0 Wh (95.4%)
CPU:
  Info: quad core model: Intel Pentium N4200 bits: 64 type: MCP cache:
    L2: 2 MiB
  Speed (MHz): avg: 801 min/max: 800/2500 cores: 1: 800 2: 798 3: 807 4: 800
Graphics:
  Device-1: Intel Apollo Lake [HD Graphics 505] driver: i915 v: kernel
  Device-2: Chicony Integrated HD WebCam driver: uvcvideo type: USB
  Display: x11 server: X.Org v: 21.1.9 driver: X: loaded: modesetting
    dri: iris gpu: i915 resolution: 1920x1080
  API: EGL v: 1.5 drivers: iris,swrast platforms: gbm,x11,surfaceless,device
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.1.9-manjaro1.1
    renderer: Mesa Intel HD Graphics 505 (APL 3)
  API: Vulkan v: 1.3.269 drivers: intel surfaces: xcb,xlib
Audio:
  Device-1: Intel Celeron N3350/Pentium N4200/Atom E3900 Series Audio Cluster
    driver: snd_hda_intel
  API: ALSA v: k6.1.62-1-MANJARO status: kernel-api
  Server-1: PulseAudio v: 16.1 status: active
Network:
  Device-1: Intel Wireless 7265 driver: iwlwifi
  IF: wlp2s0 state: up mac: 74:e5:f9:6c:37:39
Bluetooth:
  Device-1: Intel Bluetooth wireless interface driver: btusb type: USB
  Report: rfkill ID: hci0 state: up address: see --recommends
Drives:
  Local Storage: total: 58.24 GiB used: 25.66 GiB (44.1%)
  ID-1: /dev/mmcblk0 vendor: HP model: DF4064 size: 58.24 GiB
Partition:
  ID-1: / size: 56.74 GiB used: 25.66 GiB (45.2%) fs: ext4 dev: /dev/mmcblk0p2
  ID-2: /boot/efi size: 299.4 MiB used: 312 KiB (0.1%) fs: vfat
    dev: /dev/mmcblk0p1
Swap:
  ID-1: swap-1 type: file size: 512 MiB used: 302.5 MiB (59.1%)
    file: /swapfile
Schon mal Danke für Eure Hilfe.

Gruß
Steffen
Dateianhänge
kde.jpg
kde.jpg (98.51 KiB) 310 mal betrachtet
Benutzeravatar

country
Forum Held
Forum Held
Beiträge: 998
Registriert: Samstag 16. Oktober 2021, 02:12
CPU: Ryzen 7 3700X
GPU: RTX 3060Ti
Kernel: up-to-date
Desktop-Variante: Cinnamon
GPU Treiber: RTX 3060Ti
Hat sich bedankt: 113 Mal
Danksagung erhalten: 186 Mal

Re: Kein Compositor nach letztem Update

#2

Beitrag von country »

Ist die inxi Ausgabe von einem live Stick gemacht? Ist zufällig deine Festplatte voll?
Versuch mal deinen Grafiktreiber neu zu installieren. https://wiki.manjaro.org/index.php/Conf ... hics_Cards
Ist deine System aktuell?

Code: Alles auswählen

pamac upgrade -a
Benutzeravatar

Themen Author
steffen
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 11
Registriert: Mittwoch 18. Mai 2016, 17:09
Wohnort: Oberfranken
CPU: unterschiedlich
GPU: unterschiedlich
Kernel: LTS
Desktop-Variante: KDE
GPU Treiber: freier Treiber
Hat sich bedankt: 2 Mal

Re: Kein Compositor nach letztem Update

#3

Beitrag von steffen »

country hat geschrieben: Freitag 17. November 2023, 20:24 Ist die inxi Ausgabe von einem live Stick gemacht?
Nein, vom defekten KDE-Rechner
country hat geschrieben: Freitag 17. November 2023, 20:24 Ist zufällig deine Festplatte voll?
Nein. Ca. 28GB frei.
country hat geschrieben: Freitag 17. November 2023, 20:24 Ist deine System aktuell?
Ja.
country hat geschrieben: Freitag 17. November 2023, 20:24 pamac upgrade -a
sagt: nix zu tun

Aber mhwd -l -d sagt

Code: Alles auswählen

  > INSTALLED:

   NAME:        video-linux
   ATTACHED:    PCI
   VERSION:     2018.05.04
   INFO:        Standard open source drivers.
   PRIORITY:    2
   FREEDRIVER:  true
   DEPENDS:     -
   CONFLICTS:   -
   CLASSIDS:    0300 0380 0302
   VENDORIDS:   1002 8086 10de



  > AVAILABLE:

   NAME:        video-linux
   ATTACHED:    PCI
   VERSION:     2018.05.04
   INFO:        Standard open source drivers.
   PRIORITY:    2
   FREEDRIVER:  true
   DEPENDS:     -
   CONFLICTS:   -
   CLASSIDS:    0300 0380 0302
   VENDORIDS:   1002 8086 10de

   NAME:        video-modesetting
   ATTACHED:    PCI
   VERSION:     2020.01.13
   INFO:        X.org modesetting video driver.
   PRIORITY:    1
   FREEDRIVER:  true
   DEPENDS:     -
   CONFLICTS:   -
   CLASSIDS:    0300
   VENDORIDS:   *

   NAME:        video-vesa
   ATTACHED:    PCI
   VERSION:     2017.03.12
   INFO:        X.org vesa video driver.
   PRIORITY:    0
   FREEDRIVER:  true
   DEPENDS:     -
   CONFLICTS:   -
   CLASSIDS:    0300
   VENDORIDS:   *
Wie kann ich video-modesetting und video-mesa installieren? Brauche ich das?
Benutzeravatar

country
Forum Held
Forum Held
Beiträge: 998
Registriert: Samstag 16. Oktober 2021, 02:12
CPU: Ryzen 7 3700X
GPU: RTX 3060Ti
Kernel: up-to-date
Desktop-Variante: Cinnamon
GPU Treiber: RTX 3060Ti
Hat sich bedankt: 113 Mal
Danksagung erhalten: 186 Mal

Re: Kein Compositor nach letztem Update

#4

Beitrag von country »

Schau mal unter Einstellung Display - Monitor -> compositor ob da alles stimmt.
Benutzeravatar

Themen Author
steffen
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 11
Registriert: Mittwoch 18. Mai 2016, 17:09
Wohnort: Oberfranken
CPU: unterschiedlich
GPU: unterschiedlich
Kernel: LTS
Desktop-Variante: KDE
GPU Treiber: freier Treiber
Hat sich bedankt: 2 Mal

Re: Kein Compositor nach letztem Update

#5

Beitrag von steffen »

Schaut normal aus.
Dateianhänge
kde3.png
kde3.png (376.38 KiB) 219 mal betrachtet
Benutzeravatar

Themen Author
steffen
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 11
Registriert: Mittwoch 18. Mai 2016, 17:09
Wohnort: Oberfranken
CPU: unterschiedlich
GPU: unterschiedlich
Kernel: LTS
Desktop-Variante: KDE
GPU Treiber: freier Treiber
Hat sich bedankt: 2 Mal

Re: Kein Compositor nach letztem Update

#6

Beitrag von steffen »

Gelöst!

KWin wurde beim Update nicht installiert. Ich habe es rausgefunden, als ich im Infozentrum die Einträge für Grafik anschauen wollte. Da stand, dass KWin nicht vorhanden ist. Ich habe es mit

Code: Alles auswählen

sudo pamac install kwin
installiert. Jetzt funktioniert wieder alles.

Danke allen, die sich Gedanken zur Lösung meines Problems gemacht habe.
Benutzeravatar

country
Forum Held
Forum Held
Beiträge: 998
Registriert: Samstag 16. Oktober 2021, 02:12
CPU: Ryzen 7 3700X
GPU: RTX 3060Ti
Kernel: up-to-date
Desktop-Variante: Cinnamon
GPU Treiber: RTX 3060Ti
Hat sich bedankt: 113 Mal
Danksagung erhalten: 186 Mal

Re: Kein Compositor nach letztem Update

#7

Beitrag von country »

Seltsam aber Hauptsache es geht wieder.
Das sieht man in /var/log/pacman.log wenn was nicht installiert wurde oder fehlgeschlagen ist.
Antworten