Update schlägt fehl weil Abhängigkeiten nicht erfüllt sind Thema ist als GELÖST markiert

Hilfe bei Updates und Installtion von neuen Paketen bzw. Programmen.
Antworten

Themen Author
Fansurfer
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 24
Registriert: Montag 27. Dezember 2021, 09:19
CPU: Intel Pentium G4600
GPU: NVIDIA GeForce GTX 1050 Ti
Kernel: 5.18.17-1-MANJARO
Desktop-Variante: Xfce 4.16
GPU Treiber: NVIDIA 515.65.01
Danksagung erhalten: 1 Mal

Update schlägt fehl weil Abhängigkeiten nicht erfüllt sind

#1

Beitrag von Fansurfer »

Hallo,
mein letzte Update von Manjaro liegt ca. 14 Tage zurück. Heute wollte ich dies durchführen, aber es funktioniert nicht.

Code: Alles auswählen

sudo pacman -Syu
[sudo] Passwort für xxx: 
:: Paketdatenbanken werden synchronisiert …
 core ist aktuell
 extra ist aktuell
 community ist aktuell
 multilib ist aktuell
:: Vollständige Systemaktualisierung wird gestartet …
:: at-spi2-atk durch extra/at-spi2-core ersetzen? [J/n] j
:: atk durch extra/at-spi2-core ersetzen? [J/n] j
Abhängigkeiten werden aufgelöst …
Nach in Konflikt stehenden Paketen wird gesucht …
Fehler: Vorgang konnte nicht vorbereitet werden (Kann Abhängigkeiten nicht erfüllen)
:: Installation von nvidia-utils (520.56.06-2) verletzt Abhängigkeit »nvidia-utils=515.65.01«, benötigt von linux518-nvidia
Wie kann das gelöst werden?
Benutzeravatar

zompel
Forum Gott
Forum Gott
Beiträge: 419
Registriert: Montag 9. Dezember 2019, 19:52
Wohnort: Essen, NRW
CPU: Intel Core i9-9900KF
GPU: nVidia GeForce RTX 2070
Kernel: 5.15 LTS
Desktop-Variante: Gnome
GPU Treiber: nVidia
Hat sich bedankt: 13 Mal
Danksagung erhalten: 71 Mal

Re: Update schlägt fehl weil Abhängigkeiten nicht erfüllt sind

#2

Beitrag von zompel »

Fansurfer hat geschrieben: Dienstag 22. November 2022, 19:08 :: Installation von nvidia-utils (520.56.06-2) verletzt Abhängigkeit »nvidia-utils=515.65.01«, benötigt von linux518-nvidia
Diese Ausgabe lässt mich vermuten, dass du noch den Kernel 5.18 benutzt.
Da er längst EOL ist (selbst 5.19 ist schon EOL) würde ich als erstes vorher den Kernel aktualisieren.
Entweder nimmst du den 5.15 LTS oder den 6.0.
Den Kernel wechsel ich immer über das Tool "Manjaro-Settings" (oder so ähnlich... bin gerade nicht zu Hause)

Themen Author
Fansurfer
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 24
Registriert: Montag 27. Dezember 2021, 09:19
CPU: Intel Pentium G4600
GPU: NVIDIA GeForce GTX 1050 Ti
Kernel: 5.18.17-1-MANJARO
Desktop-Variante: Xfce 4.16
GPU Treiber: NVIDIA 515.65.01
Danksagung erhalten: 1 Mal

Re: Update schlägt fehl weil Abhängigkeiten nicht erfüllt sind

#3

Beitrag von Fansurfer »

Ich habe es gelöst in dem ich die Nvidia Pakete deinstalliert habe. Dann konnte ich ein Update machen. Anschließend wieder die Nvidia Pakete wieder installiert.
Ich werde mal schauen was für ein Kernel ich eingesetzt habe und ggf. den ändern.
Antworten

Zurück zu „Manjaro Linux Paketverwaltung und Kommandozeile“