Probleme mit Einbinden neuer Disk per LUKS/BTRFS

Probleme bei der Installation von Hardware unter Manjaro Linux? Hier wird geholfen.</span
Antworten

Themen Author
Günther
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 59
Registriert: Mittwoch 23. Juni 2021, 00:19
CPU: AMD Ryzen 7 5700G
GPU: AMD Radeon Graphics (iGPU)
Kernel: Manjaro, actual
Desktop-Variante: KDE Plasma
GPU Treiber: amdfree
Hat sich bedankt: 5 Mal
Danksagung erhalten: 7 Mal

Probleme mit Einbinden neuer Disk per LUKS/BTRFS

#1

Beitrag von Günther »

Hallo zusammen!

Ich habe mir eine "Western Digital Ultrastar DC HC560 20TB" (baugleich: "Western Digital WD Gold 20TB") gekauft.

Folgendes Problem: Ich kann sie nicht (automatisch) über LUKS/BTRFS einbinden.

Mehrere versuchte Szenarien erwähne ich hier, da ich sehr Vieles probiert habe und auch mehrfach wiederholt habe und manchmal andere Ergebnisse herauskamen:


1. Formatiert über Disks/Laufwerke (Gnome): Formatiert wird ein LUKS2-Verschlüsselung, die eine BTRFS-Partition freigibt.

Option a.) Anschließend lässt sich die Partiation nicht mounten, es kommt:

Code: Alles auswählen

Fehler beim Einhängen der Dateisystems [...] wrong fs type, bad option, bad superblock on /dev/mapper/luks[...] missing codepage or helper prog or other error (udisk-error-quark, 0)
Option b.) Die Partition habe ich auch einmal gemountet bekommen, aber nur per Gnome Disk (kA wieso)

Aber so oder so war der Mount mit crypttab/fstab-Eintrag nicht möglich, mehrfach probiert. Ergebnis:

Code: Alles auswählen

Failed to mount /xyz/
Dependency failed for local system
Siehe dazu die Screenshots.


2. Formatiert über KDE-Partitionsverwaltung, wo LUKS1+BTRFS verwendet wird. Hier dasselbe Problem. Wobei ich hier kein Problem gehabt habe, es über das Frontend der KDE-Partitionsverwaltung die Festplatte einzubinden. Aber über den crypttab/fstab-Eintrag funktioniert es hier auch nicht.


Zur Info:

Ich habe über die letzten 3 Jahre nie solch ein Problem gehabt und mehrere Platten problemlos auf diese Weise eingebunden. Ich denke, ich weiß was ich tue. Aber vielleicht übersehe ich dies mal etwas?

Ich habe die Festplatte sowohl über SATA, als auch über einen SATA-to-USB-Adapter probiert einzubinden/einzurichten. Mehrfach alles probiert. Ich habe auch kreuz und quer im Netz nach meinem Problem gesucht und ehrlichgesagt verzweifle ich :(

Was wichtig ist: Die erste Platte, die ich geliefert bekam, war fehlerhaft, sie drehte nicht hoch. Habe eine neue bekommen. Gibt es da eventuell massive Qualitätsprobleme? Ist dass das Problem? Ich denke nicht, was denkt ihr?

Erwähnenswert ist vielleicht, dass die Festplatte einen Teil ihrer Spur-Informationen auf einer Mini-SSD, glaube 64 GB, zwischenspeichert. Aber das sollte die Firmware klären, das sollte die Benutzer-hardware-Schicht nicht betreffen, denke ich.

Was ich auch komisch fand, ich habe eine andere funktionerende LUKS/BTRFS Disk also solche per "dd /sdFUNKTIONIERD auf /sdNEU" kopiert, dabei kam es zu unterirdischen Transferraten ~10MB/s und die Festplatte ist ständig eingeschlafen und hat wieder hochgedreht. Das ging 30 Minuten so, bis ich das abgebrochen habe. Habe nicht verstanden, wieso?


Hier ein "dmesg":

Code: Alles auswählen

[36206.709806] BTRFS info (device dm-8): flagging fs with big metadata feature
[36206.709812] BTRFS info (device dm-8): enabling disk space caching
[36206.709813] BTRFS error (device dm-8): cannot disable free space tree
[36206.709833] BTRFS error (device dm-8): open_ctree failed
Hier Versuch, die "defekte" BTRFS-Partition zu Checken auf Fehler:

Code: Alles auswählen

sudo btrfs check /dev/mapper/luks-458323f0-18a4-4928-b01d-27e02d06f2e8

Opening filesystem to check...
Checking filesystem on /dev/mapper/luks-458323f0-18a4-4928-b01d-27e02d06f2e8
UUID: 2575c981-8112-497b-8a24-ee2f9850ce29
[1/7] checking root items
[2/7] checking extents
[3/7] checking free space tree
[4/7] checking fs roots
[5/7] checking only csums items (without verifying data)
[6/7] checking root refs
[7/7] checking quota groups skipped (not enabled on this FS)
found 147456 bytes used, no error found
total csum bytes: 0
total tree bytes: 147456
total fs tree bytes: 32768
total extent tree bytes: 16384
btree space waste bytes: 139609
file data blocks allocated: 0
 referenced 0

VIelen und lieben Dank fürs Lesen, vielleicht hat einer eine Idee! :) ;)
Dateianhänge
2022-05-15_14-42.png
2022-05-15_14-42.png (50.29 KiB) 449 mal betrachtet
2022-05-26_22-22.png
2022-05-26_22-22.png (183.47 KiB) 449 mal betrachtet
2022-05-26_22-24.png
2022-05-26_22-24.png (895.79 KiB) 449 mal betrachtet

Siliziumfuchs
Forum Kenner
Forum Kenner
Beiträge: 105
Registriert: Mittwoch 23. Februar 2022, 22:34
Wohnort: Hamburg
CPU: Intel® Core™ i9-11900K
GPU: NVIDIA GeForce RTX 3070
Kernel: 5.15.48-1-MANJARO (64-bit)
Desktop-Variante: KDE-Plasma 5.24.x
GPU Treiber: NVidia 510.68
Hat sich bedankt: 14 Mal
Danksagung erhalten: 6 Mal

Re: Probleme mit Einbinden neuer Disk per LUKS/BTRFS

#2

Beitrag von Siliziumfuchs »

Ideen habe ich keine, nur anderthalb launige Kommentare:

ich habe zwar hier auch KDE, aber mir auch noch 'Laufwerke' [gnome-disk-utility 42.0 / UDisks 2.9.4 (gebaut gegen 2.9.4)] installiert. Das hat oben rechts in dem drei-Punkte Menü den Punkt 'Leistungstest für Laufwerk...'

Den hatte ich mal mit einem bemerkenswerten USB-Stick ausprobiert: Schreib/Lesegeschwindigkeiten waren vielleicht ganz nett, aber die mittlere Zugriffszeit absurd hoch (die Messpunkte hatten da zwei Zeiten angezeigt, die höhere so um 900ms, die zweite nur etwas niedriger).

Hilft jetzt auch nicht weiter, aber ist noch eine nette Messmöglichkeit die eigentlich schnell durchläuft. Könnte aber auf der neuen Platte, wie auch beim meinem USB-Stick, etwas länger brauchen.

Dann noch der andere Kommentar: wirklich 20TB (also 20 Terrabyte?)....? 8) [habe die letzten Jahre immer nur mobile USB-Platten gekauft und da bin ich diese Größenordnung nicht gewohnt. Andererseits, wenn ich die 1TB, 2TB und 4TB-Platten hier im Haushalt zusammen zähle... ]
Also früher, ganz früher.... unter DOS oder so da gab es Probleme bei der Formatierung wenn die Platten zu groß waren. Ich habe hier nur ext4 im Einsatz, zu LUKS/BTRFS kann ich nichts sagen. Das überlasse ich mal denen die sich damit auskennen.

(doch noch'n dritter Kommentar)
Aber als ich eben mal im Web geschaut hatte, wie groß die Platten heutztage sind, da bin ich hier gelandet:
https://www.kitguru.net/components/hard ... d=noscript
Bei der Beschreibung den Text zum CrystalDiskMark 6.0 beachten! Beim sequentiellen Schreiben/Lesen sind die Transferraten zwar hoch, aber beim nicht-sequentiellen Schreiben/Lesen sind die Werte nun ganz andere.
Günther hat geschrieben: Donnerstag 26. Mai 2022, 22:42 Was ich auch komisch fand, ich habe eine andere funktionerende LUKS/BTRFS Disk also solche per "dd /sdFUNKTIONIERD auf /sdNEU" kopiert, dabei kam es zu unterirdischen Transferraten ~10MB/s und die Festplatte ist ständig eingeschlafen und hat wieder hochgedreht. Das ging 30 Minuten so, bis ich das abgebrochen habe. Habe nicht verstanden, wieso?
Die ~10MB/s scheinen mir jetzt nicht so "unterirdisch" zu sein. Wenn eben nicht sequentiell geschrieben wird!
Aber ich habe da keine Ahnung wie sequentiell beim kopieren mit dd wirklich auf die Platte geschrieben wird. Eigentlich gehe ich da auch von sehr viel sequentiellem Schreiben aus. Aber die Geschwindigkeit und das ständige einschlafen und hochdrehen...? Erscheint mir gerade nicht sehr sequentiell... warum? Leider auch keine Ahnung.

Themen Author
Günther
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 59
Registriert: Mittwoch 23. Juni 2021, 00:19
CPU: AMD Ryzen 7 5700G
GPU: AMD Radeon Graphics (iGPU)
Kernel: Manjaro, actual
Desktop-Variante: KDE Plasma
GPU Treiber: amdfree
Hat sich bedankt: 5 Mal
Danksagung erhalten: 7 Mal

Re: Probleme mit Einbinden neuer Disk per LUKS/BTRFS

#3

Beitrag von Günther »

Danke, Siliziumfuchs, für deine Antwort :)

Am Leistungstest meiner Platte sieht man Nichts, siehe Anhang.

Den verlinkten Test kenne ich, bei zufälligen+kleinen Daten versagen mechanische Laufwerke aufgrund ihrer Natur, das ist so.

Thema dd: Ich hätte gedacht, dass das Programm stur bit für bit sequenziell schreibt, daher habe ich eigentlich höhere Werte erwartet und vor allem kein "Einschlafen" der Festplatte ;)
Dateianhänge
leistungstestDISKS.png
leistungstestDISKS.png (646.22 KiB) 425 mal betrachtet

Themen Author
Günther
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 59
Registriert: Mittwoch 23. Juni 2021, 00:19
CPU: AMD Ryzen 7 5700G
GPU: AMD Radeon Graphics (iGPU)
Kernel: Manjaro, actual
Desktop-Variante: KDE Plasma
GPU Treiber: amdfree
Hat sich bedankt: 5 Mal
Danksagung erhalten: 7 Mal

Re: Probleme mit Einbinden neuer Disk per LUKS/BTRFS

#4

Beitrag von Günther »

Ich habe im KDE-Partitionmanager per Rechtsklick/Prüfen die Partition gechecked:

Code: Alles auswählen

 Prüfen und reparieren von Partition „/dev/sde1“ (18,19 TiB, Btrfs) 
Operation: Das Dateisystem auf der Partition „/dev/sde1“ wird überprüft. 
Befehl: btrfs check --repair /dev/mapper/luks-458323f0-18a4-4928-b01d-27e02d06f2e8 
Das Dateisystem auf der Partition „/dev/sde1“ wird überprüft.: Erfolgreich

Operation: Dateisystem auf „/dev/sde1“ wird maximiert, sodass es die Partition ausfüllt. 
Das Dateisystem auf der Partition „/dev/sde1“ hat bereits die gewünschte Länge von 39.063.646.208 Sektoren. 
Dateisystem auf „/dev/sde1“ wird maximiert, sodass es die Partition ausfüllt.: Erfolgreich
Prüfen und reparieren von Partition „/dev/sde1“ (18,19 TiB, Btrfs): Erfolgreich
Ich kann die Partition problemlos per KDE-Partitionmanager einbinden. Über Gnome Disks und über den Systemstart kommen weiter die im Startbeitrag genannten Fehler.

Woran liegt das? Ich bin für jede Idee dankbar ;)


Edit: Da wenig Feedback kommt, habe ich das Thema auf manjaro.org "geklont", ich hoffe, niemand ist mir böse deswegen.

Code: Alles auswählen

https://forum.manjaro.org/t/problems-with-mounting-new-disc-via-luks-btrfs/112269
Antworten

Zurück zu „Manjaro Linux Hardware und Kernel“