KDE Standyby Fragen

Support rund um die Manjaro KDE Edition findet man in dieser Kategorie!
Antworten

Themen Author
4tmelDriver
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 10
Registriert: Dienstag 10. Dezember 2019, 20:58
CPU: i5-8250U
GPU: GeForce MX150
Kernel: 5.3
DE: KDE
GPU Treiber: Nvidia

KDE Standyby Fragen

#1

#1 Beitrag von 4tmelDriver »

Hallo liebes Forum,

ich habe zwei kleine Probleme festgestellt bzgl. des Standyby Modus:

Wenn ich meinen Laptop in den Standyby versetze mittels Knopfdruck auf dem Powerknopf, funktioniert das auch, aber nach ein paar Sekunden springt der Bildschirm sofort wieder an. Vermutlich weil kleinste Bewegungen (am Touchpad?) dazu führen, dass er wieder aufwacht. Das Problem tritt unter Windows nicht auf, und ist besonders in Vorlesungen nervig, wenn dauernd der Bildschirm wieder an geht. Wie kann man das verhindern?

Das führt mich zur zweiten Frage:
Wenn ich dann im Sperrbildschirm bin möchte ich auch wieder mit einem Druck auf dem Powerknopf den Laptop wieder in den Standby schicken. Das tut er allerdings nur wenn ich eingeloggt bin. Der Powerknopf im Sperrbildschirm verhält sich nur so als würde ich eine ganz normale Taste drücken. Aber ich will auch im Sperrbildschrim sofort den Bildschirm ausschalten können bzw. in den Standby schicken. Wie kann man das ändern?

Vielleicht hat jemand eine Idee dazu. Danke für die Hilfe

Gruß
Benutzeravatar

zompel
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 73
Registriert: Montag 9. Dezember 2019, 19:52
CPU: Intel Core i9-9900KF
GPU: nVidia GeForce RTX 2070
Kernel: Linux 5.8
DE: Gnome 3.36
GPU Treiber: nVidia 450.xx
Hat sich bedankt: 3 Mal
Danksagung erhalten: 13 Mal

Re: KDE Standyby Fragen

#2

#2 Beitrag von zompel »

Zum ersten Punkt kann ich Dir leider nichts sagen, außer dass ich früher auch schon mal eine Maus hatte wo sich der Cursor oft langsam aber stetig in eine Richtung bewegte, obwohl die Maus nicht angerührt wurde. Das ist dann wohl eher ein Hardwaredefekt.... obwohl vielleicht helfen könnte die Empfindlichkeit zu reduzieren... einfach mal probieren.

Zum 2. Punkt würde ich sagen, dass es vollkommen normal und auch so gedacht ist. Der Sperrbildschirm heißt nicht umsonst so. Es soll ja niemand ohne sich authentifiziert (eingeloggt) zu haben irgendetwas am Rechner "anstellen" können.
Die beste Lösung wäre wohl zu verhindern dass der Sperrbildschirm aktiviert wird.

Themen Author
4tmelDriver
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 10
Registriert: Dienstag 10. Dezember 2019, 20:58
CPU: i5-8250U
GPU: GeForce MX150
Kernel: 5.3
DE: KDE
GPU Treiber: Nvidia

Re: KDE Standyby Fragen

#3

#3 Beitrag von 4tmelDriver »

Danke für die Antwort.

Problem Nummer 2. habe ich so gelöst, dass der Sperrbildschirm einfach nicht mehr aufgerufen wird, nach dem aufwachen. Das reicht mir...

Zu Problem Nummer 1: Ich war so schlau und habe Mal die Verbindung zur Maus deaktiviert und das Touchpad ausgeschaltet. Trotzdem wacht das Notebook immer wieder aus dem Standby grundlos auf. Kann man irgendwie die Events herausfinden, weswegen Manjaro wieder angesprungen ist?

Gruß
Benutzeravatar

zompel
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 73
Registriert: Montag 9. Dezember 2019, 19:52
CPU: Intel Core i9-9900KF
GPU: nVidia GeForce RTX 2070
Kernel: Linux 5.8
DE: Gnome 3.36
GPU Treiber: nVidia 450.xx
Hat sich bedankt: 3 Mal
Danksagung erhalten: 13 Mal

Re: KDE Standyby Fragen

#4

#4 Beitrag von zompel »

Da habe ich leider keine Ahnung von. Sicher gibt es irgendwo logfiles oder ähnliches, aber ich wüsste nicht wo man suchen müsste.

Themen Author
4tmelDriver
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 10
Registriert: Dienstag 10. Dezember 2019, 20:58
CPU: i5-8250U
GPU: GeForce MX150
Kernel: 5.3
DE: KDE
GPU Treiber: Nvidia

Re: KDE Standyby Fragen

#5

#5 Beitrag von 4tmelDriver »

Hallo,

inzwischen habe ich auch das erste Problem gelöst. Falls in Zukunft andere User auf den Thread stoßen, will ich ihnen die Lösung nicht vorenthalten:

Bei mir war das Problem Bluetooth. Nach deaktivieren von Bluetooth hat sich der Laptop nicht mehr selber aufgeweckt. Damit man weiter Bluetooth nutzen kann, habe ich ein kleines Skript geschrieben, um bei Eintritt des Standby Bluetooth abzuschalten und beim Aufwecken wieder zu starten.
Damit hat es bei mir geklappt.

Themen Author
4tmelDriver
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 10
Registriert: Dienstag 10. Dezember 2019, 20:58
CPU: i5-8250U
GPU: GeForce MX150
Kernel: 5.3
DE: KDE
GPU Treiber: Nvidia

Re: KDE Standyby Fragen

#6

#6 Beitrag von 4tmelDriver »

Hallo,

ich habe ja bereits einen Workaround zum Problem beschrieben. Es gibt noch einen Weiteren, der sogar im Arch Wiki nachzulesen ist und ich nur nicht gefunden habe:
https://wiki.archlinux.org/index.php/Po ... om_suspend

Beim ändern von XHC auf disabled ist bei mir das Problem verschwunden.
Antworten