Installation von Project Libre bricht ab mit Fehlermeldung Thema ist als GELÖST markiert

User helfen sich hier bei der Manjaro XFCE Edition!
Antworten
Benutzeravatar

Themen Author
moniaqua
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 6
Registriert: Dienstag 19. September 2023, 14:11
CPU: Ryzen 7
GPU: GeForce RTX 2060 Mobile
Kernel: 6.5.3-1-MANJARO
Desktop-Variante: XFCE
GPU Treiber: video-hybrid-amd-nvidia-prime, video-linux
Hat sich bedankt: 5 Mal

Installation von Project Libre bricht ab mit Fehlermeldung

#1

Beitrag von moniaqua »

Grüß Euch,

ich habe mir heute Manjaro installiert und bin soweit auch ganz glücklich damit. Nun wollte ich Project Libre installieren; dies bricht ab mit der Fehlermeldung

Code: Alles auswählen

/var/tmp/pamac-build-moniuser/projectlibre/PKGBUILD: line 27: patch: command not found
Im Kontext:

Code: Alles auswählen

manjaro:~$ pamac build projectlibre
Preparing...
Cloning projectlibre build files...
Generating projectlibre information...
Checking projectlibre dependencies...
Resolving dependencies...
Checking inter-conflicts...

To build (1):
  projectlibre  1.9.3-1    AUR


Edit build files : [e] 
Apply transaction ? [e/y/N] e


Cloning projectlibre build files...
Generating projectlibre information...
Checking projectlibre dependencies...
Resolving dependencies...
Checking inter-conflicts...

To build (1):
  projectlibre  1.9.3-1    AUR


Edit build files : [e] 
Apply transaction ? [e/y/N] y

==== AUTHENTICATING FOR org.manjaro.pamac.commit ====
Authentication is required to install, update, or remove packages
Authenticating as: Monika 
Password: 
==== AUTHENTICATION COMPLETE ====

Building projectlibre...
==> Making package: projectlibre 1.9.3-1 (Di 19 Sep 2023 13:51:18 CEST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found projectlibre-1.9.3.tar.gz
  -> Found projectlibre.png
  -> Found projectlibre.desktop
  -> Found projectlibre.patch
  -> Found projectlibre.xml
==> Validating source files with md5sums...
    projectlibre-1.9.3.tar.gz ... Passed
    projectlibre.png ... Passed
    projectlibre.desktop ... Passed
    projectlibre.patch ... Passed
    projectlibre.xml ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Extracting projectlibre-1.9.3.tar.gz with bsdtar
==> Removing existing $pkgdir/ directory...
==> Starting build()...
/var/tmp/pamac-build-moniuser/projectlibre/PKGBUILD: line 27: patch: command not found
==> ERROR: A failure occurred in build().
    Aborting...
Was kann ich tun, damit ich an ein funktionierendes Project Libre komme?
Vielen Dank.
cu
Monika
Benutzeravatar

Siliziumfuchs
Forum Kenner
Forum Kenner
Beiträge: 183
Registriert: Mittwoch 23. Februar 2022, 22:34
Wohnort: Hamburg
CPU: Intel® Core™ i9-11900K
GPU: NVIDIA GeForce RTX 3070
Kernel: 5.15.76-1-MANJARO (64-bit)
Desktop-Variante: KDE-Plasma 5.26.x
GPU Treiber: NVidia 520.56.06
Hat sich bedankt: 19 Mal
Danksagung erhalten: 18 Mal

Re: Installation von Project Libre bricht ab mit Fehlermeldung

#2

Beitrag von Siliziumfuchs »

moniaqua hat geschrieben: Dienstag 19. September 2023, 14:27

Code: Alles auswählen

/var/tmp/pamac-build-moniuser/projectlibre/PKGBUILD: line 27: patch: command not found
das fehlende command `patch` installieren....
(Version 2.7.6-10 bei mir)
Benutzeravatar

LaGGGer
Forum Held
Forum Held
Beiträge: 1345
Registriert: Freitag 26. Juni 2020, 18:53
CPU: AMD Ryzen 7 1700X
GPU: NVIDIA GP106 [GeForce GTX 1060 6GB]
Kernel: 5.18
Desktop-Variante: XFCE
GPU Treiber: Nvidia 510.54
Hat sich bedankt: 129 Mal
Danksagung erhalten: 217 Mal

Re: Installation von Project Libre bricht ab mit Fehlermeldung

#3

Beitrag von LaGGGer »

Ist base-devel installiert? Manche programme aus dem AUR benötigen das.
Wenn patch nicht funktioniert, könnte es daran liegen.

Code: Alles auswählen

pamac install base-devel
°°
MfG LaGGGer
Benutzeravatar

Themen Author
moniaqua
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 6
Registriert: Dienstag 19. September 2023, 14:11
CPU: Ryzen 7
GPU: GeForce RTX 2060 Mobile
Kernel: 6.5.3-1-MANJARO
Desktop-Variante: XFCE
GPU Treiber: video-hybrid-amd-nvidia-prime, video-linux
Hat sich bedankt: 5 Mal

Re: Installation von Project Libre bricht ab mit Fehlermeldung

#4

Beitrag von moniaqua »

LaGGGer hat geschrieben: Dienstag 19. September 2023, 15:16 Ist base-devel installiert? Manche programme aus dem AUR benötigen das.
Wenn patch nicht funktioniert, könnte es daran liegen.

Code: Alles auswählen

pamac install base-devel
Das war's, lieben Dank. Ich bin zwar schon eine Zeit unter Linux unterwegs, aber Manjaro ist an manchen Ecken doch anders :) Der Fehlermeldung hätte ich das jetzt auch nicht wirklich entnommen, dass basic-devel fehlt.
cu
Monika
Benutzeravatar

Themen Author
moniaqua
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 6
Registriert: Dienstag 19. September 2023, 14:11
CPU: Ryzen 7
GPU: GeForce RTX 2060 Mobile
Kernel: 6.5.3-1-MANJARO
Desktop-Variante: XFCE
GPU Treiber: video-hybrid-amd-nvidia-prime, video-linux
Hat sich bedankt: 5 Mal

Re: Installation von Project Libre bricht ab mit Fehlermeldung

#5

Beitrag von moniaqua »

Siliziumfuchs hat geschrieben: Dienstag 19. September 2023, 14:57
moniaqua hat geschrieben: Dienstag 19. September 2023, 14:27

Code: Alles auswählen

/var/tmp/pamac-build-moniuser/projectlibre/PKGBUILD: line 27: patch: command not found
das fehlende command `patch` installieren....
(Version 2.7.6-10 bei mir)
Danke auch Dir; ich vermute, patch ist Bestandteil von base-devel oder hat zumindest eine ähnliche Funktion?
cu
Monika
Benutzeravatar

Siliziumfuchs
Forum Kenner
Forum Kenner
Beiträge: 183
Registriert: Mittwoch 23. Februar 2022, 22:34
Wohnort: Hamburg
CPU: Intel® Core™ i9-11900K
GPU: NVIDIA GeForce RTX 3070
Kernel: 5.15.76-1-MANJARO (64-bit)
Desktop-Variante: KDE-Plasma 5.26.x
GPU Treiber: NVidia 520.56.06
Hat sich bedankt: 19 Mal
Danksagung erhalten: 18 Mal

Re: Installation von Project Libre bricht ab mit Fehlermeldung

#6

Beitrag von Siliziumfuchs »

yep... sowohl patch, als auch den ganzen Rest den man so zum übersetzten von Sourcecode benötigt bekommt man mit base-devel auf's System
(siehe die ganzen Abhängigkeiten vom Paket base-devel)
Antworten