Alsa Kanal immer wieder auf Mute Thema ist als GELÖST markiert

User helfen sich hier bei der Manjaro XFCE Edition!
Benutzeravatar

Themen Author
Gekom
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 12
Registriert: Dienstag 7. September 2021, 21:46
CPU: Intel(R) Core(TM) i7-4900MQ CPU @ 2.80GHz
GPU: NVIDIA GK106GLM [Quadro K2100M]
Kernel: LTS aktuell linux510
Desktop-Variante: XFCE
GPU Treiber: video-hybrid-intel-nvidia-390xx-bumblebee
Hat sich bedankt: 1 Mal
Danksagung erhalten: 1 Mal

Alsa Kanal immer wieder auf Mute

#1

Beitrag von Gekom »

Hi,
seit neuesten macht Alsa Probleme, wenn ich Kopfhörer in die Soundblaster Notebook Karte stecke schaltet sich "Front" auf "MM" und nix ist zu hören.
Alsamixer im Terminal öffnen und "Front MM" deaktivieren ist umständlich.
Bisher funktionierte es gut automatisch aber nun nicht mehr.
Alsa Infos: http://alsa-project.org/db/?f=bd8826d1f ... 16ec4e0972

Ich behalf mir damit ein Icon mit dem Terminal Befehl

Code: Alles auswählen

amixer --card=2 sset Front unmute && amixer --card=2 sset Headphone unmute
zu erstellen.

So kann ich unkompliziert die KH nutzen.
Ansonsten scheint es keine Probleme mit Audio zu geben.
Ich hätte nur gern das beim einstecken der KH auch "Front" unmute bleibt wie es früher mal war und ich auf das Icon verzichten kann.
Weiß jemand woran es liegen könnte das es nicht mehr so funktioniert?
Ich habe Pipewire in Verdacht das durch ein Update hinzukam.
Das dumme an Linux bin ich.
Benutzeravatar

LaGGGer
Forum Kenner
Forum Kenner
Beiträge: 238
Registriert: Freitag 26. Juni 2020, 18:53
CPU: AMD Ryzen 7 1700X
GPU: NVIDIA GP106 [GeForce GTX 1060 6GB]
Kernel: 5.10
Desktop-Variante: XFCE
GPU Treiber: Nvidia 460
Hat sich bedankt: 17 Mal
Danksagung erhalten: 34 Mal

Re: Alsa Kanal immer wieder auf Mute

#2

Beitrag von LaGGGer »

Hi
Schon mal über pulsaudio die Einstellungen gemacht? Sollte eigentlich installiert sein, wenn nicht:

Code: Alles auswählen

sudo pacman -S pavucontrol
°°
MfG LaGGGer
Benutzeravatar

Themen Author
Gekom
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 12
Registriert: Dienstag 7. September 2021, 21:46
CPU: Intel(R) Core(TM) i7-4900MQ CPU @ 2.80GHz
GPU: NVIDIA GK106GLM [Quadro K2100M]
Kernel: LTS aktuell linux510
Desktop-Variante: XFCE
GPU Treiber: video-hybrid-intel-nvidia-390xx-bumblebee
Hat sich bedankt: 1 Mal
Danksagung erhalten: 1 Mal

Re: Alsa Kanal immer wieder auf Mute

#3

Beitrag von Gekom »

LaGGGer hat geschrieben: Mittwoch 8. September 2021, 17:35 Schon mal über pulsaudio die Einstellungen gemacht?
Ja klar die Lautstärkeregelung mit Tonmischer ist ja Standard.
Hilft aber nicht da auch da die Soundkarte beim einstecken der KH stumm schaltet.
Also auf Headphone (eingesteckt) kommt kein Ton weil im Alsamixer Front auf MM schaltet.
Beim umschalten auf Analog Output im Pulse Tonmischer sind wieder alle Kanäle an. Also kommt da auch Ton auf KH.
Das Problem liegt an der Alsa Konfiguration wo ich aber nicht weiß wo das gefixt werden muss.

Eine andere Lösung wäre im Pulse Tonmischer das automatische Umschalten beim einstecken zu deaktivieren.
Habe aber auch da keine Ahnung wie.

PS: es geht immer um die SoundBlaster PCI Express Karte, Onboard- Sound funktioniert
Das dumme an Linux bin ich.
Benutzeravatar

djeli
Forum Held
Forum Held
Beiträge: 679
Registriert: Samstag 21. Mai 2016, 12:12
GPU:
Kernel:
Desktop-Variante:
GPU Treiber:
Hat sich bedankt: 33 Mal
Danksagung erhalten: 71 Mal

Re: Alsa Kanal immer wieder auf Mute

#4

Beitrag von djeli »

Moin

Schalte dein Sound bitte ein,so das du über Kopfhörer Sound hast.
Dann im Terminal

Code: Alles auswählen

alsactl store
Das sollte deine momentane einstellung dann sichern.
Ob es dann mit der Soundkarte so funktioniert kann Ich aber nicht sagen.
Kann aber auch nicht schaden.

djeli
Benutzeravatar

Themen Author
Gekom
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 12
Registriert: Dienstag 7. September 2021, 21:46
CPU: Intel(R) Core(TM) i7-4900MQ CPU @ 2.80GHz
GPU: NVIDIA GK106GLM [Quadro K2100M]
Kernel: LTS aktuell linux510
Desktop-Variante: XFCE
GPU Treiber: video-hybrid-intel-nvidia-390xx-bumblebee
Hat sich bedankt: 1 Mal
Danksagung erhalten: 1 Mal

Re: Alsa Kanal immer wieder auf Mute

#5

Beitrag von Gekom »

djeli hat geschrieben: Donnerstag 9. September 2021, 09:51 Moin

Schalte dein Sound bitte ein,so das du über Kopfhörer Sound hast.
Dann im Terminal

Code: Alles auswählen

alsactl store
Das sollte deine momentane einstellung dann sichern.
Ob es dann mit der Soundkarte so funktioniert kann Ich aber nicht sagen.
Kann aber auch nicht schaden.

djeli
Ja auch das hatte ich schon gemacht aber auch das bringt nix. Beim nächsten aus/einstecken der KH ist es wieder MM.
Das dumme an Linux bin ich.
Benutzeravatar

LaGGGer
Forum Kenner
Forum Kenner
Beiträge: 238
Registriert: Freitag 26. Juni 2020, 18:53
CPU: AMD Ryzen 7 1700X
GPU: NVIDIA GP106 [GeForce GTX 1060 6GB]
Kernel: 5.10
Desktop-Variante: XFCE
GPU Treiber: Nvidia 460
Hat sich bedankt: 17 Mal
Danksagung erhalten: 34 Mal

Re: Alsa Kanal immer wieder auf Mute

#6

Beitrag von LaGGGer »

Ich habe hier auch ein Ähliches Problem gehabt, wenn ich den Kopfhörer Eingesteckt habe ging der Sound der Lautsprecher aus. auch hierbei hat mein Linux, damals wars wohl noch LinuxMint, die Einstellungen nicht behalten das beim abziehen des Kopfhörerkabels die Lautsprecher aktiv bleiben sollten.

Meine Vorgehensweise hört sich etwas blöd an, aber ich habe mir damals eine USB-Soundkarte geholt und die Kopfhörer daran angeschlossen. Nutze ich auch jetzt weiterhin mit Manjaro.
Das war, jedenfalls für mich, die Lösung.

Das wirst du wahrscheinlich nicht wollen, aber es funktioniert. Wenn ich die USB-Soundkarte abziehe und wieder anstecke bleiben die Einstellungen vorhanden. Und die Soundquallität ist, jedendalls für mich, absolut in Ordnung. Kaum zu glauben was so ein kleines Ding leistet.

Ohne Alsa zu bemühen, geht alles mit pavucontrol.
Das hier wäre so eine Soundkarte, unter 10€, sehr klein: Sabrent USB Externe Soundkarte

Wie gesagt, umständlich, aber es funktioniert.
°°
MfG LaGGGer
Benutzeravatar

Themen Author
Gekom
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 12
Registriert: Dienstag 7. September 2021, 21:46
CPU: Intel(R) Core(TM) i7-4900MQ CPU @ 2.80GHz
GPU: NVIDIA GK106GLM [Quadro K2100M]
Kernel: LTS aktuell linux510
Desktop-Variante: XFCE
GPU Treiber: video-hybrid-intel-nvidia-390xx-bumblebee
Hat sich bedankt: 1 Mal
Danksagung erhalten: 1 Mal

Re: Alsa Kanal immer wieder auf Mute

#7

Beitrag von Gekom »

Hm, wie schon erwähnt die integrierte Soundkarte meines Notebooks funktioniert gut.
Und bis vor einiger Zeit funktionierte auch alles mit der Creative Soundkarte wie es sollte.
Aber irgend ein Update muss etwas in den Konfigurationsdateien verändert haben, was den "Front" Kanal in Alsa mutet lässt beim einstecken von KH.

Das kann doch kein unlösbares Problem sein. Deswegen eine andere Soundkarte zu nutzen kommt nicht in Frage.
Der simple Befehl

Code: Alles auswählen

amixer --card=2 sset Front unmute
schaltet es wie es sein soll.
Allerdings nur bis zum nächsten einstecken, dann muss ich den Befehl wiederholen.

Irgendwo ist doch Alsa konfigurierbar was wann wie passiert, so sollte es doch möglich sein das umschalten zu unterbinden.

Wo ist die verantwortliche Datei und wie heißt sie?

Vielleicht habe ich auch einen Holzweg vor Augen oder am Treiber der Soundkarte hat sich was geändert.
Auf jeden Fall benutze ich die Creative Soundkarte schon Jahrelang ohne dieses Problem.
Nochmal der Befehl mit Ausgabe :

Code: Alles auswählen

$ amixer --card=2 sset Front unmute
Simple mixer control 'Front',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 103
  Mono:
  Front Left: Playback 103 [100%] [0.00dB] [on]
  Front Right: Playback 103 [100%] [0.00dB] [on]
Das dumme an Linux bin ich.
Benutzeravatar

Manfrago
Forum Held
Forum Held
Beiträge: 599
Registriert: Dienstag 8. Dezember 2020, 17:23
Wohnort: Lubeca
CPU: ausschließlich i7/ 3.Gen.
GPU: Intel / Nvidia
Kernel: 5.4 / 5.10
Desktop-Variante: XFCE
GPU Treiber: Nvidia-390xx / Optimus qt
Hat sich bedankt: 14 Mal
Danksagung erhalten: 109 Mal

Re: Alsa Kanal immer wieder auf Mute

#8

Beitrag von Manfrago »

Gekom hat geschrieben: Freitag 10. September 2021, 14:38 ....Vielleicht habe ich auch einen Holzweg vor Augen oder am Treiber der Soundkarte hat sich was geändert.
Auf jeden Fall benutze ich die Creative Soundkarte schon Jahrelang ohne dieses Problem.
Ich rätsel schon die ganze Zeit, um was für eine PCI Creative Soundkarte es bei deinem Laptop wohl geht :)
Kann es sein, das wir hier über eine Soundkarte reden, die als Erweiterung in einem Express Kartenschacht steckt?
Dann wäre für die Verwaltung der Karte ausschließlich der Kernel verantwortlich.
Zur Beachtung, es ist NIEMALS alsaconf zu benutzen, wenn eine PCI oder ISAPNP Soundkarte vorhanden ist, dies könnte udev durcheinander bringen!
Ungesicherte Daten sind unwichtige Daten. Niemals einer Befehlszeile vertrauen, ohne zu wissen, was diese bewirkt.
Benutzeravatar

LaGGGer
Forum Kenner
Forum Kenner
Beiträge: 238
Registriert: Freitag 26. Juni 2020, 18:53
CPU: AMD Ryzen 7 1700X
GPU: NVIDIA GP106 [GeForce GTX 1060 6GB]
Kernel: 5.10
Desktop-Variante: XFCE
GPU Treiber: Nvidia 460
Hat sich bedankt: 17 Mal
Danksagung erhalten: 34 Mal

Re: Alsa Kanal immer wieder auf Mute

#9

Beitrag von LaGGGer »

Ich schließe mich mal Manfrago an und rätsele mit ..
Um was gehts hier eigendlich? .. um eine Intere Soundkarte und eine Soundblaster Karte ?

Bitte mache:

Code: Alles auswählen

inxi -Fz
im Terminal. Das Resultat bitte in eine Codebox.

Ich raff echt nicht was du da meinst ..gehts um zwei Computer ?
Du musst das schon mal genauer beschreiben damit wir aufhören zu mutmaßen ..
°°
MfG LaGGGer
Benutzeravatar

Themen Author
Gekom
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 12
Registriert: Dienstag 7. September 2021, 21:46
CPU: Intel(R) Core(TM) i7-4900MQ CPU @ 2.80GHz
GPU: NVIDIA GK106GLM [Quadro K2100M]
Kernel: LTS aktuell linux510
Desktop-Variante: XFCE
GPU Treiber: video-hybrid-intel-nvidia-390xx-bumblebee
Hat sich bedankt: 1 Mal
Danksagung erhalten: 1 Mal

Re: Alsa Kanal immer wieder auf Mute

#10

Beitrag von Gekom »

Habe nur den einen Laptop in Benutzung, ein HP ZBook 15. Es geht um die im Expresslot steckende Soundblaster Soundkarte.

Code: Alles auswählen

inxi -Fz
System:
  Kernel: 5.10.61-1-MANJARO x86_64 bits: 64 Desktop: Xfce 4.16.0 
  Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Hewlett-Packard product: HP ZBook 15 v: A3009DD10203 
  serial: <filter> 
  Mobo: Hewlett-Packard model: 1909 v: KBC Version 94.56 serial: <filter> 
  BIOS: Hewlett-Packard v: L70 Ver. 01.44 date: 08/08/2018 
Battery:
  ID-1: BAT0 charge: 54.7 Wh (96.1%) condition: 56.9/56.9 Wh (100.0%) 
CPU:
  Info: Quad Core model: Intel Core i7-4900MQ bits: 64 type: MT MCP cache: 
  L2: 8 MiB 
  Speed: 1363 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 1363 2: 1226 
  3: 1681 4: 2266 5: 1399 6: 1446 7: 1340 8: 1651 
Graphics:
  Device-1: Intel 4th Gen Core Processor Integrated Graphics driver: i915 
  v: kernel 
  Device-2: NVIDIA GK106GLM [Quadro K2100M] driver: N/A 
  Display: x11 server: X.Org 1.20.13 driver: loaded: intel 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4600 (HSW GT2) 
  v: 4.5 Mesa 21.2.1 
Audio:
  Device-1: Intel 8 Series/C220 Series High Definition Audio 
  driver: snd_hda_intel 
  Device-2: NVIDIA GK106 HDMI Audio driver: snd_hda_intel 
  Device-3: Creative Labs CA0110 [Sound Blaster X-Fi Xtreme Audio] 
  driver: snd_hda_intel 
  Sound Server-1: ALSA v: k5.10.61-1-MANJARO running: yes 
  Sound Server-2: PulseAudio v: 15.0 running: yes 
Network:
  Device-1: Intel Ethernet I217-LM driver: e1000e 
  IF: enp0s25 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Intel Wireless 7260 driver: iwlwifi 
  IF: wlo1 state: down mac: <filter> 
Bluetooth:
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb 
  Report: rfkill ID: hci0 rfk-id: 6 state: down bt-service: enabled,running 
  rfk-block: hardware: no software: yes address: see --recommends 
Drives:
  Local Storage: total: 1.42 TiB used: 228.51 GiB (15.7%) 
  ID-1: /dev/mmcblk0 model: EC1S5 size: 59.69 GiB 
  ID-2: /dev/sda vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB 
  ID-3: /dev/sdb vendor: Seagate model: ST500LM000-SSHD-8GB size: 465.76 GiB 
  ID-4: /dev/sdc vendor: Samsung model: SSD 850 EVO mSATA 500GB 
  size: 465.76 GiB 
Partition:
  ID-1: / size: 57.42 GiB used: 41.09 GiB (71.6%) fs: ext4 dev: /dev/sda5 
  ID-2: /boot size: 282.6 MiB used: 146 MiB (51.7%) fs: ext4 dev: /dev/sda1 
Swap:
  ID-1: swap-1 type: partition size: 16.15 GiB used: 0 KiB (0.0%) 
  dev: /dev/sda6 
Sensors:
  System Temperatures: cpu: 46.0 C mobo: 0.0 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 278 Uptime: 13h 48m Memory: 15.44 GiB used: 4.32 GiB (28.0%) 
  Shell: Bash inxi: 3.3.06
Ich hatte doch schon im 1.Post den Link zum Alsa-Projekt mit allen Infos....
Das dumme an Linux bin ich.
Benutzeravatar

Themen Author
Gekom
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 12
Registriert: Dienstag 7. September 2021, 21:46
CPU: Intel(R) Core(TM) i7-4900MQ CPU @ 2.80GHz
GPU: NVIDIA GK106GLM [Quadro K2100M]
Kernel: LTS aktuell linux510
Desktop-Variante: XFCE
GPU Treiber: video-hybrid-intel-nvidia-390xx-bumblebee
Hat sich bedankt: 1 Mal
Danksagung erhalten: 1 Mal

Re: Alsa Kanal immer wieder auf Mute

#11

Beitrag von Gekom »

Noch ein Bild vom Alsamixer:
Bildschirmfoto_2021-09-07_08-48-01.png
Bildschirmfoto_2021-09-07_08-48-01.png (48.67 KiB) 226 mal betrachtet
Kopfhörer sind in Soudblaster Karte eingesteckt und nix ist zu hören.
Erst wenn ich auch "Front" auf "00" schalte ist alles gut. (Bis zum nächsten mal booten oder neu einstecken der KH)
Das dumme an Linux bin ich.
Benutzeravatar

Manfrago
Forum Held
Forum Held
Beiträge: 599
Registriert: Dienstag 8. Dezember 2020, 17:23
Wohnort: Lubeca
CPU: ausschließlich i7/ 3.Gen.
GPU: Intel / Nvidia
Kernel: 5.4 / 5.10
Desktop-Variante: XFCE
GPU Treiber: Nvidia-390xx / Optimus qt
Hat sich bedankt: 14 Mal
Danksagung erhalten: 109 Mal

Re: Alsa Kanal immer wieder auf Mute

#12

Beitrag von Manfrago »

Gekom hat geschrieben: Freitag 10. September 2021, 21:43 ...Ich hatte doch schon im 1.Post den Link zum Alsa-Projekt mit allen Infos....
Sorry, das nicht jeder hier Lust hat, sich irgendein Script vollständig durchzulesen.
Wie schon geschrieben, solltest du eine zusätzliche Soundkarte die an PCI liegt (und der Express-Slot liegt an PCI) nicht einfach auf deine Bedürfnisse mittels Konfigurationsänderungen hinbiegen. Mein Vorschlag wäre, in der mhwd zu schauen, ob auch der Kernel 5.4 für deinen PC akzeptiert wird. Einfach mal ausprobieren und berichten. Wenn das auch nicht läuft, dann ist die vollständige Unterstützung dieser Karte inzwischen wohl aus dem Kernel rausgeflogen. Das hatte ich auch schon mit einer PCMCIA (so hieß der Express-Einschub vormals) USB3 Karte. Lief am Anfang mit Manjaro bombig, mit der Zeit immer hakeliger und schlechter.
Ungesicherte Daten sind unwichtige Daten. Niemals einer Befehlszeile vertrauen, ohne zu wissen, was diese bewirkt.
Benutzeravatar

Themen Author
Gekom
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 12
Registriert: Dienstag 7. September 2021, 21:46
CPU: Intel(R) Core(TM) i7-4900MQ CPU @ 2.80GHz
GPU: NVIDIA GK106GLM [Quadro K2100M]
Kernel: LTS aktuell linux510
Desktop-Variante: XFCE
GPU Treiber: video-hybrid-intel-nvidia-390xx-bumblebee
Hat sich bedankt: 1 Mal
Danksagung erhalten: 1 Mal

Re: Alsa Kanal immer wieder auf Mute

#13

Beitrag von Gekom »

in der mhwd zu schauen, ob auch der Kernel 5.4 für deinen PC akzeptiert wird
Wie genau ist das gemeint? Ich habe die letzten 3 LTS Kernel noch inst. werde gleich mal neu booten.
Das dumme an Linux bin ich.
Benutzeravatar

Themen Author
Gekom
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 12
Registriert: Dienstag 7. September 2021, 21:46
CPU: Intel(R) Core(TM) i7-4900MQ CPU @ 2.80GHz
GPU: NVIDIA GK106GLM [Quadro K2100M]
Kernel: LTS aktuell linux510
Desktop-Variante: XFCE
GPU Treiber: video-hybrid-intel-nvidia-390xx-bumblebee
Hat sich bedankt: 1 Mal
Danksagung erhalten: 1 Mal

Re: Alsa Kanal immer wieder auf Mute

#14

Beitrag von Gekom »

Also unter 4.19 Kernel ist es das gleiche Problem.
Das dumme an Linux bin ich.
Benutzeravatar

Manfrago
Forum Held
Forum Held
Beiträge: 599
Registriert: Dienstag 8. Dezember 2020, 17:23
Wohnort: Lubeca
CPU: ausschließlich i7/ 3.Gen.
GPU: Intel / Nvidia
Kernel: 5.4 / 5.10
Desktop-Variante: XFCE
GPU Treiber: Nvidia-390xx / Optimus qt
Hat sich bedankt: 14 Mal
Danksagung erhalten: 109 Mal

Re: Alsa Kanal immer wieder auf Mute

#15

Beitrag von Manfrago »

Gekom hat geschrieben: Freitag 10. September 2021, 22:42 Also unter 4.19 Kernel ist es das gleiche Problem.
Schade und danke für den Versuch. Ich habe dazu keine mit gutem Gewissen vereinbare Idee mehr.
Ungesicherte Daten sind unwichtige Daten. Niemals einer Befehlszeile vertrauen, ohne zu wissen, was diese bewirkt.
Antworten