Kann SMB Shares meines Router nicht in Thunar öffnen (SMBv1)

User helfen sich hier bei der Manjaro XFCE Edition!
Antworten

Themen Author
Karacho
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 2
Registriert: Mittwoch 20. Mai 2020, 17:27
CPU: i7-3720QM
GPU: Quadro M2000M
Kernel: 5.6.12-1-MANJARO
DE: XFCE
GPU Treiber: nvidia 440.82

Kann SMB Shares meines Router nicht in Thunar öffnen (SMBv1)

#1

#1 Beitrag von Karacho »

Hallo!

Ich bin die Tage von Xubuntu 18.04 auf Manjaro XFCE 20.0.1 umgestiegen.
In Thunar hatte ich zuvor unter Xubuntu immer mehrere SMB-Shares aus meinem LAN engebunden.
Z.B. von einem Windows PC, von einem kleinen Homeserver und von meinem Router.
Die Shares vom Server und vom Windows-PC funktionieren auch wie zuvor.
Aber die Shares auf dem Router kann ich in Thunar nicht mehr öffen. Wenn ich die Adresse des Routers eingebe erscheinen noch die Namen der Shares ("PS2SMB" und "entware"), die auf dem Router freigegeben sind, aber ich kann diese nicht öffnen. Es erscheint diese Fehlermeldung:
Bildschirmfoto_2020-05-20_17-33-15.png
Bildschirmfoto_2020-05-20_17-33-15.png (23.02 KiB) 283 mal betrachtet
Nun hatte ich in Erinnerung, dass die Shares vom Router wohl noch SMBv1-Shares sind.
Also habe ich es mal per Kommando versucht und es hat geklappt: wenn ich mount.cifs mit der Option "vers=1.0" starte, kann ich den Share mounten.
Somit liegt es wahrscheinlich daran dass Thunar in Manjaro SMB v1 nicht mag, vermutlich entweder weil es eine neuere Version ist, oder weil er anders konfiguriert wurde.
Wie kann ich das ändern?

Danke!
:)


Themen Author
Karacho
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 2
Registriert: Mittwoch 20. Mai 2020, 17:27
CPU: i7-3720QM
GPU: Quadro M2000M
Kernel: 5.6.12-1-MANJARO
DE: XFCE
GPU Treiber: nvidia 440.82

Re: Kann SMB Shares meines Router nicht in Thunar öffnen (SMBv1)

#2

#2 Beitrag von Karacho »

So, habe die Antwort endlich selbst gefunden:
Seit Samba 4 ist SMBv1 per Default deaktiviert.
Wieder einschalten kann man es, indem man in /etc/samba/smb.conf die Zeile:
client min protocol = SMB2
ändert zu:
client min protocol = LANMAN2

Antworten