Blackscreen nach dem Hochfahren Thema ist als GELÖST markiert

Probleme bei der Installation von Hardware unter Manjaro Linux? Hier wird geholfen.</span
Benutzeravatar

Manfrago
Forum Held
Forum Held
Beiträge: 693
Registriert: Dienstag 8. Dezember 2020, 17:23
Wohnort: Lubeca
CPU: ausschließlich i7/ 3.Gen.
GPU: Intel / Nvidia
Kernel: 5.4 / 5.10
Desktop-Variante: XFCE
GPU Treiber: Nvidia-390xx / Optimus qt
Hat sich bedankt: 17 Mal
Danksagung erhalten: 119 Mal

Re: Blackscreen nach dem Hochfahren

#16

Beitrag von Manfrago »

@Daemon Ich hätte
loaded: modesetting resolution: 1366x768~60Hz
erwartet und nicht
unloaded: modesetting resolution: 1366x768~60Hz
Ungesicherte Daten sind unwichtige Daten. Niemals einer Befehlszeile vertrauen, ohne zu wissen, was diese bewirkt.
Benutzeravatar

Daemon
Forum Held
Forum Held
Beiträge: 600
Registriert: Freitag 22. Dezember 2017, 14:17
CPU: 6082
GPU: wtf
Kernel: pre-linux
Desktop-Variante: pre-linux
GPU Treiber: hab keine
Hat sich bedankt: 10 Mal
Danksagung erhalten: 69 Mal

Re: Blackscreen nach dem Hochfahren

#17

Beitrag von Daemon »

Dann schau dir noch mal die inxi an. Bei loaded steht intel. ;)

Code: Alles auswählen

Display: x11 server: X.Org 1.20.11 driver: loaded: intel 
  unloaded: modesetting resolution: 1366x768~60Hz 
Siamo con il nostro Dio Scuro
Benutzeravatar

Manfrago
Forum Held
Forum Held
Beiträge: 693
Registriert: Dienstag 8. Dezember 2020, 17:23
Wohnort: Lubeca
CPU: ausschließlich i7/ 3.Gen.
GPU: Intel / Nvidia
Kernel: 5.4 / 5.10
Desktop-Variante: XFCE
GPU Treiber: Nvidia-390xx / Optimus qt
Hat sich bedankt: 17 Mal
Danksagung erhalten: 119 Mal

Re: Blackscreen nach dem Hochfahren

#18

Beitrag von Manfrago »

@Daemon Ich kann hier mangels X250 lediglich meine Lenovos vom X220 bis zum X240 und s440 zum Vergleich heranziehen.
Installiert ist Kernel 4.19 und 5.4, alle laufen unter Manjaro XFCE.
Alle nutzen beim Setup den Intel Grafiktreiber i915.
Bei allen lautet hernach die Displayinitialisierungszeile wie folgt:
Display: x11 server: X.Org 1.20.11 driver: loaded: modesetting resolution: 1366x768~60Hz
Den einzigen Unterschied macht nur die jeweilige Intel HD Graphics Version.
Mich wundert daher der Eintrag "driver: loaded: intel" beim X250 des TE.
Ungesicherte Daten sind unwichtige Daten. Niemals einer Befehlszeile vertrauen, ohne zu wissen, was diese bewirkt.
Benutzeravatar

Daemon
Forum Held
Forum Held
Beiträge: 600
Registriert: Freitag 22. Dezember 2017, 14:17
CPU: 6082
GPU: wtf
Kernel: pre-linux
Desktop-Variante: pre-linux
GPU Treiber: hab keine
Hat sich bedankt: 10 Mal
Danksagung erhalten: 69 Mal

Re: Blackscreen nach dem Hochfahren

#19

Beitrag von Daemon »

Ob das stimmt was inxi ausgibt?
Bei mir steht z.B. bei inxi folgendes:

Code: Alles auswählen

Device-1: NVIDIA TU117M driver: N/A 
Device-2: Advanced Micro Devices [AMD/ATI] Renoir driver: amdgpu v: kernel 
           
Display: x11 server: X.Org 1.20.11 driver: loaded: amdgpu,ati unloaded: modesetting resolution: 1920x1080~120Hz 
OpenGL: renderer: AMD RENOIR (DRM 3.40.0 5.12.5-1-MANJARO LLVM 11.1.0) v: 4.6 Mesa 21.1.1
Aber bei neofetch steht dies:

Code: Alles auswählen

GPU: NVIDIA 01:00.0 NVIDIA Corporation TU117M 
GPU: AMD ATI 05:00.0 Renoir 
GPU Driver: nouveau 
Und, ich habe tatsächlich nur den nVidia Treiber installiert.
Siamo con il nostro Dio Scuro

Themen Author
idealist
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 12
Registriert: Dienstag 18. Mai 2021, 16:22
CPU: Dual Core model: Intel Core i5-5200U bits: 64 type: MT MCP
GPU: Intel HD Graphics 5500
Kernel: 5.4.116-1-MANJARO x86_64
Desktop-Variante: Xfce 4.16.0
GPU Treiber: i915 v
Hat sich bedankt: 13 Mal
Danksagung erhalten: 1 Mal

Re: Blackscreen nach dem Hochfahren

#20

Beitrag von idealist »

Hallo zusammen,

also danke erstmal euch allen für die vielen tollen Beiträge!! Ich fühle mich sehr wohlig bei euch :)

Inzwischen war ich nochmal in dem Fall, dass ich das Notebook hochfahren musste, was nach wirklich vielen Versuchen auch irgendwann geklappt hat. Direkt danach habe ich gleichmal die Konsole gefragt:

Code: Alles auswählen

[...]$ sudo dmesg -T -l err
[Fr Mai 21 22:18:33 2021] ACPI Error: Needed type [Reference], found [Integer] 00000000074eb251 (20190816/exresop-66)
[Fr Mai 21 22:18:33 2021] ACPI Error: AE_AML_OPERAND_TYPE, While resolving operands for [Store] (20190816/dswexec-431)
[Fr Mai 21 22:18:33 2021] ACPI Error: Aborting method \_PR.CPU0._PDC due to previous error (AE_AML_OPERAND_TYPE) (20190816/psparse-529)
[Fr Mai 21 22:18:35 2021] proc: Bad value for 'hidepid'
[Fr Mai 21 22:18:35 2021] proc: Bad value for 'hidepid'
[Fr Mai 21 22:18:35 2021] proc: Bad value for 'hidepid'
[Fr Mai 21 22:18:36 2021] kvm: disabled by bios
[Fr Mai 21 22:18:36 2021] kvm: disabled by bios
[Fr Mai 21 22:18:36 2021] kvm: disabled by bios
[Fr Mai 21 22:18:36 2021] kvm: disabled by bios
und gerade noch das Ergebnis des anderen Befehls:

Code: Alles auswählen

[...]$ sudo journalctl -p 3 -xb
-- Journal begins at Wed 2019-11-20 22:42:09 CET, ends at Tue 2021-05-25 17:43:>
Mai 21 22:18:34 XXX kernel: ACPI Error: Needed type [Reference], found [Intege>
Mai 21 22:18:34 XXX kernel: ACPI Error: AE_AML_OPERAND_TYPE, While resolving o>
Mai 21 22:18:34 XXX kernel: ACPI Error: Aborting method \_PR.CPU0._PDC due to >
Mai 21 22:18:34 XXX systemd-modules-load[228]: Failed to find module 'vfs_moni>
Mai 21 22:18:35 XXX kernel: proc: Bad value for 'hidepid'
Mai 21 22:18:35 XXX kernel: proc: Bad value for 'hidepid'
Mai 21 22:18:35 XXX kernel: proc: Bad value for 'hidepid'
Mai 21 22:18:36 XXX kernel: kvm: disabled by bios
Mai 21 22:18:36 XXX kernel: kvm: disabled by bios
Mai 21 22:18:36 XXX kernel: kvm: disabled by bios
Mai 21 22:18:36 XXX kernel: kvm: disabled by bios
Mai 21 22:18:42 XXX lightdm[930]: gkr-pam: unable to locate daemon control file
Mai 21 22:18:47 XXX python[1147]: backintime (xxx/1): ERROR: Back In Time i>
Mai 21 22:21:30 XXX kernel: sd 3:0:0:0: [sdb] No Caching mode page found
Mai 21 22:21:30 XXX kernel: sd 3:0:0:0: [sdb] Assuming drive cache: write thro>
Mai 21 22:21:41 XXX kernel: ata1.00: exception Emask 0x10 SAct 0x800 SErr 0x28>
Mai 21 22:21:41 XXX kernel: ata1.00: irq_stat 0x08000000, interface fatal error
Mai 21 22:21:41 XXX kernel: ata1: SError: { UnrecovData 10B8B BadCRC }
Mai 21 22:21:41 XXX kernel: ata1.00: failed command: READ FPDMA QUEUED
Mai 21 22:21:41 XXX kernel: ata1.00: cmd 60/08:58:28:08:00/00:00:02:00:00/40 t>
                                      res 40/00:58:28:08:00/00:00:02:00:00/40 E>
Mai 21 22:21:41 XXX kernel: ata1.00: status: { DRDY }
lines 1-23...skipping...
-- Journal begins at Wed 2019-11-20 22:42:09 CET, ends at Tue 2021-05-25 17:43:43 CEST. --
Mai 21 22:18:34 XXX kernel: ACPI Error: Needed type [Reference], found [Integer] 00000000074eb251 (20190816/exresop-66)
Mai 21 22:18:34 XXX kernel: ACPI Error: AE_AML_OPERAND_TYPE, While resolving operands for [Store] (20190816/dswexec-431)
Mai 21 22:18:34 XXX kernel: ACPI Error: Aborting method \_PR.CPU0._PDC due to previous error (AE_AML_OPERAND_TYPE) (20190816/psparse-529)
Mai 21 22:18:34 XXX systemd-modules-load[228]: Failed to find module 'vfs_monitor'
Mai 21 22:18:35 XXX kernel: proc: Bad value for 'hidepid'
Mai 21 22:18:35 XXX kernel: proc: Bad value for 'hidepid'
Mai 21 22:18:35 XXX kernel: proc: Bad value for 'hidepid'
Mai 21 22:18:36 XXX kernel: kvm: disabled by bios
Mai 21 22:18:36 XXX kernel: kvm: disabled by bios
Mai 21 22:18:36 XXX kernel: kvm: disabled by bios
Mai 21 22:18:36 XXX kernel: kvm: disabled by bios
Mai 21 22:18:42 XXX lightdm[930]: gkr-pam: unable to locate daemon control file
Mai 21 22:18:47 XXX python[1147]: backintime (xxx/1): ERROR: Back In Time is not configured!
Mai 21 22:21:30 XXX kernel: sd 3:0:0:0: [sdb] No Caching mode page found
Mai 21 22:21:30 XXX kernel: sd 3:0:0:0: [sdb] Assuming drive cache: write through
Mai 21 22:21:41 XXX kernel: ata1.00: exception Emask 0x10 SAct 0x800 SErr 0x280100 action 0x6 frozen
Mai 21 22:21:41 XXX kernel: ata1.00: irq_stat 0x08000000, interface fatal error
Mai 21 22:21:41 XXX kernel: ata1: SError: { UnrecovData 10B8B BadCRC }
Mai 21 22:21:41 XXX kernel: ata1.00: failed command: READ FPDMA QUEUED
Mai 21 22:21:41 XXX kernel: ata1.00: cmd 60/08:58:28:08:00/00:00:02:00:00/40 tag 11 ncq dma 4096 in
                                      res 40/00:58:28:08:00/00:00:02:00:00/40 Emask 0x10 (ATA bus error)
Mai 21 22:21:41 XXX kernel: ata1.00: status: { DRDY }
Mai 21 22:21:42 XXX kernel: ata1.00: exception Emask 0x10 SAct 0x30 SErr 0x280100 action 0x6 frozen
Mai 21 22:21:42 XXX kernel: ata1.00: irq_stat 0x08000000, interface fatal error
Mai 21 22:21:42 XXX kernel: ata1: SError: { UnrecovData 10B8B BadCRC }
Mai 21 22:21:42 XXX kernel: ata1.00: failed command: READ FPDMA QUEUED
Mai 21 22:21:42 XXX kernel: ata1.00: cmd 60/00:20:00:b0:b7/04:00:0b:00:00/40 tag 4 ncq dma 524288 in
                                      res 40/00:20:00:b0:b7/00:00:0b:00:00/40 Emask 0x10 (ATA bus error)
Mai 21 22:21:42 XXX kernel: ata1.00: status: { DRDY }
Mai 21 22:21:42 XXX kernel: ata1.00: failed command: READ FPDMA QUEUED
Mai 21 22:21:42 XXX kernel: ata1.00: cmd 60/00:28:00:b4:b7/08:00:0b:00:00/40 tag 5 ncq dma 1048576 in
                                      res 40/00:20:00:b0:b7/00:00:0b:00:00/40 Emask 0x10 (ATA bus error)
Mai 21 22:21:42 XXX kernel: ata1.00: status: { DRDY }
Mai 21 22:21:43 XXX kernel: blk_update_request: I/O error, dev sda, sector 196587520 op 0x0:(READ) flags 0x80700 phys_seg 65 prio class 0
Mai 21 22:21:43 XXX kernel: blk_update_request: I/O error, dev sda, sector 196588544 op 0x0:(READ) flags 0x80700 phys_seg 126 prio class 0
Mai 21 22:21:43 XXX kernel: ata1.00: exception Emask 0x10 SAct 0x100180 SErr 0x280100 action 0x6 frozen
Mai 21 22:21:43 XXX kernel: ata1.00: irq_stat 0x08000000, interface fatal error
Mai 21 22:21:43 XXX kernel: ata1: SError: { UnrecovData 10B8B BadCRC }
Mai 21 22:21:43 XXX kernel: ata1.00: failed command: READ FPDMA QUEUED
Mai 21 22:21:43 XXX kernel: ata1.00: cmd 60/00:38:00:0c:b8/04:00:0b:00:00/40 tag 7 ncq dma 524288 in
                                      res 40/00:38:00:0c:b8/00:00:0b:00:00/40 Emask 0x10 (ATA bus error)
Mai 21 22:21:43 XXX kernel: ata1.00: status: { DRDY }
Mai 21 22:21:43 XXX kernel: ata1.00: failed command: READ FPDMA QUEUED
Mai 21 22:21:43 XXX kernel: ata1.00: cmd 60/00:40:00:10:b8/04:00:0b:00:00/40 tag 8 ncq dma 524288 in
                                      res 40/00:38:00:0c:b8/00:00:0b:00:00/40 Emask 0x10 (ATA bus error)
Mai 21 22:21:43 XXX kernel: ata1.00: status: { DRDY }
Mai 21 22:21:43 XXX kernel: ata1.00: failed command: READ FPDMA QUEUED
Mai 21 22:21:43 XXX kernel: ata1.00: cmd 60/20:a0:00:f0:0d/00:00:00:00:00/40 tag 20 ncq dma 16384 in
Die Hinweise, dass es an der zu vollen SSD liegen könnte, schaue ich mir noch genauer an und werde mal etwas aufräumen und wenn das passiert ist, mal einen Neustart wagen.
zompel hat geschrieben: Mittwoch 19. Mai 2021, 15:37 Läuft dein Notebook über Akku oder läuft es übers Netzteil?
Falls letzteres der Fall ist, funktioniert es auch noch wenn du den Akkublock herausnimmst?
Sowohl als auch und manchmal auch Docking-Station. In dem Thinkpad X250 sind ja 2 Akkus drin - ein fest verbauter und einen größeren, den man einfach rausnehmen kann. Letzteren hatte ich bei den endlosen Hochfahrversuchen rausgenommen (und auch nicht die Dockingstation benutzt), habe aber nicht den Eindruck, dass das irgendeinen Unterschied macht.

Zu der Bildschirmauflösung: Da ich nicht weiß, wie ich die BIOS-Version aktualisieren kann und Daemon ohnehin die Glaubwürdigkeit von inxi anzweifelt, kann ich mir leider aus der kleinen Diskussion nichts nehmen.

Bis bald!
Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 1647
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.19
Desktop-Variante: Openbox
GPU Treiber: i915
Hat sich bedankt: 8 Mal
Danksagung erhalten: 317 Mal

Re: Blackscreen nach dem Hochfahren

#21

Beitrag von gosia »

Hallo Idealist,
zumindest solche Meldungen
idealist hat geschrieben: Dienstag 25. Mai 2021, 18:05

Code: Alles auswählen

Mai 21 22:21:41 XXX kernel: ata1.00: exception Emask 0x10 SAct 0x800 SErr 0x280100 action 0x6 frozen
Mai 21 22:21:41 XXX kernel: ata1.00: irq_stat 0x08000000, interface fatal error
Mai 21 22:21:41 XXX kernel: ata1: SError: { UnrecovData 10B8B BadCRC }
Mai 21 22:21:41 XXX kernel: ata1.00: failed command: READ FPDMA QUEUED
könnten auf einen Hardwarefehler deuten, wobei Hardwarefehler ziemlich unspezifisch ist. Möglich wäre fehlerhafte Stromversorgung, Controllerprobleme, fehlerhafte oder schlechte Kabel bzw. Verbindung (Stecker) bis zu FP kurz vor dem Tod.
Würde auch gut zu "manchmal gehts, manchmal nicht" passen, sowas ist mehr Hardware- als Softwarespezifisch. Kann aber letzteres trotzdem nicht ausschliessen.
Dass wohl noch mehr im Argen liegt
idealist hat geschrieben: Dienstag 25. Mai 2021, 18:05 Back In Time is not configured!
ist ärgerlich, aber wohl kaum Ursache für deine Probleme.
Aber deine volle FP ist immer noch interessant, also wie vorgenommen aufräumen, aber auch mal irgendwie zeigen, was soviel Platz verbraucht.
Übrigens sind deine dmesg-Meldungen rechts abgeschnitten.

viele Grüße gosia
Benutzeravatar

Daemon
Forum Held
Forum Held
Beiträge: 600
Registriert: Freitag 22. Dezember 2017, 14:17
CPU: 6082
GPU: wtf
Kernel: pre-linux
Desktop-Variante: pre-linux
GPU Treiber: hab keine
Hat sich bedankt: 10 Mal
Danksagung erhalten: 69 Mal

Re: Blackscreen nach dem Hochfahren

#22

Beitrag von Daemon »

Ich habe mir mal die Fehlermeldungen angesehen, und die "Aussage" ist, dass das SATA Kabel, oder in deinem Fall der Steckplatz, nicht richtig funktioniert bzw. wackelt. Mach mal den Laptop hinten auf und stecke die SSD fest in den Stecker. Die SSD fällt ja hoffentlich nicht im Schacht rum, oder?
Siamo con il nostro Dio Scuro
Benutzeravatar

Manfrago
Forum Held
Forum Held
Beiträge: 693
Registriert: Dienstag 8. Dezember 2020, 17:23
Wohnort: Lubeca
CPU: ausschließlich i7/ 3.Gen.
GPU: Intel / Nvidia
Kernel: 5.4 / 5.10
Desktop-Variante: XFCE
GPU Treiber: Nvidia-390xx / Optimus qt
Hat sich bedankt: 17 Mal
Danksagung erhalten: 119 Mal

Re: Blackscreen nach dem Hochfahren

#23

Beitrag von Manfrago »

gosia hat geschrieben: Dienstag 25. Mai 2021, 18:44 Hallo Idealist,
zumindest solche Meldungen
idealist hat geschrieben: Dienstag 25. Mai 2021, 18:05

Code: Alles auswählen

Mai 21 22:21:41 XXX kernel: ata1.00: exception Emask 0x10 SAct 0x800 SErr 0x280100 action 0x6 frozen
Mai 21 22:21:41 XXX kernel: ata1.00: irq_stat 0x08000000, interface fatal error
Mai 21 22:21:41 XXX kernel: ata1: SError: { UnrecovData 10B8B BadCRC }
Mai 21 22:21:41 XXX kernel: ata1.00: failed command: READ FPDMA QUEUED
könnten auf einen Hardwarefehler deuten, wobei Hardwarefehler ziemlich unspezifisch ist.
Dann schauen wir doch einmal nach, wer eigentlich an ata1.00 hängt:

Code: Alles auswählen

ls -l /dev/disk/by-path/
Edit: Die Fehler-Meldungen 'hidepid' und 'kvm' sind unwichtig. Die habe ich auf allen meinen Lenovos und haben etwas mit nicht unterstützten Funktionen der installierten Kernel Version zu tun.
Ungesicherte Daten sind unwichtige Daten. Niemals einer Befehlszeile vertrauen, ohne zu wissen, was diese bewirkt.

Themen Author
idealist
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 12
Registriert: Dienstag 18. Mai 2021, 16:22
CPU: Dual Core model: Intel Core i5-5200U bits: 64 type: MT MCP
GPU: Intel HD Graphics 5500
Kernel: 5.4.116-1-MANJARO x86_64
Desktop-Variante: Xfce 4.16.0
GPU Treiber: i915 v
Hat sich bedankt: 13 Mal
Danksagung erhalten: 1 Mal

Re: Blackscreen nach dem Hochfahren

#24

Beitrag von idealist »

Manfrago hat geschrieben: Dienstag 25. Mai 2021, 19:49 Dann schauen wir doch einmal nach, wer eigentlich an ata1.00 hängt:

Code: Alles auswählen

ls -l /dev/disk/by-path/

Code: Alles auswählen

$ ls -l /dev/disk/by-path/
insgesamt 0
lrwxrwxrwx 1 root root  9 25. Mai 19:07 pci-0000:00:1f.2-ata-1 -> ../../sda
lrwxrwxrwx 1 root root  9 25. Mai 19:07 pci-0000:00:1f.2-ata-1.0 -> ../../sda
lrwxrwxrwx 1 root root 10 25. Mai 19:07 pci-0000:00:1f.2-ata-1.0-part1 -> ../../sda1
lrwxrwxrwx 1 root root 10 25. Mai 19:07 pci-0000:00:1f.2-ata-1-part1 -> ../../sda1
PS: bin noch am Aufräumen. Ein Neustart mit weniger als 90% war wieder ziemlich nervig. Also beim nächsten Mal schraub ichs auch mal auf :)
Benutzeravatar

Manfrago
Forum Held
Forum Held
Beiträge: 693
Registriert: Dienstag 8. Dezember 2020, 17:23
Wohnort: Lubeca
CPU: ausschließlich i7/ 3.Gen.
GPU: Intel / Nvidia
Kernel: 5.4 / 5.10
Desktop-Variante: XFCE
GPU Treiber: Nvidia-390xx / Optimus qt
Hat sich bedankt: 17 Mal
Danksagung erhalten: 119 Mal

Re: Blackscreen nach dem Hochfahren

#25

Beitrag von Manfrago »

idealist hat geschrieben: Sonntag 30. Mai 2021, 10:48 ...Also beim nächsten Mal schraub ichs auch mal auf :)
Also...wenn du deinen Lenovo ohnehin aufschraubst, dann wirst du wahrscheinlich feststellen, das in deinem X250 noch zwei M.2-Slots frei sind. (laut deiner Inxi-Ausgabe müsste das eigentlich so sein). Nun folgende Überlegung: In einen der Slots könntest du eine 256er M.2 SSD einbauen und darauf Manjaro mit deinen Anwendungen installieren. Danach kannst du ggfls dein Homeverzeichnis von der alten SSD rüberziehen und die alte SSD als Zusatzspeicher und/oder Timeshift Datensicherung vorsehen. Vorteil: Verdopplung des ohnehin knappen Speichers und keine schlaflosen Nächte mehr, weil entweder dein System auf der einen Platte läuft oder du es jederzeit von der anderen Platte wiederherstellen kannst. Kostenpunkt einer guten M.2 mit 256GB ca. 45 Euro. Aber Achtung: Ist wider Erwarten doch nur noch ein M.2 Slot frei, dann braucht es eventuell eine spezielle M.2 Karte beim Lenovo.
Ungesicherte Daten sind unwichtige Daten. Niemals einer Befehlszeile vertrauen, ohne zu wissen, was diese bewirkt.
Benutzeravatar

zompel
Forum Gott
Forum Gott
Beiträge: 286
Registriert: Montag 9. Dezember 2019, 19:52
Wohnort: Essen, NRW
CPU: Intel Core i9-9900KF
GPU: nVidia GeForce RTX 2070
Kernel: Linux 5.14
Desktop-Variante: Gnome
GPU Treiber: nVidia
Hat sich bedankt: 7 Mal
Danksagung erhalten: 56 Mal

Re: Blackscreen nach dem Hochfahren

#26

Beitrag von zompel »

@idealist
Was Manfrago vorgeschlagen hat wäre schon eine Überlegung wert (falls du 2 M.2 Slots hast), aber ich würde vielleicht vorher sogar noch einen Manjaro Lifestick erstellen.
Das Problem auszusitzen und solange damit arbeiten bis du wieder gezwungen bist zu booten könnte auch mal zu totalen Datenverlust führen wenn es wirklich ein Problem mit der SSD sein sollte.
So könntest du im Notfall wenigstens immer noch sofort ein System booten und würdest damit auch bestätigen dass es ein Problem mit dem Datenträger ist. Ob kalte Lötstelle, lockeres Kabel, defekte oder zu volle SSD muss man dann noch sehen.
Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 1647
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.19
Desktop-Variante: Openbox
GPU Treiber: i915
Hat sich bedankt: 8 Mal
Danksagung erhalten: 317 Mal

Re: Blackscreen nach dem Hochfahren

#27

Beitrag von gosia »

Hallo Idealist,
es ist auch keine schlechte Idee den Zustand deiner FP mit smartctl (aus den smartmontools) zu kontrollieren. Ginge auch graphisch und leichter lesbar mit GSmartControl
https://wiki.archlinux.org/title/S.M.A.R.T.

viele Grüße gosia

Thatsme
Forum Gott
Forum Gott
Beiträge: 337
Registriert: Dienstag 15. September 2020, 10:14
CPU: verschiedene
GPU: verschiedene
Kernel: LTS 5.4.105-1
Desktop-Variante: XFCE
GPU Treiber: free-nonfree, kommt darauf an, welcher aktuell funktioniert
Hat sich bedankt: 77 Mal
Danksagung erhalten: 23 Mal

Re: Blackscreen nach dem Hochfahren

#28

Beitrag von Thatsme »

gosia hat geschrieben: Sonntag 30. Mai 2021, 22:49 smartctl (aus den smartmontools) zu kontrollieren.
Hier noch eine Übersicht dazu, für nvme
https://www.smartmontools.org/wiki/NVMe_Support

Bei mir geht es unter Artix nur mit sudo.
Viele Tipps, die die Umwelt schonen https://www.smarticular.net/

Themen Author
idealist
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 12
Registriert: Dienstag 18. Mai 2021, 16:22
CPU: Dual Core model: Intel Core i5-5200U bits: 64 type: MT MCP
GPU: Intel HD Graphics 5500
Kernel: 5.4.116-1-MANJARO x86_64
Desktop-Variante: Xfce 4.16.0
GPU Treiber: i915 v
Hat sich bedankt: 13 Mal
Danksagung erhalten: 1 Mal

Re: Blackscreen nach dem Hochfahren

#29

Beitrag von idealist »

@goisa
Mit Paket-Cache konnte ich 2,38 GiB freimachen: "finished: 410 packages removed (disk space saved: 2.38 GiB)"
Das ist gut, aber nicht mein Hauptproblem.

@Manfrago, @gosia

Code: Alles auswählen

$ du -sh ~
161G	/home/xxx
Mit xxx habe ich meinen Benutzername anonymisiert.

@Manfrago @zompel
Danke für eure Gedanken zu M.2. Ehrlich gesagt überfordert das mich gerade mich da auch noch reinzudenken...

@gosia
Mit S.M.A.R.T hab ich mal einen Testlauf (short) gemacht: gab keine Fehler.


Generell habe ich den Eindruck, dass mein Verhältnis von belegtem zu gesamten Speicher ständig zunimmt zunimmt, auch wenn ich gar keine neuen Dateien speichere.

Ich mache gerade noch Backups. Ich hatte versucht die Festplatte mit dd zu klonen, bin mir aber nicht sicher obs funktioniert hat. Naja, also spätestens morgen meld ich mich nochmal, ob alles wieder funktioniert oder ob ich weiter verzweifle.

Danke für alles, auch wenn ich nicht immer bis ins letzte folgen kann :)
Benutzeravatar

Daemon
Forum Held
Forum Held
Beiträge: 600
Registriert: Freitag 22. Dezember 2017, 14:17
CPU: 6082
GPU: wtf
Kernel: pre-linux
Desktop-Variante: pre-linux
GPU Treiber: hab keine
Hat sich bedankt: 10 Mal
Danksagung erhalten: 69 Mal

Re: Blackscreen nach dem Hochfahren

#30

Beitrag von Daemon »

Mach mal ein Terminal auf und wechsele ins root Verzeichnis, also mit cd /
Dort gibst du dann folgendes ein:

Code: Alles auswählen

du -sh * | sort -hr | head -20
Das zeigt dir die Ordner der Größe nach sortiert.
Danach gehst du in den Ordner mit dem größten Speicherverbrauch, und machst den Befehl von eben nochmal. Das ganze Spiel halt bis du weisst wer der Verursacher ist.
Alternativ gibt es natrülich auch noch GUI Programme die das können, wie z.B. baobab, filelight, QDirStat, usw.

EDIT:
Oder noch besser für das Terminal ist folgendes.
Öffne deine .bashrc (oder .zshrc) mit einem Editor deiner Wahl, und füge folgendes ganz am Schluss ein:

Code: Alles auswählen

treesize () {
  du -k --max-depth=1 | sort -nr | awk '
     BEGIN {
        split("KB,MB,GB,TB", Units, ",");
     }
     {
        u = 1;
        while ($1 >= 1024) {
           $1 = $1 / 1024;
           u += 1
        }
        $1 = sprintf("%.1f %s", $1, Units[u]);
        print $0;
     }
    '
}
Falls das Terminal/Konsole noch offen ist, einmal schliessen und wieder öffnen, dann nur noch treesize im Terminal eingeben.
Damit siehst du auch versteckte Ordner. Bei mir z.B. ist der versteckte .cache Ordner 4GB groß.
Siamo con il nostro Dio Scuro
Antworten