Nvidia GTX 1650 neu installiert - Überprüfung korrekter Einbindung? Thema ist als GELÖST markiert

Probleme bei der Installation von Hardware unter Manjaro Linux? Hier wird geholfen.</span

Themen Author
Clemens
Forum Kenner
Forum Kenner
Beiträge: 155
Registriert: Donnerstag 9. Januar 2020, 18:16
Wohnort: Rottweil
CPU: Intel i5-7400
GPU: nVidia GTX 1650
Kernel: 5.5.19
DE: FXCE
GPU Treiber: Linux / nVidia free
Hat sich bedankt: 40 Mal
Danksagung erhalten: 1 Mal
Kontaktdaten:

Nvidia GTX 1650 neu installiert - Überprüfung korrekter Einbindung?

#1

#1 Beitrag von Clemens »

Hab mir jetzt eine passive Nvidia GTX 1650 in den PC gebaut. Zuvor lief der nur mit Intel OnChip-Grafik. Ziel ist, dem Videoschnittprogramm KDenlive für das Rendern die bestmögliche Hardware-Leistung zur Verfügung zu stellen.

Ich war erstaunt und glücklich, dass nach Einbau der Karte diese sofort von Manjaro erkannt und automatisch installiert wurde und das Ganze auf Anhieb funktioniert! – Aber ich weiß nicht, ob die Treiber optimal eingerichtet sind. So sind z.B. keine Open-CL-Treiber installiert. Es ist bei KDenlive im Gespräch, dass in der kommenden oder der darauf folgenden Version Open-CL unterstützt werden soll.

Nach Webrecherchen zu Nvidia unter Arch kann ich folgende Angaben zu meinem System machen:
1.) die an diesen Post angehängte Datei Xorg.0.log
Xorg.0.log.tar.gz
(11.93 KiB) 26-mal heruntergeladen
2.) Folgende Bestandteile zur Nvidia-Grafik fand ich im Pacman installiert:

Code: Alles auswählen

xf86-video-nouveau
mhwd-nvidia-340xx
mhwd-nvidia-390xx
mhwd-nvidia-418xx
mhwd-nvidia-430xx
mhwd-nvidia-435xx
mhwd-nvidia-440xx
lib32-libvdpau
libvdpau
libxnvctrl
xf86-video-nouveau
Laut Nouveau-Website hat meine Graka die Bezeichnung: NV167 (TU117) GeForce GTX 1650

Im System-Info finde ich zur Graka:

Code: Alles auswählen

nVidia TU117 (GeForce GTX 1650)
2540x1440
The X.Org Foundation 1.20.8
lvmpipe (LLVM 10.0.0, 256 bits)
Im Terminal führte ich aus:

Code: Alles auswählen

lspci -k | grep -A 2 -E "(VGA|3D)"

06:00.0 VGA compatible controller: NVIDIA Corporation TU117 [GeForce GTX 1650] (rev a1)
	Subsystem: NVIDIA Corporation TU117 [GeForce GTX 1650]
	Kernel driver in use: nouveau
Frage: Auf meinem PC spiele ich keine Spiele! Aber wie kann ich nun überprüfen, ob alle erforderlichen Treiber installiert sind und richtig konfiguriert sind, sodass ich die besten Ergebnisse unter KDenlive erhalte – speziell ein schnelles Rendern?


Themen Author
Clemens
Forum Kenner
Forum Kenner
Beiträge: 155
Registriert: Donnerstag 9. Januar 2020, 18:16
Wohnort: Rottweil
CPU: Intel i5-7400
GPU: nVidia GTX 1650
Kernel: 5.5.19
DE: FXCE
GPU Treiber: Linux / nVidia free
Hat sich bedankt: 40 Mal
Danksagung erhalten: 1 Mal
Kontaktdaten:

Re: Nvidia GTX 1650 neu installiert - Überprüfung korrekter Einbindung?

#2

#2 Beitrag von Clemens »

Hab soeben mein BIOS upgedatet. Eventuell wird die Graka nun etwas besser eingebunden und mit mehr Aufgaben belastet, da sie nun ca. 1 bis 2 Grad wärmer wird bei gleichen Aufgaben.

Nun erwartete ich aber auch beim Rendern unter KDenlive einen Geschwindigkeitszuwachs, auch wenn KDenlive noch kein Open-CL unterstützt (Verknüpfung des MLT-Framework mit Open-CL oder CUDA existiert noch immer nicht). Leider gab es keinen Geschwindigkeitsgewinn, egal wie ich KDenlive eingestellt habe.

Frage noch mal: Es gibt aus dem Repo multilib und dem Repo AUR verschiedene Open-CL Treiber für die Nvidia-Karte. Keiner davon ist bei mir installiert. Würde es mir etwas bringen, derartige Treiber zusätzlich zu den vorhandenen zu installieren? Oder besteht sogar die Gefahr, dass ich das stabil laufende derzeitige System beschädige statt einen Geschwindigkeitsvorteil mit KDenlive zu erreichen?
Was haben Windows und ein U-Boot gemeinsam? – Sobald man auch nur ein Fenster öffnet, gehen die Probleme los.


Daemon
Forum Gott
Forum Gott
Beiträge: 338
Registriert: Freitag 22. Dezember 2017, 14:17
CPU: 6082
GPU: wtf
Kernel: pre-linux
DE: pre-linux
GPU Treiber: hab keine
Hat sich bedankt: 2 Mal
Danksagung erhalten: 25 Mal

Re: Nvidia GTX 1650 neu installiert - Überprüfung korrekter Einbindung?

#3

#3 Beitrag von Daemon »

Ich habe keine nVidia Karte, kann das also nicht direkt nachstellen.
Aber, du musst OpenCL und auch den OpenCL nVidia Treiber (passend zu deinem Treiber) installieren.


Themen Author
Clemens
Forum Kenner
Forum Kenner
Beiträge: 155
Registriert: Donnerstag 9. Januar 2020, 18:16
Wohnort: Rottweil
CPU: Intel i5-7400
GPU: nVidia GTX 1650
Kernel: 5.5.19
DE: FXCE
GPU Treiber: Linux / nVidia free
Hat sich bedankt: 40 Mal
Danksagung erhalten: 1 Mal
Kontaktdaten:

Re: Nvidia GTX 1650 neu installiert - Überprüfung korrekter Einbindung?

#4

#4 Beitrag von Clemens »

Ich würd ja gerne experimentell die im Repo extra angebotenen opencl-nvidia Treiber installieren, habe aber Sorge, dass es zu Konflikten zu den bereits im System installierten Nvidia-Treibern kommt.

Ich sehe anhand der Bezeichnungen gewisse Zusammengehörigkeiten:

xf86-video-nouveau --- keine open-cl Entsprechung
mhwd-nvidia-340xx --- opencl-nvidia-340xx
mhwd-nvidia-390xx --- opencl-nvidia-390xx
mhwd-nvidia-418xx --- opencl-nvidia-418xx
mhwd-nvidia-430xx --- opencl-nvidia-430xx
mhwd-nvidia-435xx --- opencl-nvidia-435xx
mhwd-nvidia-440xx --- opencl-nvidia-440xx
lib32-libvdpau --- keine open-cl Entsprechung
libvdpau --- keine open-cl Entsprechung
libxnvctrl --- keine open-cl Entsprechung
xf86-video-nouveau --- keine open-cl Entsprechung

Hier verstehe ich nicht, wieso bereits jetzt mehrere "mhwd-nvidia-xxxx"-Treiber installiert sind und nicht nur einer.
Und was würde ich damit auslösen, wenn ich deren OpenCL-Pendant einfach zusätzlich installiere?
Im Manjaro-Einstellungsmanager finde ich unter "Hardwarekonfiguration" die Grafikkarte und unter TU117 (GeForce GTX 1650) die oben genannten mhwd-nvidia-Treiber, aber es sind nur die 440, 435, 430 und 418 aufglistet. Kein Treiber ist davon durch das Kontrollkästchen als "installiert" markiert.
video-linux ist installiert und sonst nichts.

Du schreibst, ich müsse außer dem OpenCL-Nvidia-Treiber (welchem???) auch generell Open-CL installieren. Gibt es da ein OpenCL-Framework, das ich vorher oder zusätzlich installieren müsste? – Bin etwas verwirrt darüber.
Was haben Windows und ein U-Boot gemeinsam? – Sobald man auch nur ein Fenster öffnet, gehen die Probleme los.


Daemon
Forum Gott
Forum Gott
Beiträge: 338
Registriert: Freitag 22. Dezember 2017, 14:17
CPU: 6082
GPU: wtf
Kernel: pre-linux
DE: pre-linux
GPU Treiber: hab keine
Hat sich bedankt: 2 Mal
Danksagung erhalten: 25 Mal

Re: Nvidia GTX 1650 neu installiert - Überprüfung korrekter Einbindung?

#5

#5 Beitrag von Daemon »

Welchen Treiber du brauchst liegt an deiner Grafikkarte, das weiß ich nicht. Ich schätze aber mal den 440xx ....

OpenCL ist eine Bibliothek, da braucht man kein Tool dafür. Die Programme die OpenCL benutzen, machen das dann automatisch (also auf die Bibliothek zugreifen).

Du brauchst OpenCL ansich, und dann noch den OpenCL NVidia Treiber. Das ist sozusagen die "Brücke" zwischen den beiden.


Themen Author
Clemens
Forum Kenner
Forum Kenner
Beiträge: 155
Registriert: Donnerstag 9. Januar 2020, 18:16
Wohnort: Rottweil
CPU: Intel i5-7400
GPU: nVidia GTX 1650
Kernel: 5.5.19
DE: FXCE
GPU Treiber: Linux / nVidia free
Hat sich bedankt: 40 Mal
Danksagung erhalten: 1 Mal
Kontaktdaten:

Re: Nvidia GTX 1650 neu installiert - Überprüfung korrekter Einbindung?

#6

#6 Beitrag von Clemens »

OK, wenn ich in Pacman auf den Treiber opencl-nvidia-440xx klicke, zeigt er mir unter "Abhängigkeiten" an, dass ein opencl-driver installiert wird und zusätzlich eben der opencl-nvidia-440.82
Anscheinend wird damit OpenCl und der Nvidia-Treiber gleichzeitig installiert.

Ferner weist Pacman darauf hin, dass der Treiber opencl-nvidia-440xx in Konflikt steht mit allen anderen opencl-nvidia-xxx.xx Treibern.

Nach wie vor bin ich in Sorge, dass nach Installation und Aktivierung von "opencl-nvidia-440.82" im ungünstigsten Fall der Bildschirm schwarz bleibt nach einem Reboot. Da würde mir nur helfen, vorher mit Clonezilla ein "Reserve-System" anzulegen. – Habe noch nie ein geclontes System wieder hergestellt! Das alles ist mir ein Graus.
Was haben Windows und ein U-Boot gemeinsam? – Sobald man auch nur ein Fenster öffnet, gehen die Probleme los.


Daemon
Forum Gott
Forum Gott
Beiträge: 338
Registriert: Freitag 22. Dezember 2017, 14:17
CPU: 6082
GPU: wtf
Kernel: pre-linux
DE: pre-linux
GPU Treiber: hab keine
Hat sich bedankt: 2 Mal
Danksagung erhalten: 25 Mal

Re: Nvidia GTX 1650 neu installiert - Überprüfung korrekter Einbindung?

#7

#7 Beitrag von Daemon »

Ab hier kann ich dir nicht mehr helfen, da ich die HW nicht habe. Ansonsten hätte ich es selbst mal probiert und eine "Anleitung" gemacht.

Benutzeravatar

zompel
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 57
Registriert: Montag 9. Dezember 2019, 19:52
CPU: Intel Core i9-9900KF
GPU: nVidia GeForce RTX 2070
Kernel: Linux 5.4 LTS
DE: Gnome 3.36
GPU Treiber: nVidia 440.xx
Hat sich bedankt: 3 Mal
Danksagung erhalten: 10 Mal

Re: Nvidia GTX 1650 neu installiert - Überprüfung korrekter Einbindung?

#8

#8 Beitrag von zompel »

Konflikte gibt es nur wenn du nicht die zum Treiber passende Implmentierung von OpenCL installierst.
Wenn es um Geschwindigkeit geht würde ich auf jeden Fall den proprietären Treiber über den Manjaro-Einstellungsmanager installieren.
... ist bei mir schon eine Weile her, aber ich meine du brauchst nur "Auto Install Proprietary Driver" anklicken und es wird die richtige Version installiert (bei mir der 440.82).
Anschließend installierst du die OpenCL Bibliotheken die zu der Treiberversion passen.
Es ist ja kein Graphiktreiber von daher wird da auch nichts passieren - hab es gerade einfach mal selber probiert ;)


Themen Author
Clemens
Forum Kenner
Forum Kenner
Beiträge: 155
Registriert: Donnerstag 9. Januar 2020, 18:16
Wohnort: Rottweil
CPU: Intel i5-7400
GPU: nVidia GTX 1650
Kernel: 5.5.19
DE: FXCE
GPU Treiber: Linux / nVidia free
Hat sich bedankt: 40 Mal
Danksagung erhalten: 1 Mal
Kontaktdaten:

Re: Nvidia GTX 1650 neu installiert - Überprüfung korrekter Einbindung?

#9

#9 Beitrag von Clemens »

Herzlichen Dank!

Mir geht Stabilität vor Geschwindigkeit. Deshalb habe ich die OpenSource-Treiber im Hardwaremanager ausgewählt. Im nachfolgenden Dialog wurden mir aber nicht die OpenCl-Treiber angeboten, sondern der Manager wollte aus den bereits installierten mhwd-nvidia-Treibern auswählen. Die sind aber nicht OpenCl.

Daher habe ich die mhwd-treiber mittels Pacman gelöscht, denn die waren ja eh nicht aktiv – zumindest wenn ich dem Hardwaremanager und den nicht aktivierten Checkboxen glaube. Zudem stand in Pacman bei diesen Treibern, dass sie nicht miteinander kompatibel sind und daher nur einer von denen im System aktiv sein sollte.

Wie die ganzen Nvidia-Treiber in mein System gekommen sind, weiß ich nicht. Ich hatte sie jedenfalls nicht installiert.

Nach der Deinstallation der mhwd-Treiber habe ich nun den OpenCl-Treiber opencl-nvidia-440.82-1 installiert. Dann habe ich den Hardwaremanager geöffnet und... fand dort keine Eintragungen mehr!!! – Den OpenCl-Treiber hätte ich jetzt dort erwartet! Statt dessen ist nichts mehr aufgeführt!

Nur wenn ich "alle Geräte anzeigen" anklicke, erhalte ich noch eine Geräteliste. Unter Multimedia controller finde ich:
Unbekannter Gerätename (nVidia Corporation)
Unter Display Controller finde ich "TU117 (GeForce GTX 1650) (nVidia Corporation)

Und egal welchen Eintrag eines Geräts ich anklicke, es erscheint kein Eintrag betreffend Treibern dazu.

Dann habe ich versucht, die Deinstallation der offensichtlich ja doch wichtigen mhwd-nvidia-Treiber rückgängig zu machen. Das gelang nicht, weil ein Konflikt der Abhängigkeiten gemeldet wurde. Also habe ich versucht, nur den mhwd-nvidia-440xx Treiber (extra) wieder zu installieren. Das gelang. Aber der Hardwaremanager bleibt leer.

In dem jetzigen Zustand sind leider die beiden Buttons für die automatische Installation der closed-source oder der open-source-Treiber nicht verfügbar.

Anscheinend habe ich jetzt leider genau das geschafft, wovor ich so viel Angst habe! – was nun????
Was haben Windows und ein U-Boot gemeinsam? – Sobald man auch nur ein Fenster öffnet, gehen die Probleme los.


Themen Author
Clemens
Forum Kenner
Forum Kenner
Beiträge: 155
Registriert: Donnerstag 9. Januar 2020, 18:16
Wohnort: Rottweil
CPU: Intel i5-7400
GPU: nVidia GTX 1650
Kernel: 5.5.19
DE: FXCE
GPU Treiber: Linux / nVidia free
Hat sich bedankt: 40 Mal
Danksagung erhalten: 1 Mal
Kontaktdaten:

Re: Nvidia GTX 1650 neu installiert - Überprüfung korrekter Einbindung?

#10

#10 Beitrag von Clemens »

OK, ich sehe jetzt in Pacman, dass die mhwd Komponenten weitgehend deinstalliert worden sind. mhwd bedeutet wohl Manjaro HardwareDevice.

Ehe ich jetzt weiter Schaden anrichte, schreibe ich erst mal, was ich zurzeit in Pacman sehen kann. Das einzige, was an mhwd-Komponenten installiert ist zurzeit ist:
mhwd-amdgpu und mhwd-ati

Es fehlen anscheinend mhwd-db und mhdw-nvidia und mhwd-nvidia-440xx.
Sollte ich diese Komponenten jetzt installieren, um das System sozusagen wieder zu heilen?
Was haben Windows und ein U-Boot gemeinsam? – Sobald man auch nur ein Fenster öffnet, gehen die Probleme los.

Benutzeravatar

zompel
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 57
Registriert: Montag 9. Dezember 2019, 19:52
CPU: Intel Core i9-9900KF
GPU: nVidia GeForce RTX 2070
Kernel: Linux 5.4 LTS
DE: Gnome 3.36
GPU Treiber: nVidia 440.xx
Hat sich bedankt: 3 Mal
Danksagung erhalten: 10 Mal

Re: Nvidia GTX 1650 neu installiert - Überprüfung korrekter Einbindung?

#11

#11 Beitrag von zompel »

Bei mir sind folgende "mhwd"-Pakete installiert:

mhwd
mhwd-amdgpu
mhwd-ati
mhwd-db
mhwd-nvidia-340xx
mhwd-nvidia-390xx
mhwd-nvidia-418xx
mhwd-nvidia-430xx
mhwd-nvidia-435xx
mhwd-nvidia-440xx
mhwd-tui

Es sind ja nur ID-Listen um die Hardware korrekt zu erkennen um den richtigen Treiber anzubieten. Installiere mal ruhig alle wieder nach.


Themen Author
Clemens
Forum Kenner
Forum Kenner
Beiträge: 155
Registriert: Donnerstag 9. Januar 2020, 18:16
Wohnort: Rottweil
CPU: Intel i5-7400
GPU: nVidia GTX 1650
Kernel: 5.5.19
DE: FXCE
GPU Treiber: Linux / nVidia free
Hat sich bedankt: 40 Mal
Danksagung erhalten: 1 Mal
Kontaktdaten:

Re: Nvidia GTX 1650 neu installiert - Überprüfung korrekter Einbindung?

#12

#12 Beitrag von Clemens »

OK, gerettet! Herzlichen Dank!
Hab das so wieder installiert, wie du es gelistet hast. So war das auch vorher bei mir installiert. Zusätzlich habe ich aus dem "extra" Repo noch den opencl-nvidia-440.82 installiert, wie oben beschrieben.

Dann habe ich den Button zur automatischen Installation der freien nVidia-Treiber geklickt und nach kurzer zeit (Ladebalken) kam ein OK. Sicherheitshalber habe ich noch mal rebootet.

Dieser opencl-nvidia wird aber nicht im Hardwaremanager aufgeführt, so wie z.B. der mhwd-nvidia-440xx und die anderen.

Dann habe ich die Treiber im System mit mhwd -l -d geprüft und erhielt:

Code: Alles auswählen

$ mhwd -l -d
--------------------------------------------------------------------------------
> PCI Device: /devices/pci0000:00/0000:00:1c.4/0000:06:00.0 (0300:10de:1f82)
  Display controller nVidia Corporation TU117 [GeForce GTX 1650]
--------------------------------------------------------------------------------
  > INSTALLED:
   NAME:	video-linux
   ATTACHED:	PCI
   VERSION:	2018.05.04
   INFO:	Standard open source drivers.
   PRIORITY:	2
   FREEDRIVER:	true
   DEPENDS:	-
   CONFLICTS:	-
   CLASSIDS:	0300 0380 0302 
   VENDORIDS:	1002 8086 10de 

  > AVAILABLE:
   NAME:	video-nvidia-440xx
   ATTACHED:	PCI
   VERSION:	2019.10.25
   INFO:	Closed source NVIDIA drivers for linux.
   PRIORITY:	8
   FREEDRIVER:	false
   DEPENDS:	-
   CONFLICTS:	video-hybrid-intel-nvidia-340xx-bumblebee video-hybrid-intel-nvidia-390xx-bumblebee video-hybrid-intel-nvidia-418xx-bumblebee video-hybrid-intel-nvidia-430xx-bumblebee video-hybrid-intel-nvidia-435xx-prime video-hybrid-intel-nvidia-440xx-prime video-nvidia-340xx video-nvidia-390xx video-nvidia-418xx video-nvidia-430xx video-nvidia-435xxs 
   CLASSIDS:	0300 0302 
   VENDORIDS:	10de 

   NAME:	video-nvidia-435xx
   ATTACHED:	PCI
   VERSION:	2019.10.25
   INFO:	Closed source NVIDIA drivers for linux.
   PRIORITY:	7
   FREEDRIVER:	false
   DEPENDS:	-
   CONFLICTS:	video-hybrid-intel-nvidia-340xx-bumblebee video-hybrid-intel-nvidia-390xx-bumblebee video-hybrid-intel-nvidia-418xx-bumblebee video-hybrid-intel-nvidia-430xx-bumblebee video-hybrid-intel-nvidia-435xx-prime video-hybrid-intel-nvidia-440xx-prime video-nvidia-340xx video-nvidia-390xx video-nvidia-418xx video-nvidia-430xx video-nvidia-440xx 
   CLASSIDS:	0300 0302 
   VENDORIDS:	10de 

   NAME:	video-nvidia-430xx
   ATTACHED:	PCI
   VERSION:	2019.10.25
   INFO:	Closed source NVIDIA drivers for linux.
   PRIORITY:	6
   FREEDRIVER:	false
   DEPENDS:	-
   CONFLICTS:	video-hybrid-intel-nvidia-340xx-bumblebee video-hybrid-intel-nvidia-390xx-bumblebee video-hybrid-intel-nvidia-418xx-bumblebee video-hybrid-intel-nvidia-430xx-bumblebee video-hybrid-intel-nvidia-435xx-prime video-hybrid-intel-nvidia-440xx-prime video-nvidia-340xx video-nvidia-390xx video-nvidia-418xx video-nvidia-435xx video-nvidia-440xx 
   CLASSIDS:	0300 0302 
   VENDORIDS:	10de 

   NAME:	video-nvidia-418xx
   ATTACHED:	PCI
   VERSION:	2019.10.25
   INFO:	Closed source NVIDIA drivers for linux.
   PRIORITY:	5
   FREEDRIVER:	false
   DEPENDS:	-
   CONFLICTS:	video-hybrid-intel-nvidia-340xx-bumblebee video-hybrid-intel-nvidia-390xx-bumblebee video-hybrid-intel-nvidia-418xx-bumblebee video-hybrid-intel-nvidia-430xx-bumblebee video-hybrid-intel-nvidia-435xx-prime video-hybrid-intel-nvidia-440xx-prime video-nvidia-340xx video-nvidia-390xx video-nvidia-430xx video-nvidia-435xx video-nvidia-440xx 
   CLASSIDS:	0300 0302 
   VENDORIDS:	10de 

   NAME:	video-linux
   ATTACHED:	PCI
   VERSION:	2018.05.04
   INFO:	Standard open source drivers.
   PRIORITY:	2
   FREEDRIVER:	true
   DEPENDS:	-
   CONFLICTS:	-
   CLASSIDS:	0300 0380 0302 
   VENDORIDS:	1002 8086 10de 

   NAME:	video-modesetting
   ATTACHED:	PCI
   VERSION:	2020.01.13
   INFO:	X.org modesetting video driver.
   PRIORITY:	1
   FREEDRIVER:	true
   DEPENDS:	-
   CONFLICTS:	-
   CLASSIDS:	0300 
   VENDORIDS:	* 

   NAME:	video-vesa
   ATTACHED:	PCI
   VERSION:	2017.03.12
   INFO:	X.org vesa video driver.
   PRIORITY:	0
   FREEDRIVER:	true
   DEPENDS:	-
   CONFLICTS:	-
   CLASSIDS:	0300 
   VENDORIDS:	* 

--------------------------------------------------------------------------------
> PCI Device: /devices/pci0000:00/0000:00:1c.3/0000:05:00.0 (0200:10ec:8168)
  Network controller Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
--------------------------------------------------------------------------------
  > AVAILABLE:
   NAME:	network-r8168
   ATTACHED:	PCI
   VERSION:	2016.04.20
   INFO:	RealTek RTL-8168 Gigabit Ethernet driver
   PRIORITY:	0
   FREEDRIVER:	true
   DEPENDS:	-
   CONFLICTS:	-
   CLASSIDS:	0200 
   VENDORIDS:	1186 10ec 

Warning: no configs for USB devices found!
Daraus entnehme ich, dass trotz aller Bemühungen immer noch kein opencl-nvidia-Treiber aktiv ist und die Graka in einem einfachen Standard-Modus läuft.

Außerdem stelle ich fest, dass alle hier aufgeführten nVidia-Treiber als closed source gekennzeichnet sind, obwohl ich doch open source bzw. "free" haben wollte. Ich hatte nie bisher etwas "closed source"-mäßiges auf meinem System installiert!

Zusätzlich entdecke ich nun, dass wohl auch ein USB-Problem besteht, von dem ich noch nichts wusste! Oder bedeutet die Meldung nur, dass der mhwd im aktuellen Zustand die USB devices nicht verwalten kann?

inxi -G liefert mir:

Code: Alles auswählen

$ inxi -G
Graphics:
  Device-1: NVIDIA TU117 [GeForce GTX 1650] driver: nouveau v: kernel 
  Display: x11 server: X.Org 1.20.8 driver: modesetting,nouveau 
  resolution: 2560x1440~60Hz 
  OpenGL: renderer: llvmpipe (LLVM 10.0.0 256 bits) v: 3.3 Mesa 20.0.5 
Im Hardware-Manager wird unter Display-Controller nach wie vor angezeigt:
video-nvidia-440xx - - keine Checkbox aktiviert
video-nvidia-435xx - - keine Checkbox aktiviert
video-nvidia-430xx - - keine Checkbox aktiviert
video-nvidia-418xx - - keine Checkbox aktiviert
video-linux Checkbox offene Quellen und Checkbox "installiert" aktiviert
video-modesetting nur Checkbox "offene Quellen" aktiviert
video-vesa nur Checkbox "offene Quellen" aktiviert

Im Pacman finde ich keine weiteren opencl-Treiber. Oder soll ich im Hardwaremanager die beiden Checkboxen zu "video-nvidia-440xx aktivieren? Wenn ja, warum hat die Funktion "Auto Install Open-Source Driver das nicht erledigt? Weil diese Treiber gemäß Terminal-Auskunft eben doch "closed source" sind?

Was tun?

Benutzeravatar

zompel
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 57
Registriert: Montag 9. Dezember 2019, 19:52
CPU: Intel Core i9-9900KF
GPU: nVidia GeForce RTX 2070
Kernel: Linux 5.4 LTS
DE: Gnome 3.36
GPU Treiber: nVidia 440.xx
Hat sich bedankt: 3 Mal
Danksagung erhalten: 10 Mal

Re: Nvidia GTX 1650 neu installiert - Überprüfung korrekter Einbindung?

#13

#13 Beitrag von zompel »

Der Manjaro-Einstellungsmanager listet nur die möglichen Treiber auf, aber nur die mit Häkchen versehenen Treiber sind auch installiert, also ist alles ok.
Ich bin auch kein Experte, aber ich vermute dass die USB-Meldung nichts zu bedeuten hat. Wahrscheinlich wurden einfach nur keine weiteren Geräte am USB-Port erkannt. Wenn nichts angeschlossen war, oder z.B. der Drucker ausgeschaltet war mach dir keine Gedanken darüber.

Was OpenCL betrifft... nach meinem Verständnis sind das eher Bibliotheken zu Programmierung der GrafikChips welche bestimmte Berechnungen wesentlich schneller durchführen können als CPUs. OpenCL liegt so lange ungenutzt auf deinem System herum bis es ein Programm explizit anfordert. Ob es allerdings auch mit den nuveau Treibern funktioniert kann ich nicht sagen. Programme die OpenCL nutzen werden wahrscheinlich mit dem Grafiktreiber in Konflikt kommen wenn sie nicht zueinander passen. Deshalb gibt es ja auch die verschiedenen Versionen der OpenCL Pakete.

edit:
Hab gerade noch mal gelesen was Daemon geschrieben hat. Ich werde (wahrscheinlich) heute abend noch mal bei mir zu Hause nachschauen, ob es neben dem treiberspezifischen OpenCL-Paket noch eine weitere allgemeine OpenCL-Bibliothek gibt. Aber das treiberspezifische Paket wirst du auf jeden Fall wegen der oben erwähnten Konflikte brauchen.

edit2:

Installiere mal "clinfo" und sieh was das Programm ausgibt.
Zuletzt geändert von zompel am Dienstag 28. April 2020, 09:02, insgesamt 1-mal geändert.


Themen Author
Clemens
Forum Kenner
Forum Kenner
Beiträge: 155
Registriert: Donnerstag 9. Januar 2020, 18:16
Wohnort: Rottweil
CPU: Intel i5-7400
GPU: nVidia GTX 1650
Kernel: 5.5.19
DE: FXCE
GPU Treiber: Linux / nVidia free
Hat sich bedankt: 40 Mal
Danksagung erhalten: 1 Mal
Kontaktdaten:

Re: Nvidia GTX 1650 neu installiert - Überprüfung korrekter Einbindung?

#14

#14 Beitrag von Clemens »

So früh schon wieder am PC? :-) Herzlichen Dank für deine Antwort.

Mein System läuft auch nach den zuletzt vorgenommenen Änderungen stabil und mit einwandfreier Grafik-Darstellung – nutzt aber offensichtlich die Potenziale der Grafikkarte keinesfalls aus.

Ich hab jetzt weiter geschaut und dies hier gefunden: https://wiki.archlinux.org/index.php/FF ... celeration

Kdenlive arbeitet mit ffmpeg. Da es aber zwischen dem MLT-Framework und OpenCl noch keine Verbindung gibt, kann man nach dem o.g. Link anscheinend über den proprietären nVidia-Treiber und NVencode sowie NVdecode zusammen mit ffmpeg eine deutliche Beschleunigung erreichen.

Damit nun meine Investition in die Graka nicht ganz für die Katz ist, wäre es angesichts dieser Info doch vernünftig, den proprietären nVidia-Treiber zu benutzen, so wie du es zu Anfang mir geraten hattest. ZU dem Zeitpunkt hatte ich aber die Information betr. NVencode und NVdecode und ffmpeg noch nicht. Das Zusammenspiel wird auf der nVidia-Website hier https://developer.nvidia.com/nvidia-video-codec-sdk genauer beschrieben. Demnach erreicht man mit NVencode und NCdecode fast schon Geschwindigkeiten wie mit CUDA.
Wenn das so ist, dann stelle ich mal die Frage betr. OpenCl usw. nach hinten.

Meine (hoffentlich letzte) Frage also: Kann ich beim derzeitigen Stand meines Systems mittels Hardware-Manager einfach durch Betätigung des Button "Auto Install Proprietary Driver" von den derzeitigen auf die proprietären Nvidia-Treibern wechseln? Oder muss ich zuvor noch etwas via Pacman installieren oder deinstallieren?

Benutzeravatar

zompel
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 57
Registriert: Montag 9. Dezember 2019, 19:52
CPU: Intel Core i9-9900KF
GPU: nVidia GeForce RTX 2070
Kernel: Linux 5.4 LTS
DE: Gnome 3.36
GPU Treiber: nVidia 440.xx
Hat sich bedankt: 3 Mal
Danksagung erhalten: 10 Mal

Re: Nvidia GTX 1650 neu installiert - Überprüfung korrekter Einbindung?

#15

#15 Beitrag von zompel »

Deswegen heißt es ja "Auto Install..." ;D

...nein eigentlich sollte alles glatt laufen. wie gerade noch oben erwähnt - könntest du ja trotzdem noch mal das Programm clinfo installieren um zu sehen ob alles nötige Vorhanden ist.

Antworten