Device "eth0" does not exist ??? Thema ist als GELÖST markiert

Probleme bei der Installation von Hardware unter Manjaro Linux? Hier wird geholfen.</span
Benutzeravatar

Themen Author
Terrorizer
Forum Kenner
Forum Kenner
Beiträge: 117
Registriert: Sonntag 29. Januar 2017, 14:28
CPU: AMD A10-4655M
GPU: AMD® Aruba
Kernel: LTS
DE: Awesome
GPU Treiber: Free
Hat sich bedankt: 7 Mal
Danksagung erhalten: 4 Mal
Kontaktdaten:

Re: Device "eth0" does not exist ???

#31

#31 Beitrag von Terrorizer »

gosia hat geschrieben:
Dienstag 15. Oktober 2019, 23:05

PS. Ich benutze auch kein Manjaro.
... wieso benutzt ihr alle kein Manjaro, Daemon & Gosia was nutzt ihr denn ???
>>> AMD® A10-4655m apu with radeon(tm) hd graphics × 4 <<<
>>> AMD® Aruba <<<
>>> Manjaro Linux Awesome <<<

>>> Si vis pacem para bellum <<<

Benutzeravatar

Themen Author
Terrorizer
Forum Kenner
Forum Kenner
Beiträge: 117
Registriert: Sonntag 29. Januar 2017, 14:28
CPU: AMD A10-4655M
GPU: AMD® Aruba
Kernel: LTS
DE: Awesome
GPU Treiber: Free
Hat sich bedankt: 7 Mal
Danksagung erhalten: 4 Mal
Kontaktdaten:

Re: Device "eth0" does not exist ???

#32

#32 Beitrag von Terrorizer »

gosia hat geschrieben:
Dienstag 15. Oktober 2019, 23:05
Terrorizer hat geschrieben:
Dienstag 15. Oktober 2019, 11:49
cp: reguläre Datei '/etc/resolv. conf' kann nicht angelegt werden: Die Operation ist nicht erlaubt
Nach dieser Meldung hast Du einfach ein Leerzeichen zuviel eingegeben. Nicht

Code: Alles auswählen

resolv. conf
sondern

Code: Alles auswählen

resolv.conf
viele Grüße gosia

PS. Ich benutze auch kein Manjaro.
... habe das ganze gerade mit copy & paste probiert >>> kommt die gleiche Meldung:

Code: Alles auswählen

sudo cp /etc/resolv.conf.bak /etc/resolv.conf
cp: reguläre Datei '/etc/resolv.conf' kann nicht angelegt werden: Die Operation ist nicht erlaubt

... langsam verzweifel ich :-[
>>> AMD® A10-4655m apu with radeon(tm) hd graphics × 4 <<<
>>> AMD® Aruba <<<
>>> Manjaro Linux Awesome <<<

>>> Si vis pacem para bellum <<<

Benutzeravatar

Themen Author
Terrorizer
Forum Kenner
Forum Kenner
Beiträge: 117
Registriert: Sonntag 29. Januar 2017, 14:28
CPU: AMD A10-4655M
GPU: AMD® Aruba
Kernel: LTS
DE: Awesome
GPU Treiber: Free
Hat sich bedankt: 7 Mal
Danksagung erhalten: 4 Mal
Kontaktdaten:

Re: Device "eth0" does not exist ???

#33

#33 Beitrag von Terrorizer »

... ich wollte jetzt mit

Code: Alles auswählen

sudo rm -f /etc/resolv.conf
die Datei erst mal löschen, dann kommt

Code: Alles auswählen

rm: das Entfernen von '/etc/resolv.conf' ist nicht möglich: Die Operation ist nicht erlaubt
>>> kann ich nicht irgendwie abgesichert starten & dann den Befehl ausführen ???
>>> AMD® A10-4655m apu with radeon(tm) hd graphics × 4 <<<
>>> AMD® Aruba <<<
>>> Manjaro Linux Awesome <<<

>>> Si vis pacem para bellum <<<

Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 1037
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.19
DE: Openbox
GPU Treiber: i915
Hat sich bedankt: 6 Mal
Danksagung erhalten: 129 Mal

Re: Device "eth0" does not exist ???

#34

#34 Beitrag von gosia »

Hallo Terrorizer,
irgendwas ist da faul.
Sollte zwar nicht sein, aber probiere mal folgendes:
Stelle im NetworkManager mal wieder auf dein VPN um und teste, ob so die Internetverbindung funktioniert. Dann mach die Verbindung wieder zu und starte mit der "normalen" Verbindung, also über Ethernet. Anschliessend nachsehen

Code: Alles auswählen

cat /etc/resolv.conf
ob sich was am Inhalt geändert hat. Ist nur so eine verrückte Idee, aber warum nicht.
Außerdem poste mal unbedingt die Ausgabe von diesem Befehl:

Code: Alles auswählen

ls -l /etc/resolv.conf*
Copy&Paste, damit das Sternchen * am Ende nicht verloren geht ;)
Terrorizer hat geschrieben:
Dienstag 15. Oktober 2019, 23:21
wieso benutzt ihr alle kein Manjaro, ... Gosia was nutzt ihr denn
Ich benutze kein Manjaro mehr, weil Manjaro systemD benutzt >:D
Ich benutze Artix und MX Linux.

viele Grüße gosia

Benutzeravatar

Themen Author
Terrorizer
Forum Kenner
Forum Kenner
Beiträge: 117
Registriert: Sonntag 29. Januar 2017, 14:28
CPU: AMD A10-4655M
GPU: AMD® Aruba
Kernel: LTS
DE: Awesome
GPU Treiber: Free
Hat sich bedankt: 7 Mal
Danksagung erhalten: 4 Mal
Kontaktdaten:

Re: Device "eth0" does not exist ???

#35

#35 Beitrag von Terrorizer »

gosia hat geschrieben:
Mittwoch 16. Oktober 2019, 11:41
Hallo Terrorizer,
irgendwas ist da faul.
Sollte zwar nicht sein, aber probiere mal folgendes:
Stelle im NetworkManager mal wieder auf dein VPN um und teste, ob so die Internetverbindung funktioniert. Dann mach die Verbindung wieder zu und starte mit der "normalen" Verbindung, also über Ethernet. Anschliessend nachsehen

Code: Alles auswählen

cat /etc/resolv.conf
ob sich was am Inhalt geändert hat. Ist nur so eine verrückte Idee, aber warum nicht.
Außerdem poste mal unbedingt die Ausgabe von diesem Befehl:

Code: Alles auswählen

ls -l /etc/resolv.conf*
Copy&Paste, damit das Sternchen * am Ende nicht verloren geht ;)
Terrorizer hat geschrieben:
Dienstag 15. Oktober 2019, 23:21
wieso benutzt ihr alle kein Manjaro, ... Gosia was nutzt ihr denn
Ich benutze kein Manjaro mehr, weil Manjaro systemD benutzt >:D
Ich benutze Artix und MX Linux.

viele Grüße gosia
... der NordVPN funktioniert bei mir nicht über den NetworkManager, sondern mit dem installierten

Code: Alles auswählen

nordvpn-bin 3.3.1_3-1
über Konsolenbefehle, hab jetzt zwar per Konsole mal versucht zu connecten & disconnecten usw. aber er sagt er wäre nicht connected.


... die Ausgabe Deines Befehls:

Code: Alles auswählen

ls -l /etc/resolv.conf*

-rw-r--r-- 1 root root  74 11. Okt 15:35 /etc/resolv.conf
-rw-r--r-- 1 root root 109 11. Okt 15:35 /etc/resolv.conf.bak
-rw-r--r-- 1 root root  65 28. Aug 21:58 /etc/resolv.conf.pacnew
-rw-r--r-- 1 root root 109 18. Mai 07:23 /etc/resolv.conf.qomui.bak

>>> AMD® A10-4655m apu with radeon(tm) hd graphics × 4 <<<
>>> AMD® Aruba <<<
>>> Manjaro Linux Awesome <<<

>>> Si vis pacem para bellum <<<

Benutzeravatar

Themen Author
Terrorizer
Forum Kenner
Forum Kenner
Beiträge: 117
Registriert: Sonntag 29. Januar 2017, 14:28
CPU: AMD A10-4655M
GPU: AMD® Aruba
Kernel: LTS
DE: Awesome
GPU Treiber: Free
Hat sich bedankt: 7 Mal
Danksagung erhalten: 4 Mal
Kontaktdaten:

Re: Device "eth0" does not exist ???

#36

#36 Beitrag von Terrorizer »

... was ist an systemD verkehrt?
>>> AMD® A10-4655m apu with radeon(tm) hd graphics × 4 <<<
>>> AMD® Aruba <<<
>>> Manjaro Linux Awesome <<<

>>> Si vis pacem para bellum <<<

Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 1037
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.19
DE: Openbox
GPU Treiber: i915
Hat sich bedankt: 6 Mal
Danksagung erhalten: 129 Mal

Re: Device "eth0" does not exist ???

#37

#37 Beitrag von gosia »

Hallo Terrorizer,
Terrorizer hat geschrieben:
Mittwoch 16. Oktober 2019, 12:07
hab jetzt zwar per Konsole mal versucht zu connecten & disconnecten usw. aber er sagt er wäre nicht connected.
Na gut, habe nichts anderes erwartet, aber einen Versuch war es wert.
Terrorizer hat geschrieben:
Mittwoch 16. Oktober 2019, 12:07

Code: Alles auswählen

ls -l /etc/resolv.conf*
-rw-r--r-- 1 root root  74 11. Okt 15:35 /etc/resolv.conf
-rw-r--r-- 1 root root 109 11. Okt 15:35 /etc/resolv.conf.bak
-rw-r--r-- 1 root root  65 28. Aug 21:58 /etc/resolv.conf.pacnew
-rw-r--r-- 1 root root 109 18. Mai 07:23 /etc/resolv.conf.qomui.bak
Sehe nicht, was dich hindern sollte, als root die resolv.conf zu löschen oder umzubennen. Nur als Nebenbemerkung wegen /etc/resolv.conf.pacnew: Hast Du jemals die vom Paketmanager eingespielten neuen Konfigurationen (*.pacnew) mit den vorhandenen abgeglichen und bei Bedarf die neuen benutzt? Bin mir sicher, daß sich da noch mehr *.pacnew auf deinem Rechner rumtreiben.
https://wiki.manjaro.org/index.php?titl ... save_files
Terrorizer hat geschrieben:
Mittwoch 16. Oktober 2019, 12:12
was ist an systemD verkehrt?
Alles. Der ganze Ansatz, statt eines Initsystems einen Risenkraken einzubauen, der a la Windows-Registry sich um alles und jedes kümmen möchte und dabei das KISS-Prinzp (Keep it simple, stupid) verletzt. Aber das ist ein ganz anderes Thema und ein sehr weites Feld.

viele Grüße gosia

Benutzeravatar

Themen Author
Terrorizer
Forum Kenner
Forum Kenner
Beiträge: 117
Registriert: Sonntag 29. Januar 2017, 14:28
CPU: AMD A10-4655M
GPU: AMD® Aruba
Kernel: LTS
DE: Awesome
GPU Treiber: Free
Hat sich bedankt: 7 Mal
Danksagung erhalten: 4 Mal
Kontaktdaten:

Re: Device "eth0" does not exist ???

#38

#38 Beitrag von Terrorizer »

gosia hat geschrieben:
Mittwoch 16. Oktober 2019, 14:25
Hallo Terrorizer,
Terrorizer hat geschrieben:
Mittwoch 16. Oktober 2019, 12:07
hab jetzt zwar per Konsole mal versucht zu connecten & disconnecten usw. aber er sagt er wäre nicht connected.
Na gut, habe nichts anderes erwartet, aber einen Versuch war es wert.
Terrorizer hat geschrieben:
Mittwoch 16. Oktober 2019, 12:07

Code: Alles auswählen

ls -l /etc/resolv.conf*
-rw-r--r-- 1 root root  74 11. Okt 15:35 /etc/resolv.conf
-rw-r--r-- 1 root root 109 11. Okt 15:35 /etc/resolv.conf.bak
-rw-r--r-- 1 root root  65 28. Aug 21:58 /etc/resolv.conf.pacnew
-rw-r--r-- 1 root root 109 18. Mai 07:23 /etc/resolv.conf.qomui.bak
Sehe nicht, was dich hindern sollte, als root die resolv.conf zu löschen oder umzubennen. Nur als Nebenbemerkung wegen /etc/resolv.conf.pacnew: Hast Du jemals die vom Paketmanager eingespielten neuen Konfigurationen (*.pacnew) mit den vorhandenen abgeglichen und bei Bedarf die neuen benutzt? Bin mir sicher, daß sich da noch mehr *.pacnew auf deinem Rechner rumtreiben.
https://wiki.manjaro.org/index.php?titl ... save_files
Terrorizer hat geschrieben:
Mittwoch 16. Oktober 2019, 12:12
was ist an systemD verkehrt?
Alles. Der ganze Ansatz, statt eines Initsystems einen Risenkraken einzubauen, der a la Windows-Registry sich um alles und jedes kümmen möchte und dabei das KISS-Prinzp (Keep it simple, stupid) verletzt. Aber das ist ein ganz anderes Thema und ein sehr weites Feld.

viele Grüße gosia
... ja und wie gehe ich jetzt vor, oder ist eine Neuinstallation unabwendbar???
>>> AMD® A10-4655m apu with radeon(tm) hd graphics × 4 <<<
>>> AMD® Aruba <<<
>>> Manjaro Linux Awesome <<<

>>> Si vis pacem para bellum <<<


Daemon
Forum Gott
Forum Gott
Beiträge: 276
Registriert: Freitag 22. Dezember 2017, 14:17
CPU: 6082
GPU: wtf
Kernel: pre-linux
DE: pre-linux
GPU Treiber: hab keine
Hat sich bedankt: 1 Mal
Danksagung erhalten: 15 Mal

Re: Device "eth0" does not exist ???

#39

#39 Beitrag von Daemon »

Mach mal in der Konsole folgendes:

Code: Alles auswählen

sudo find / -name "*.pacnew"
Der Befehl spuckt dir dann sämtliche pacnew Dateien aus.

Geht aber wahrscheinlich nicht, da ja sudo nicht geht.

Ganz ehrlich, wenn sudo schon nicht mehr geht, hilft wahrscheinlich nur noch eine Neuinstallation.

Benutzeravatar

Themen Author
Terrorizer
Forum Kenner
Forum Kenner
Beiträge: 117
Registriert: Sonntag 29. Januar 2017, 14:28
CPU: AMD A10-4655M
GPU: AMD® Aruba
Kernel: LTS
DE: Awesome
GPU Treiber: Free
Hat sich bedankt: 7 Mal
Danksagung erhalten: 4 Mal
Kontaktdaten:

Re: Device "eth0" does not exist ???

#40

#40 Beitrag von Terrorizer »

... sche***e 😭
>>> AMD® A10-4655m apu with radeon(tm) hd graphics × 4 <<<
>>> AMD® Aruba <<<
>>> Manjaro Linux Awesome <<<

>>> Si vis pacem para bellum <<<

Benutzeravatar

Themen Author
Terrorizer
Forum Kenner
Forum Kenner
Beiträge: 117
Registriert: Sonntag 29. Januar 2017, 14:28
CPU: AMD A10-4655M
GPU: AMD® Aruba
Kernel: LTS
DE: Awesome
GPU Treiber: Free
Hat sich bedankt: 7 Mal
Danksagung erhalten: 4 Mal
Kontaktdaten:

Re: Device "eth0" does not exist ???

#41

#41 Beitrag von Terrorizer »

Daemon hat geschrieben:
Mittwoch 16. Oktober 2019, 15:56

Geht aber wahrscheinlich nicht, da ja sudo nicht geht.

Ganz ehrlich, wenn sudo schon nicht mehr geht, hilft wahrscheinlich nur noch eine Neuinstallation.
... glaub ich aber nicht, da ich auch mit einer Manjaro Live CD gestartet habe, und da konnte ich auch keine der Dateien löschen bzw. den Inhalt ändern, es muss doch irgendeine Hardcore-Methode geben diese Dateien zu löschen bzw. ändern 😢
>>> AMD® A10-4655m apu with radeon(tm) hd graphics × 4 <<<
>>> AMD® Aruba <<<
>>> Manjaro Linux Awesome <<<

>>> Si vis pacem para bellum <<<

Benutzeravatar

Josef_K
Forum Kenner
Forum Kenner
Beiträge: 196
Registriert: Mittwoch 18. Mai 2016, 16:08
CPU: AMD Phenom II P920
GPU: AMD RS880M
Kernel: 5.2
DE: XFCE
GPU Treiber: free
Danksagung erhalten: 11 Mal

Re: Device "eth0" does not exist ???

#42

#42 Beitrag von Josef_K »

Terrorizer hat geschrieben:
Mittwoch 16. Oktober 2019, 18:08
Daemon hat geschrieben:
Mittwoch 16. Oktober 2019, 15:56

Geht aber wahrscheinlich nicht, da ja sudo nicht geht.

Ganz ehrlich, wenn sudo schon nicht mehr geht, hilft wahrscheinlich nur noch eine Neuinstallation.
... glaub ich aber nicht, da ich auch mit einer Manjaro Live CD gestartet habe, und da konnte ich auch keine der Dateien löschen bzw. den Inhalt ändern, es muss doch irgendeine Hardcore-Methode geben diese Dateien zu löschen bzw. ändern 😢
Versuch es mit Root-PW und dann den Befehl ohne sudo

Manche Sachen gehen nicht als User mit sudo. ;)


Daemon
Forum Gott
Forum Gott
Beiträge: 276
Registriert: Freitag 22. Dezember 2017, 14:17
CPU: 6082
GPU: wtf
Kernel: pre-linux
DE: pre-linux
GPU Treiber: hab keine
Hat sich bedankt: 1 Mal
Danksagung erhalten: 15 Mal

Re: Device "eth0" does not exist ???

#43

#43 Beitrag von Daemon »

Josef_K hat geschrieben:
Mittwoch 16. Oktober 2019, 19:14
Versuch es mit Root-PW und dann den Befehl ohne sudo

Manche Sachen gehen nicht als User mit sudo. ;)
Das stimmt, allerdings gehen solche Sachen wie cp, mv, find, grep usw. immer mit sudo, außer das System ist falsch konfiguriert, was ich bei einer Live-ISO nicht glauben kann (vor allem da es bei mir auch geht mit der Live-ISO).

Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 1037
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.19
DE: Openbox
GPU Treiber: i915
Hat sich bedankt: 6 Mal
Danksagung erhalten: 129 Mal

Re: Device "eth0" does not exist ???

#44

#44 Beitrag von gosia »

Hallo Terrorizer,
Terrorizer hat geschrieben:
Mittwoch 16. Oktober 2019, 18:08
es muss doch irgendeine Hardcore-Methode geben diese Dateien zu löschen bzw. ändern 😢
naja, ich habe einen Verdacht...
mach mal folgendes:

Code: Alles auswählen

sudo chattr -i /etc/resolv.conf
sudo rm /etc/resolv.conf
viele Grüße gosia


Daemon
Forum Gott
Forum Gott
Beiträge: 276
Registriert: Freitag 22. Dezember 2017, 14:17
CPU: 6082
GPU: wtf
Kernel: pre-linux
DE: pre-linux
GPU Treiber: hab keine
Hat sich bedankt: 1 Mal
Danksagung erhalten: 15 Mal

Re: Device "eth0" does not exist ???

#45

#45 Beitrag von Daemon »

Das könnte es natürlich sein. Ist nur die Frage, wer das geändert hat. Wahrscheinlich die VPN Software? Aber warum?

Und warum geht dann trotzdem kein sudo find?

Antworten