laptop Poweroff & Shutdown Probleme - es gibt kein Poweroff ....mehr

Probleme bei der Installation von Hardware unter Manjaro Linux? Hier wird geholfen.</span
Antworten
Benutzeravatar

Themen Author
malaga
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 79
Registriert: Freitag 20. Juli 2018, 16:20
GPU:
Kernel:
DE:
GPU Treiber:
Hat sich bedankt: 1 Mal

laptop Poweroff & Shutdown Probleme - es gibt kein Poweroff ....mehr

#1

#1 Beitrag von malaga » Sonntag 14. April 2019, 13:21

hallo und guten Tag liebe Community,


hier geht es um laptop Poweroff & Shutdown Probleme.

habe Manjaro 18.04 installiert - alles super!

was im Moment nicht funktioniert - der automatische shutdown - wenn der laptop-Deckel geschlossen wird,

Nein - Das Notebook läuf einfach weiter!
Früher allerdings ging das problemlos. Ich konnte den Laptopdeckel schließen - und das NB ist heruntergefahren.
Jetzt wird lediglich der Bildschirm dunkel - aber sonst läuft noch vieles weiter - auch die Festplatte

Das ist natürlich doof... - so kann das nicht bleiben:


Anm: ich hatte früher ein paar Probleme mit dem hibernation-device...#

hibernation-device UUID xyz not found -> dropped into emergency shell

vgl. viewtopic.php?f=11&t=2088

die Hardware: https://www.asus.com/Laptops/X54L/

Windows 7 Home Premium or other editions available
IceCool Technology keeps the palm rest area cool, placing heat-producing components away from users
Experience high transfer speeds with USB 3.0 10x faster than USB 2.0
Power4Gear automatically adjusts fan speeds for quiet computing and prolonged battery life
Palm Proof Technology disables the touchpad for uninterrupted typing and accuracy

was meint ihr denn - was hier vorliegt!?


seht hier im Anhang ein Bild der Hibernate-Probleme die ich vor Wochen mal hatte - hat dies ggf mit dem heutigen Verhalten zu tun!?!

hibernation_issue_manjaro.jpg
hibernation_issue_manjaro.jpg (84.37 KiB) 267 mal betrachtet

Benutzeravatar

Blueriver
Moderator
Moderator
Beiträge: 1916
Registriert: Donnerstag 19. Mai 2016, 15:49
CPU: AMD Quad Core A8 3,6GHz
GPU: AMD/ATI Radeon R7
Kernel: 5.0
DE: LXQT und XFCE Stable, Testing, Unstable
GPU Treiber: Free
Hat sich bedankt: 3 Mal
Danksagung erhalten: 53 Mal

Re: laptop Poweroff & Shutdown Probleme - es gibt kein Poweroff ....mehr

#2

#2 Beitrag von Blueriver » Sonntag 14. April 2019, 13:32

Was für ein DE nutzt du?

Benutzeravatar

Themen Author
malaga
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 79
Registriert: Freitag 20. Juli 2018, 16:20
GPU:
Kernel:
DE:
GPU Treiber:
Hat sich bedankt: 1 Mal

Re: laptop Poweroff & Shutdown Probleme - es gibt kein Poweroff ....mehr

#3

#3 Beitrag von malaga » Sonntag 14. April 2019, 13:46

hallo Blueriver

danke rür die schnelle Antwort. Du fragst nach der Desktop Version?! Gnome oder KDE!?

Ich verwende KDE

Benutzeravatar

Blueriver
Moderator
Moderator
Beiträge: 1916
Registriert: Donnerstag 19. Mai 2016, 15:49
CPU: AMD Quad Core A8 3,6GHz
GPU: AMD/ATI Radeon R7
Kernel: 5.0
DE: LXQT und XFCE Stable, Testing, Unstable
GPU Treiber: Free
Hat sich bedankt: 3 Mal
Danksagung erhalten: 53 Mal

Re: laptop Poweroff & Shutdown Probleme - es gibt kein Poweroff ....mehr

#4

#4 Beitrag von Blueriver » Sonntag 14. April 2019, 19:55

Schau mal unter "Energiesparmodus".
Dort kannst du das bei "Wenn der Bildschirm heruntergeklappt wird" einstellen.

Benutzeravatar

Themen Author
malaga
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 79
Registriert: Freitag 20. Juli 2018, 16:20
GPU:
Kernel:
DE:
GPU Treiber:
Hat sich bedankt: 1 Mal

Re: laptop Poweroff & Shutdown Probleme - es gibt kein Poweroff ....mehr

#5

#5 Beitrag von malaga » Sonntag 14. April 2019, 23:15

guten Abend Blueriver,


vielen Dank für deine Hinweise zu der Kontrolle des Energiesparmodus.

die Dinge mit dem Hibernate haben mich noch etwas beschaeftigt - ich hatte ja - wie oben erwähnt noch Hibernate - Probleme die ixch ggf selber verursacht habe.

ggf hab ich ein paar Sachen durcheinandergebracht in fstab und grub

ich setze an mit den folgenden Abfragen:

cat /etc/fstab
cat /etc/default/grub

Code: Alles auswählen

    cat /etc/default/grub

[martin-pc martin]# cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=A790-35CD                            /boot/efi      vfat    defaults,noatime 0 2
UUID=1bf0c824-0645-47da-b8a1-88eaaabecc33 /              ext4    defaults,noatime 0 1
UUID=ae33e597-0c72-4c66-9f16-6606322111c3 swap           swap    defaults,noatime 0 2
[martin-pc martin]# cat /etc/default/grub
GRUB_DEFAULT=saved
GRUB_TIMEOUT=5
GRUB_TIMEOUT_STYLE=menu
GRUB_DISTRIBUTOR='Manjaro'
GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=ae33e597-0c72-4c66-9f16-6606322111c3"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/usr/share/grub/background.png"
GRUB_THEME="/usr/share/grub/themes/manjaro/theme.txt"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"
[martin-pc martin]#



bogdancovaciu empfiehlt hier https://forum.manjaro.org/t/if-i-close- ... wn/83103/2

in fstab folgende Aenderung vorzunehmen - diese Zeile zu tauschen

Code: Alles auswählen

 
UUID=ae33e597-0c72-4c66-9f16-6606322111c3 swap swap defaults,noatime 0 2


gegen

bzw. to:

Code: Alles auswählen

  UUID=ae33e597-0c72-4c66-9f16-6606322111c3 swap swap defaults 0 0


und bogdancovaciu empfiehlt weiter:

....
and remove ,noatime from the /boot/efi in your fstab ... All the rest seems ok ...
viewtopic.php?f=24&t=2133

ich werde mal alles untersuchen - und gucken ob ich die UUID-Aenderungen hinbekomme.


Die Einstellungen im Energiesparmodus werde ich auch nachsehen.

VG Malaga

Antworten