Script zum mounten von webdav funktioniert im autostart nicht

Support rund um die Manjaro KDE Edition findet man in dieser Kategorie!
Benutzeravatar

Themen Author
pullistricker
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 9
Registriert: Freitag 29. März 2019, 08:08
CPU: Intel(R) Core(TM) i7-3520M CPU @ 2.90GHz
GPU: Intel Corporation 3rd Gen Core processor Graphics Controller
Kernel: Linux linux 4.19.30-1-MANJARO
Desktop-Variante: KDE
GPU Treiber: Kernel driver in use: i915

Re: Script zum mounten von webdav funktioniert im autostart nicht

#16

Beitrag von pullistricker »

Code: Alles auswählen

 >>systemctl show mnt-drive.mount| grep -i network                                                                                                                                                                                                                                                                                                                             
PrivateNetwork=no
Wants=network-online.target
After=network-online.target systemd-journald.socket remote-fs-pre.target system.slice -.mount network.target
Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 2070
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.19
Desktop-Variante: Openbox
GPU Treiber: i915
Hat sich bedankt: 18 Mal
Danksagung erhalten: 441 Mal

Re: Script zum mounten von webdav funktioniert im autostart nicht

#17

Beitrag von gosia »

Hallo pullistricker,
hätte ja gern den ganzen Inhalt von mnt-drive.mount und nicht nur zwei gefilterte Zeilen. Aber sei es drum, wenn ich mir das so ansehe, bin ich eh knapp vor dem Ende der Fahnenstange, weil mir zwei Sachen auffallen, bei denen ich aber nicht sagen kann, ob sie eine Rolle spielen.
1. In allen Beispielen zu Units dieser Art ist die Reihenfolge genau andersrum, zuerst After=... und dann Wants=...
glaube nicht, dass dies eine Rolle spielt, bin mir aber auch nicht sicher.
2. Wie kommst Du auf diesen ganzen Rattenschwanz bei After?
pullistricker hat geschrieben: Freitag 17. März 2023, 10:38

Code: Alles auswählen

After=network-online.target systemd-journald.socket remote-fs-pre.target system.slice -.mount network.target
Ist mir ein wenig zu viel. Sollte da nicht ein einfaches

Code: Alles auswählen

After=network-online.target
reichen?
Und was ist mit dem Durchtesten von
https://kb.mailbox.org/de/privat/datei- ... ngerichtet
?
Das kommt ja erstmal ohne jegliche Unit aus. Und haben sich die schlauen Jungs umd Mädels von henlein (mailbox) schon mal geäussert?

viele Grüsse gosia
Benutzeravatar

Themen Author
pullistricker
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 9
Registriert: Freitag 29. März 2019, 08:08
CPU: Intel(R) Core(TM) i7-3520M CPU @ 2.90GHz
GPU: Intel Corporation 3rd Gen Core processor Graphics Controller
Kernel: Linux linux 4.19.30-1-MANJARO
Desktop-Variante: KDE
GPU Treiber: Kernel driver in use: i915

Re: Script zum mounten von webdav funktioniert im autostart nicht

#18

Beitrag von pullistricker »

So hab mein Script mal ein wenig aufgebohrt...

Code: Alles auswählen

#!/bin/bash

# Set the log file name and location
log_file="/var/log/error.log"

# Check if the log file exists, create it if it doesn't
if [ ! -f "$log_file" ]; then
    touch $log_file
fi

# Redirect stderr to the log file
exec 2>> $log_file

# Add a timestamp to the error message
timestamp=$(date +"%Y-%m-%d %T")

mount /mnt/drive
und bekomme jetzt immer noch den Fehler.....

Could not resolve hostname `dav.mailbox.org': Temporärer Fehler bei der Namensauflösung

Ich verstehe das so das wohl das mounten während des bootens so nicht möglich ist - daher auch die Angabe in der Doku "noauto" - und deshalb braucht man wohl im Autostart ein Script das den mount macht - warum ich jetzt aber beim Starten von KDE den Fehler mit der Namensauflösung bekomme ist mir noch ein Rätsel....kurz danach klappts von Hand ja auch....
Benutzeravatar

country
Forum Held
Forum Held
Beiträge: 814
Registriert: Samstag 16. Oktober 2021, 02:12
CPU: Ryzen 7 3700X
GPU: RTX 3060Ti
Kernel: up-to-date
Desktop-Variante: Cinnamon
GPU Treiber: RTX 3060Ti
Hat sich bedankt: 97 Mal
Danksagung erhalten: 148 Mal

Re: Script zum mounten von webdav funktioniert im autostart nicht

#19

Beitrag von country »

Versuche mal das hier

https://wiki.archlinux.org/title/Davfs2 ... okup_fails

Code: Alles auswählen

/etc/systemd/system/mnt-webdav-service.service
[Unit]
Description=Mount WebDAV Service
After=network-online.target
Wants=network-online.target

[Service]
Type=oneshot
ExecStart=bash -c 'for i in {1..15}; do if ping -c 1 mywebdav.server.url; then mount /path/to/mountpoint; break; else sleep 1; fi; done'
ExecStop=umount /path/to/mountpoint
RemainAfterExit=true

[Install]
WantedBy=default.target
Antworten