Bootmeldungen unterschiedlich

Unser allgemeines Manjaro Linux Diskussionsforum.
Antworten

Themen Author
rambler
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 11
Registriert: Dienstag 14. März 2017, 20:10
CPU: i5 8400
GPU: Intel UHD Graphics 630
Kernel: 4.19-24
DE: xfce, cinnamon
GPU Treiber: i915
Hat sich bedankt: 3 Mal
Danksagung erhalten: 2 Mal

Bootmeldungen unterschiedlich

#1

#1 Beitrag von rambler » Freitag 15. März 2019, 08:50

Hallo,

wie kommt es eigentlich, dass ich manchmal überhaupt keine Bootmeldungen sehe (find ich gut),
manchmal viele, ein rotes "failure", dann sehe ich die mal in grosser Schrift,
mal rattert das in mini kleiner Schrift herunter.
Das ist doch merkwürdig. Fast, als hätte der PC Launen...
MfG

R.

Benutzeravatar

Blueriver
Moderator
Moderator
Beiträge: 1880
Registriert: Donnerstag 19. Mai 2016, 15:49
CPU: AMD Quad Core A8 3,6GHz
GPU: AMD/ATI Radeon R7
Kernel: 5.0
DE: LXQT und XFCE Stable, Testing, Unstable
GPU Treiber: Free
Hat sich bedankt: 3 Mal
Danksagung erhalten: 49 Mal

Re: Bootmeldungen unterschiedlich

#2

#2 Beitrag von Blueriver » Freitag 15. März 2019, 11:06

Manjaro hat einen einen Silent Boot eingeführt, der nur zeigt was auch immer das Logo in der Firmware ist oder in der Firmware vorhanden ist.

Nach einem erfolgreichen Start - definiert durch eine Zeitspanne von zwei Minuten - schreibt ein Dienst einen Erfolgsstatus in die grubenv-Datei in /boot/grub.

Wenn Du das nächste Mal bootest, siehst Du grub nicht, es sei denn, Du drückst entweder die Tasten Esc, Shift oder F8 zur richtigen Zeit während des Bootvorgangs.

Wenn der Bootvorgang fehlgeschlagen ist oder der Systemneustart vor der zweiminütigen Zeitspanne erfolgt ist - dann wird beim Neustart automatisch das Grub-Menü angezeigt.
rambler hat geschrieben:
Freitag 15. März 2019, 08:50
ein rotes "failure"
Da steht bestimmt noch was bei.


Themen Author
rambler
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 11
Registriert: Dienstag 14. März 2017, 20:10
CPU: i5 8400
GPU: Intel UHD Graphics 630
Kernel: 4.19-24
DE: xfce, cinnamon
GPU Treiber: i915
Hat sich bedankt: 3 Mal
Danksagung erhalten: 2 Mal

Re: Bootmeldungen unterschiedlich

#3

#3 Beitrag von rambler » Freitag 15. März 2019, 14:33

Danke erstmal. in der Datei steht:

# GRUB Environment Block
saved_entry=gnulinux-simple-8f9795de-e26d-464d-a9ca-34507d01e4d6
boot_indeterminate=1
boot_success=1

und die rote Meldung ist (das geht sehr schnell) failure loading Kernel modules ...

dmesg | grep failure zeigt mir aber nichts an.

(sorry ich finde hier den Schalter zum markieren von code nicht.)
ich fänd es cool wenn mein System komplett durchbootet ohne alle Meldungen....
Gruß 1)

Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 781
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.15
DE: Openbox
GPU Treiber: i915
Hat sich bedankt: 5 Mal
Danksagung erhalten: 84 Mal

Re: Bootmeldungen unterschiedlich

#4

#4 Beitrag von gosia » Freitag 15. März 2019, 15:35

Hallo rambler,
rambler hat geschrieben:
Freitag 15. März 2019, 14:33
dmesg | grep failure zeigt mir aber nichts an.
da könnte das was anzeigen:

Code: Alles auswählen

systemctl status systemd-modules-load.service
Aber, um Mißverständnissen vorzubeugen, das ist alles, was ich dazu sagen kann :'(
rambler hat geschrieben:
Freitag 15. März 2019, 14:33
ich finde hier den Schalter zum markieren von code nicht.
Der hier, fünfter von links, bzw. im Screenshot ganz rechts:

Bild


viele Grüße gosia


Themen Author
rambler
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 11
Registriert: Dienstag 14. März 2017, 20:10
CPU: i5 8400
GPU: Intel UHD Graphics 630
Kernel: 4.19-24
DE: xfce, cinnamon
GPU Treiber: i915
Hat sich bedankt: 3 Mal
Danksagung erhalten: 2 Mal

Re: Bootmeldungen unterschiedlich

#5

#5 Beitrag von rambler » Freitag 15. März 2019, 21:22

A-ha!

Code: Alles auswählen

$ systemctl status systemd-modules-load.service
● systemd-modules-load.service - Load Kernel Modules
   Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static>
   Active: failed (Result: exit-code) since Fri 2019-03-15 21:04:17 CET; 11min >
     Docs: man:systemd-modules-load.service(8)
           man:modules-load.d(5)
  Process: 243 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, st>
 Main PID: 243 (code=exited, status=1/FAILURE)

Mär 15 21:04:17 r-pc systemd-modules-load[243]: Inserted module 'vboxdrv'
Mär 15 21:04:17 r-pc systemd-modules-load[243]: Inserted module 'vboxnetadp'
Mär 15 21:04:17 r-pc systemd-modules-load[243]: Inserted module 'vboxnetflt'
Mär 15 21:04:17 r-pc systemd-modules-load[243]: Inserted module 'vboxpci'
Mär 15 21:04:17 r-pc systemd-modules-load[243]: Inserted module 'vboxguest'
Mär 15 21:04:17 r-pc systemd-modules-load[243]: Failed to find module 'vboxsf'
Mär 15 21:04:17 r-pc systemd-modules-load[243]: Inserted module 'vboxvideo'
Mär 15 21:04:17 r-pc systemd[1]: systemd-modules-load.service: Main process exi>
Mär 15 21:04:17 r-pc systemd[1]: systemd-modules-load.service: Failed with resu>
Mär 15 21:04:17 r-pc systemd[1]: Failed to start Load Kernel Modules.
lines 1-18/18 (END)...skipping...
vielleicht deaktiviere ich die Virtualbox wieder. Ich habe mir ein paar Distros angeschaut und komme zu dem ergebnis, dass eh alle
so ziemlich das gleiche tun. Da kann ich bleiben wo ich bin 1)

das würde bedeuten, wenn der Fehler nicht mehr existiert, dann schwindet die Grub-Auswahl am Anfang des Bootvorgangs?...und das System läuft durch bis Ende?

Benutzeravatar

charly700
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 10
Registriert: Sonntag 5. Juni 2016, 23:41
CPU: Intel Core i5
GPU: Bumblebee (NVIDIA - Intel)
Kernel: Immer den neuesten und den letzten LTS
DE: normal XFCE aber wegen HIDPI derzeit Cinnamon
GPU Treiber: Bumblebee (NVIDIA - Intel)
Hat sich bedankt: 4 Mal

Re: Bootmeldungen unterschiedlich

#6

#6 Beitrag von charly700 » Freitag 15. März 2019, 22:32

Ich hänge mich hier mal an.

Ich will genau das umgekehrte erreichen. Ich will das Bootmenü vom Grub immer sehen. Wie kann ich den Silent Modus deaktivieren?

Edit: Anbei beine grub Settings Datei welche unter /etc/default/grub liegt.
► Text zeigen
Edit2: Habe jetzt mal das "quiet" raus genommen. Dann kam einmal das Bootmenü und die Bootmeldungen. Beim zweiten Neustart kam das Bootmenü nicht mehr, aber die Bootmeldungen schon. Wie bekomme ich den Silent Mode weg?

Benutzeravatar

Blueriver
Moderator
Moderator
Beiträge: 1880
Registriert: Donnerstag 19. Mai 2016, 15:49
CPU: AMD Quad Core A8 3,6GHz
GPU: AMD/ATI Radeon R7
Kernel: 5.0
DE: LXQT und XFCE Stable, Testing, Unstable
GPU Treiber: Free
Hat sich bedankt: 3 Mal
Danksagung erhalten: 49 Mal

Re: Bootmeldungen unterschiedlich

#7

#7 Beitrag von Blueriver » Samstag 16. März 2019, 06:50

rambler hat geschrieben:
Freitag 15. März 2019, 21:22
das würde bedeuten, wenn der Fehler nicht mehr existiert, dann schwindet die Grub-Auswahl am Anfang des Bootvorgangs?...und das System läuft durch bis Ende?
Wenn das System noch keine 2 Minuten läuft und du startest neu wird die Grubauswahl auch wieder angezeigt.

Antworten