2019-07-03 - Kernels, Systemd, Pamac 8.0, KDE, XFCE, Browser, QT (Stable Update)

Frische News und Updates zu Manjaro Linux finden sich zeitnah hier ein!

Hattet ihr Probleme mit dem Update?

Hatte keine Probleme.
9
69%
Ja, ich hatte ein Problem das ich allerdings selbst lösen konnte. ( Bitte erläutert uns eure Lösung )
1
8%
Ja, ich habe aufgrund des Updates ein Problem. ( Bitte beschreibt das Problem )
3
23%
 
Insgesamt abgegebene Stimmen: 13

Benutzeravatar

Themen Author
Blueriver
Moderator
Moderator
Beiträge: 2003
Registriert: Donnerstag 19. Mai 2016, 15:49
CPU: AMD Quad Core A8 3,6GHz
GPU: AMD/ATI Radeon R7
Kernel: 5.0
DE: LXQT und XFCE Stable, Testing, Unstable
GPU Treiber: Free
Hat sich bedankt: 6 Mal
Danksagung erhalten: 63 Mal

2019-07-03 - Kernels, Systemd, Pamac 8.0, KDE, XFCE, Browser, QT (Stable Update)

#1

#1 Beitrag von Blueriver » Mittwoch 3. Juli 2019, 13:12

Hello community,

I am happy to announce another Stable Update.

Stay tuned for the cooperation we started with Tuxedo Computers!

Some might noticed that since the #snapcraftsummit a lot of package changes went into Manjaro and our available RCs. XFCE and Gnome will come with Gnome-Software and our KDE edition has Discover, both with snap support enabled.

This way everybody can easily access the snap store by a click and don't has to hassle to get snaps enabled. This enables us to ship even more proprietary software, which we couldn't before. For example check out on how you may install Spotify on Manjaro.

This update holds the following changes:

most of our Kernels got updated. Some of them got already built with gcc 9.1. All EOL kernels got removed!
KDE Plasma is now at 5.16.2
Nvidia driver got update to 430.26
Mesa is now at 19.1.1
Texlive got it's first 2019 update
apparmor got his own profiles package, which ships those in complain mode.
Kodi got updated to 18.3
Systemd gained more stable patches. Report any issues you may have with it.
Pamac is now at its v8.0 release series
updates to XFCE 4.14-pre2
amdvlk got updated to its latest release
more updates to our KDE-Git branch
Octopi gained more features and fixes
Firefox-Dev and Thunderbird got updated
usual Haskell and Python updates
Manjaro Juhraya ISOs got updated, including snap support pre-activated: XFCE, KDE , Gnome
Give us the usual feedback and let us know what you think about this update.

Current supported Kernels
linux316 3.16.69
linux44 4.4.183 (no legacy nvidia-340 module!)
linux49 4.9.183
linux414 4.14.130
linux419 4.19.56
linux51 5.1.15
linux52 5.2-rc6 (few extramodules build, but not all yet!)
linux419-rt 4.19.50_rt22
linux50-rt 5.0.21_rt14

A detailed list of all package updates may be found here.

Quelle



Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed 1

Warning: audit: directory permissions differ on /var/log/audit/filesystem: 755 package: 700
Execute sudo chmod 700 /var/log/audit/ in terminal

XFCE 4.14-pre2 : I do not see XFCE 4.14-pre2 in the repositories!?
You won't see explicitly 4.14-pre2 anywhere on our xfce-gtk3 packages. We follow the versioning used by upstream. Here's the list of all components 2 that are part of XFCE 4.14-pre2.

Kvantum theme reset
If you are using the Matcha theme in kvantum you may experience a theme reset. Simply install kvantum-theme-matcha if not happend yet and select the new provided variants. Manjaro 18.1 releases will ship with the new themes by default.

mariadb 10.4.x update requires manual intervention
(Source: https://www.archlinux.org/news/mariadb- ... ervention/ 2 , 2019-06-27, by Christian Hesse)

The update to mariadb 10.4.6-1 and later changes configuration layout as recommended by upstream.

The main configuration file moved from /etc/mysql/my.cnf (and its include directory /etc/mysql/my.cnf.d/ ) to /etc/my.cnf (and /etc/my.cnf.d/ ). Make sure to move your configuration.

Instantiated services (like mariadb@foo.service ) are no longer configured in separate files (like /etc/mysql/myfoo.cnf ). Instead move your configuration to configuration blocks with group suffix in main configuration file, one for each service. A block should look something like this:

[mysqld.foo]
datadir = /var/lib/mysql-foo
socket = /run/mysqld/mysqld-foo.sock
...
Like every mariadb feature update this requires the data directory to be updated. With the new configuration in place run:

systemctl restart mariadb.service && mariadb-upgrade -u root -p

Some KDE System Settings may have been re-set to their defaults
System Settings > Input Devices > Touchpad > Tap-to-click
Scrolling
The compositor could get disabled during the upgrade which will stop all of the KDE eye-candy

Issues with Octopi
Currently several users report different issues 3 for Octopi. So if you encounter some of them, you may switch to pamac for now: sudo pacman -Syu pamac

(Note that sudo pacman -Syu pamac will both install Pamac and upgrade all upgradable packages on your system at the same time.)

Issues with DisplayCAL
DisplayCAL 3.8.1.1 - Missing python2-dbus causes failure to launch application.

Solution - Install the python2-dbus package for now. Version 3.8.2 fixes the dependency error. As and when DisplayCAL 3.8.2 reaches stable branch you can remove python2-dbus as it does not require it. Only remove python2-dbus again if you installed it specifically for DisplayCAL.


MichaelP
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 17
Registriert: Samstag 26. Januar 2019, 13:25
CPU: AMD Ryzen 7 1800
GPU: NVIDIA GT1080
Kernel: 4.20
DE: keine Ahnung
GPU Treiber: unfree NVIDIA

Re: 2019-07-03 - Kernels, Systemd, Pamac 8.0, KDE, XFCE, Browser, QT (Stable Update)

#2

#2 Beitrag von MichaelP » Mittwoch 3. Juli 2019, 16:51

Hallo Blueriver,

leider eher ein Disaster als ein Update.

Rechner 1: AMD Ryzen 5 2400G - nach Update Bootplatten getauscht, kein GRUB-Menü - inzwischen selbst gefixt. MariaDB wie im LOG empfohlen nicht updatebar - hat erstmal Prio 2, aber unschön...

Rechner 2: AMD Ryzen 7 1800X und NVIDIA 1080:

Hinweis auf unsupported Kernel: Genutzt 5.1.15-1 - der ist doch o.k. (und läuft gut)

und bei Update-Versuch Octopi - weiter Terminal- Abbruch:

Suche nach in Konflikt stehenden Paketen...

Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: Installation vonnvidia-utils (1:430.26-1) verletzt Abhängigkeit 'nvidia-utils=1:430.14', benötigt von linux50-nvidia

Drücken Sie eine beliebige Taste um fortzufahren...

(In den Systemeinstellungen Kernel Infos wird 5.0.21-1 als nicht unterstützt ausgewiesen)

das ist ein Showstopper :-(

Hoffe auf Besserung unf Tipps

Gruß Michael

Benutzeravatar

Themen Author
Blueriver
Moderator
Moderator
Beiträge: 2003
Registriert: Donnerstag 19. Mai 2016, 15:49
CPU: AMD Quad Core A8 3,6GHz
GPU: AMD/ATI Radeon R7
Kernel: 5.0
DE: LXQT und XFCE Stable, Testing, Unstable
GPU Treiber: Free
Hat sich bedankt: 6 Mal
Danksagung erhalten: 63 Mal

Re: 2019-07-03 - Kernels, Systemd, Pamac 8.0, KDE, XFCE, Browser, QT (Stable Update)

#3

#3 Beitrag von Blueriver » Mittwoch 3. Juli 2019, 17:27

MichaelP hat geschrieben:
Mittwoch 3. Juli 2019, 16:51
Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: Installation vonnvidia-utils (1:430.26-1) verletzt Abhängigkeit 'nvidia-utils=1:430.14', benötigt von linux50-nvidia
Du musst erst den Kernel 5.0 entfernen der wird nicht mehr unterstützt. Am besten das System neu starten und das Update noch einmal anstoßen.

Benutzeravatar

nacko
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 11
Registriert: Samstag 18. Mai 2019, 16:15
CPU: Intel Core i5 7300HQ
GPU: Nvidia 1050 GT
Kernel: 5.2
DE: KDE
GPU Treiber: Nvidia

Re: 2019-07-03 - Kernels, Systemd, Pamac 8.0, KDE, XFCE, Browser, QT (Stable Update)

#4

#4 Beitrag von nacko » Mittwoch 3. Juli 2019, 20:03

Also das Update lief sauber durch........nur war bei meinem Laptop mal wieder das Touchpad deaktiviert........ ::)


MichaelP
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 17
Registriert: Samstag 26. Januar 2019, 13:25
CPU: AMD Ryzen 7 1800
GPU: NVIDIA GT1080
Kernel: 4.20
DE: keine Ahnung
GPU Treiber: unfree NVIDIA

Re: 2019-07-03 - Kernels, Systemd, Pamac 8.0, KDE, XFCE, Browser, QT (Stable Update)

#5

#5 Beitrag von MichaelP » Mittwoch 3. Juli 2019, 22:36

Hallo Blueriver,

hat nach Kernel 5.0 entfernen geklappt.

Kleinigkeiten:
Auf zweitem System hat das Grub-Menü die Auflösung vergessen, habs aber manuell neu gesetzt und Grub-Theme Manjaro wieder aktiviert.
Auf beiden Systemen Octopi nun in Englisch.

Ist schon erstaunlich, diese Variationsbreite kleiner Gemeinheiten auf nahezu identisch bespielten Systemen ???

Morgen schau ich mir MariaDB nochmal an.

Nochmal Danke für die schnelle Hilfe

Gruß Michael


MichaelP
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 17
Registriert: Samstag 26. Januar 2019, 13:25
CPU: AMD Ryzen 7 1800
GPU: NVIDIA GT1080
Kernel: 4.20
DE: keine Ahnung
GPU Treiber: unfree NVIDIA

Re: 2019-07-03 - Kernels, Systemd, Pamac 8.0, KDE, XFCE, Browser, QT (Stable Update)

#6

#6 Beitrag von MichaelP » Donnerstag 4. Juli 2019, 08:21

Hallo Blueriver,

MariaDB ist auf beiden Rechnern Version .10.4.6.-1.

Leider greift die manuelle Korrektur nicht:

[michaelp@PRIMO ~]$ systemctl restart mariadb.service && mariadb-upgrade -u root -p

Job for mariadb.service failed because the control process exited with error code.
See "systemctl status mariadb.service" and "journalctl -xe" for details.

[michaelp@PRIMO ~]$ systemctl status mariadb.service:

● mariadb.service - MariaDB 10.4.6 database server
Loaded: loaded (/usr/lib/systemd/system/mariadb.service; disabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Thu 2019-07-04 08:13:35 CEST; 36s ago
Docs: man:mysqld(8)
https://mariadb.com/kb/en/library/systemd/
Process: 32005 ExecStartPre=/bin/sh -c systemctl unset-environment _WSREP_START_POSITION (code=exited, status=0/SUCCESS)
Process: 32007 ExecStartPre=/bin/sh -c [ ! -e /usr/bin/galera_recovery ] && VAR= || VAR=`/usr/bin/galera_recovery`; [ $? -eq 0 ] && systemctl s>
Process: 32015 ExecStart=/usr/bin/mysqld $MYSQLD_OPTS $_WSREP_NEW_CLUSTER $_WSREP_START_POSITION (code=exited, status=1/FAILURE)
Main PID: 32015 (code=exited, status=1/FAILURE)
Status: "MariaDB server is down"

Jul 04 08:13:33 PRIMO mysqld[32015]: 2019-07-04 8:13:33 0 [Note] InnoDB: Loading buffer pool(s) from /var/lib/mysql/ib_buffer_pool
Jul 04 08:13:33 PRIMO mysqld[32015]: 2019-07-04 8:13:33 0 [ERROR] Could not open mysql.plugin table. Some plugins may be not loaded
Jul 04 08:13:33 PRIMO mysqld[32015]: 2019-07-04 8:13:33 0 [Note] InnoDB: Buffer pool(s) load completed at 190704 8:13:33
Jul 04 08:13:33 PRIMO mysqld[32015]: 2019-07-04 8:13:33 0 [ERROR] Can't open and lock privilege tables: Table 'mysql.servers' doesn't exist
Jul 04 08:13:33 PRIMO mysqld[32015]: 2019-07-04 8:13:33 0 [Note] Server socket created on IP: '::'.
Jul 04 08:13:33 PRIMO mysqld[32015]: 2019-07-04 8:13:33 0 [ERROR] Fatal error: Can't open and lock privilege tables: Table 'mysql.db' doesn't exist
Jul 04 08:13:33 PRIMO mysqld[32015]: 2019-07-04 8:13:33 0 [ERROR] Aborting
Jul 04 08:13:35 PRIMO systemd[1]: mariadb.service: Main process exited, code=exited, status=1/FAILURE
Jul 04 08:13:35 PRIMO systemd[1]: mariadb.service: Failed with result 'exit-code'.
Jul 04 08:13:35 PRIMO systemd[1]: Failed to start MariaDB 10.4.6 database server.

MariaDB deinstallieren und neu aufsetzen?

Danke für Tipps und Hilfe...

Gruß Michael

Benutzeravatar

Themen Author
Blueriver
Moderator
Moderator
Beiträge: 2003
Registriert: Donnerstag 19. Mai 2016, 15:49
CPU: AMD Quad Core A8 3,6GHz
GPU: AMD/ATI Radeon R7
Kernel: 5.0
DE: LXQT und XFCE Stable, Testing, Unstable
GPU Treiber: Free
Hat sich bedankt: 6 Mal
Danksagung erhalten: 63 Mal

Re: 2019-07-03 - Kernels, Systemd, Pamac 8.0, KDE, XFCE, Browser, QT (Stable Update)

#7

#7 Beitrag von Blueriver » Donnerstag 4. Juli 2019, 17:16

MichaelP hat geschrieben:
Donnerstag 4. Juli 2019, 08:21
MariaDB deinstallieren und neu aufsetzen?
Wenn sonst keiner mehr eine Idee hat würde ich es so machen.

Benutzeravatar

m-bostaurus
Forum Kenner
Forum Kenner
Beiträge: 207
Registriert: Mittwoch 18. Mai 2016, 19:44
Wohnort: Nürnberg
CPU: i5-6500 / i5
GPU: nVidia GTX 1070Ti / nVidia
Kernel: 501/419
DE: stable (LXQt, Mate, KDE, XFCE)
GPU Treiber: nVidia - proprietär auf beiden Rechnern
Hat sich bedankt: 10 Mal
Danksagung erhalten: 5 Mal

Re: 2019-07-03 - Kernels, Systemd, Pamac 8.0, KDE, XFCE, Browser, QT (Stable Update)

#8

#8 Beitrag von m-bostaurus » Donnerstag 4. Juli 2019, 18:20

Auf meinen "alten Gurken" und den aktuellen Rechnern lief alles gut. Geupdated habe ich - wie letztens immer - ohne grafische Oberfläche. Vielen Dank an das Team!


MichaelP
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 17
Registriert: Samstag 26. Januar 2019, 13:25
CPU: AMD Ryzen 7 1800
GPU: NVIDIA GT1080
Kernel: 4.20
DE: keine Ahnung
GPU Treiber: unfree NVIDIA

Re: 2019-07-03 - Kernels, Systemd, Pamac 8.0, KDE, XFCE, Browser, QT (Stable Update)

#9

#9 Beitrag von MichaelP » Donnerstag 4. Juli 2019, 18:28

Hallo Blueriver,

reinstall schon gemacht, bleibt unverändert...

Bei Deinstallation wird es heftiger, der Prozeß fordert 11 andere Programme zur entfernen.
U.a. KODI, Python, Akonadi... kann ich zwar abwählen, aber dann dürften Abhängigkeiten verloren gehen.

So will ich es möglichst vermeiden...

Gruß Michael

Benutzeravatar

Themen Author
Blueriver
Moderator
Moderator
Beiträge: 2003
Registriert: Donnerstag 19. Mai 2016, 15:49
CPU: AMD Quad Core A8 3,6GHz
GPU: AMD/ATI Radeon R7
Kernel: 5.0
DE: LXQT und XFCE Stable, Testing, Unstable
GPU Treiber: Free
Hat sich bedankt: 6 Mal
Danksagung erhalten: 63 Mal

Re: 2019-07-03 - Kernels, Systemd, Pamac 8.0, KDE, XFCE, Browser, QT (Stable Update)

#10

#10 Beitrag von Blueriver » Donnerstag 4. Juli 2019, 21:58

@MichaelP
Da könnte dieses evtl. helfen.


MichaelP
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 17
Registriert: Samstag 26. Januar 2019, 13:25
CPU: AMD Ryzen 7 1800
GPU: NVIDIA GT1080
Kernel: 4.20
DE: keine Ahnung
GPU Treiber: unfree NVIDIA

Re: 2019-07-03 - Kernels, Systemd, Pamac 8.0, KDE, XFCE, Browser, QT (Stable Update)

#11

#11 Beitrag von MichaelP » Freitag 5. Juli 2019, 09:38

Hallo Blueriver,

daß klappt auch nicht..,:

[michaelp@PRIMO ~]$ systemctl stop mariadb
[michaelp@PRIMO ~]$ systemctl disable mariadb
[michaelp@PRIMO ~]$ sudo pacman -Rns mariadb
[sudo] Passwort für michaelp:
Prüfe Abhängigkeiten...
Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: akonadi: das Entfernen von mariadb verletzt Abhängigkeit von 'mariadb'
:: galera: das Entfernen von mariadb verletzt Abhängigkeit von 'mariadb'

Da ich bisher mit MariaDB keinen "Kontakt" hatte, weiß ich nicht weiter.
Hab es wieder gestartet mit

[michaelp@PRIMO ~]$ systemctl enable mariadb
Created symlink /etc/systemd/system/multi-user.target.wants/mariadb.service → /usr/lib/systemd/system/mariadb.service.
[michaelp@PRIMO ~]$ systemctl start mariadb

Bisher hab ich keine Mängel in Programmen gefunden, mal KODI DB aktualisiert... das klappte.

Da beide Rechner die gleiche Fehlermeldung generieren, ist es m.E. ein Problem des Update-Prozesses.
Das sollte einem DAU wie mir erspart bleiben...

Gruß und Danke für Deine Tipps

Michael

Benutzeravatar

Jean-Paul
Forum Kenner
Forum Kenner
Beiträge: 212
Registriert: Sonntag 17. Dezember 2017, 18:19
Wohnort: Baden Württemberg
CPU: Intel Core i5-7400 - 4x 3.5GHz
GPU: AMD OLAND
Kernel: x86_64 Linux 4.19.66-1
DE: Xfce4
GPU Treiber: --
Hat sich bedankt: 25 Mal
Danksagung erhalten: 15 Mal

Re: 2019-07-03 - Kernels, Systemd, Pamac 8.0, KDE, XFCE, Browser, QT (Stable Update)

#12

#12 Beitrag von Jean-Paul » Freitag 5. Juli 2019, 15:45

Moin, fast 1GB Update eingespielt, 8 Minuten später Neustart durchgeführt und? Maschine läuft ohne Probleme. So soll es sein. :)
Freundliche Grüße
Jean-Paul

Why I use Manjaro Linux? Because my computer belongs to me and no company...

Benutzeravatar

Josef_K
Forum Kenner
Forum Kenner
Beiträge: 177
Registriert: Mittwoch 18. Mai 2016, 16:08
CPU: i5-4460
GPU: GeForce GT 730
Kernel: 4.20
DE: XFCE
GPU Treiber: nvidia v: 410.78
Danksagung erhalten: 9 Mal

Re: 2019-07-03 - Kernels, Systemd, Pamac 8.0, KDE, XFCE, Browser, QT (Stable Update)

#13

#13 Beitrag von Josef_K » Freitag 5. Juli 2019, 16:40

Wieder ein Update und wieder Probleme.

Update ohne Fehlermeldung durchgelaufen, danach bootete der Rechner bis zur Meldung

Code: Alles auswählen

See 'systemctl status lightdm.service' for detail
Started update locate database
Danach blinkte nur mehr der Unterstrich und ich konnte nur mehr das Gerät ausschalten.

Neuer Versuch:

Code: Alles auswählen

Failed to start load Kernelmodules
See 'systemctl status systemd-modules-load.service' for detail
startet TPL system startup/shutdown
Danach ging wieder nichts mehr.

Das wars.
Vielleicht schaue ich mir Manjaro in einigen Jahren wider mal an.

Benutzeravatar

Themen Author
Blueriver
Moderator
Moderator
Beiträge: 2003
Registriert: Donnerstag 19. Mai 2016, 15:49
CPU: AMD Quad Core A8 3,6GHz
GPU: AMD/ATI Radeon R7
Kernel: 5.0
DE: LXQT und XFCE Stable, Testing, Unstable
GPU Treiber: Free
Hat sich bedankt: 6 Mal
Danksagung erhalten: 63 Mal

Re: 2019-07-03 - Kernels, Systemd, Pamac 8.0, KDE, XFCE, Browser, QT (Stable Update)

#14

#14 Beitrag von Blueriver » Freitag 5. Juli 2019, 17:40

Bei meinem LXQT und XFCE ist alles besten. :)

Benutzeravatar

m-bostaurus
Forum Kenner
Forum Kenner
Beiträge: 207
Registriert: Mittwoch 18. Mai 2016, 19:44
Wohnort: Nürnberg
CPU: i5-6500 / i5
GPU: nVidia GTX 1070Ti / nVidia
Kernel: 501/419
DE: stable (LXQt, Mate, KDE, XFCE)
GPU Treiber: nVidia - proprietär auf beiden Rechnern
Hat sich bedankt: 10 Mal
Danksagung erhalten: 5 Mal

Re: 2019-07-03 - Kernels, Systemd, Pamac 8.0, KDE, XFCE, Browser, QT (Stable Update)

#15

#15 Beitrag von m-bostaurus » Samstag 6. Juli 2019, 12:23

@MichaelP
Ich hatte letztens die Situation, dass es Konflikte gab, und der Rattenschwanz an zu entfernender Software wurde immer länger. Ich habe dann riskiert, alles zu deinstallieren, was "angemeckert" wurde, weil ich im Terminal sah, um welche Pakete es sich handelte. Ohne mich abzumelden oder gar neu zustarten, weil ich nicht riskieren wollte, dass Konfigurationsdateien gelöscht werden. Danach habe ich alles, was ich brauchte, wieder installiert, dann neu gestartet, und alles war gut.
Was ich nicht weiß: Ob das auf Datenbankanwendungen übertragbar ist.

Antworten