2019-03-29 - Kernels, Gnome, LibreOffice, Mesa, Budgie, Browsers, Qt (Stable Update)

Frische News und Updates zu Manjaro Linux finden sich zeitnah hier ein!
Antworten

Hattet ihr Probleme mit dem Update?

Hatte keine Probleme.
8
89%
Ja, ich hatte ein Problem das ich allerdings selbst lösen konnte. ( Bitte erläutert uns eure Lösung )
1
11%
Ja, ich habe aufgrund des Updates ein Problem. ( Bitte beschreibt das Problem )
0
Keine Stimmen
 
Insgesamt abgegebene Stimmen: 9

Benutzeravatar

Themen Author
Blueriver
Moderator
Moderator
Beiträge: 2000
Registriert: Donnerstag 19. Mai 2016, 15:49
CPU: AMD Quad Core A8 3,6GHz
GPU: AMD/ATI Radeon R7
Kernel: 5.0
DE: LXQT und XFCE Stable, Testing, Unstable
GPU Treiber: Free
Hat sich bedankt: 6 Mal
Danksagung erhalten: 62 Mal

2019-03-29 - Kernels, Gnome, LibreOffice, Mesa, Budgie, Browsers, Qt (Stable Update)

#1

#1 Beitrag von Blueriver » Freitag 29. März 2019, 18:58

Hi community,

Welcome to our tenth stable update for 2019. So what do we have with this one?

we renewed most of our Kernels
we updated Gnome to 3.32 series
Budgie got updated to 10.5
LibreOffice got renewed to the latest
our graphical stack runs now with Mesa 19
we also bumped Qt to 5.12.2 . Tell us if we need more rebuilds

We hope with all these changes Manjaro to be more efficient for you all.


Merch
Get our new T-Shirt collection #CLT2019 ! They are the latest design we did exclusively for Chemnitz Linux Days.

Manjaro v18.0.4 released!
We updated our flagship ISOs of Manjaro Illyria with the latest packages. It comes with refreshed packages and updated tools. You may want to download our XFCE Edition 4 with the latest 4.13 packages, aswell as our most recent styling efforts. Our KDE fans may try our KDE Edition 4 with the latest KDE v5.15 instead. And our GNOME fans may try our Gnome Edition 3 with the latest GNOME v3.30.

Current supported Kernels
linux316 3.16.62
linux318 3.18.137 [EOL]
linux44 4.4.167 [FZN]
linux49 4.9.166
linux414 4.14.109
linux419 4.19.32
linux420 4.20.17 [EOL]
linux50 5.0.5
linux51 5.1-rc1 (no extramodules yet)
linux418-rt 4.18.16_rt9
linux419-rt 4.19.25_rt16
linux50-rt 5.0.3_rt1-1

A detailed list of all package changes can be found here

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Gnome 3.32: Two extensions removed from our repos.
We have dropped two packages that shipped additional extensions for Gnome: gnome-shell-extensions-topicons-plus-huttli and gnome-shell-extensions-taskbar. We won’t maintain Topicons Plus and Taskbar anymore.

Those extensions are not in active development anymore and may not work properly (or not work at all) on Gnome 3.32. Notably, it has been reported that using Topicons Plus on Gnome 3.32 may leads to very high CPU usage.

We strongly recommend you to disable those extensions if they are enabled (Tweaks > Extensions) and remove those packages with your favorite package manager. To prevent potential problems with the next version of Gnome, you may do those steps (or at least the first one) before upgrading your system.

Gnome 3.32: Various problems
There is currently several problems with Gnome 3.32. Here is what we know so far.

1. Possibility of broken extensions
Broken extensions is something to expect when transitioning between major versions of Gnome, especially if you are using extensions that are not shipped by default on Manjaro Gnome. If you have a broken extension taken from somewhere else than Manjaro official repositories, you will have to contact the maintainer on the source you have taken the extension from to get more support. You may also want to report the problem to the developer(s) of the extension (if not the same person/group).

It is possible that extensions become so broken on Gnome 3.32 that it makes Gnome Shell crash completely when trying to log in, thus making Gnome completely unusable. For example, we have a report of such issue with a third-party extension (that doesn’t come from Manjaro’s official repositories) called Extensions.

To decrease the risk of breakage (especially if running Gnome extensions that does not come from Manjaro official repositories) and make the upgrade smoother, you can disable all Gnome extensions (Tweaks > Extensions) before upgrading your system, then enable them one by one only after being logged in a completely new session on Gnome 3.32.

2. Using world clocks can break Gnome Shell completely
If you have configured world clocks in Gnome, it may make Gnome Shell segfaults and crashes when trying to log in for a graphical session, making Gnome unusable. If it happens, you will need to reset your parameters for world clocks with the following command (do it in TTY): dbus-launch gsettings reset org.gnome.clocks world-clocks.
See this Arch Linux thread and this ticket from upstream.

3. Gnome Shell may crash completely when resuming from sleep if you use Wayland
If you are using Wayland (instead of X.org), Gnome Shell may crash when resuming from sleep. Upstream is aware of this issue. As a workaround, you may use X.org instead of Wayland for now.

4. Miscellaneous
Some programs don’t get focused after being launched. Reported to upstream and confirmed for distributions other than Manjaro too.

Yaourt: Rest in peace
Yaourt has been removed from our repositories completely. We won’t maintain the yaourt package anymore, which means that you will not receive any updates from us for this package. A very old package named yaourt-gui-manjaro has been removed at the same time too.

If you are still using Yaourt, we strongly encourage you to switch to an alternative like Pamac CLI (package: pamac-cli), Trizen (package: trizen), Yay (package: yay) or Pacaur (package: pacaur); and uninstall Yaourt from your system.

In addition to that, we have dropped support for several packages that depended on yaourt: allservers, pacli and pacli-jwm. Those packages has been removed from the official repositories completely.

Quelle
.

Benutzeravatar

Themen Author
Blueriver
Moderator
Moderator
Beiträge: 2000
Registriert: Donnerstag 19. Mai 2016, 15:49
CPU: AMD Quad Core A8 3,6GHz
GPU: AMD/ATI Radeon R7
Kernel: 5.0
DE: LXQT und XFCE Stable, Testing, Unstable
GPU Treiber: Free
Hat sich bedankt: 6 Mal
Danksagung erhalten: 62 Mal

Re: 2019-03-29 - Kernels, Gnome, LibreOffice, Mesa, Budgie, Browsers, Qt (Stable Update)

#2

#2 Beitrag von Blueriver » Freitag 29. März 2019, 22:08

Alles bestens! :)

Benutzeravatar

Eifelquelle
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 18
Registriert: Mittwoch 2. Januar 2019, 22:25
CPU: i5-2400 CPU @ 3.10GHz × 4
GPU: NVIDIA GeForce GT 1030
Kernel: 5.0.5-1-MANJARO
DE: Cinnamon 4.0.10
GPU Treiber: Video-Nvidia
Hat sich bedankt: 1 Mal
Danksagung erhalten: 4 Mal

Re: 2019-03-29 - Kernels, Gnome, LibreOffice, Mesa, Budgie, Browsers, Qt (Stable Update)

#3

#3 Beitrag von Eifelquelle » Samstag 30. März 2019, 01:01

Wie immer top!

Benutzeravatar

Jean-Paul
Forum Kenner
Forum Kenner
Beiträge: 212
Registriert: Sonntag 17. Dezember 2017, 18:19
Wohnort: Baden Württemberg
CPU: Intel Core i5-7400 - 4x 3.5GHz
GPU: AMD OLAND
Kernel: x86_64 Linux 4.19.66-1
DE: Xfce4
GPU Treiber: --
Hat sich bedankt: 25 Mal
Danksagung erhalten: 15 Mal

Re: 2019-03-29 - Kernels, Gnome, LibreOffice, Mesa, Budgie, Browsers, Qt (Stable Update)

#4

#4 Beitrag von Jean-Paul » Samstag 30. März 2019, 10:31

Gerade eingespielt, 590 MIB, 8 Minuten, Rechner neu gestartet. Alles Supi, XFCE läuft bestens! ;)

Benutzeravatar

Josef_K
Forum Kenner
Forum Kenner
Beiträge: 176
Registriert: Mittwoch 18. Mai 2016, 16:08
CPU: i5-4460
GPU: GeForce GT 730
Kernel: 4.20
DE: XFCE
GPU Treiber: nvidia v: 410.78
Danksagung erhalten: 9 Mal

Re: 2019-03-29 - Kernels, Gnome, LibreOffice, Mesa, Budgie, Browsers, Qt (Stable Update)

#5

#5 Beitrag von Josef_K » Samstag 30. März 2019, 19:07

Diesmal hatte ich etwas Trouble mit dem Update.

Als erstes kam bei etlichen Paketen die Meldung
Konnte Paket xx vom Server yy nicht übertragen... Nach

Code: Alles auswählen

sudo pacman-mirrors -f
war es das gleiche. Nach

Code: Alles auswählen

sudo pacman-mirrors -g
hatte ich ein Problem mit ungültigen Schlüsseln. Erst nach

Code: Alles auswählen

 sudo pacman -Sy archlinux-keyring manjaro-keyring && sudo pacman-key --populate archlinux manjaro && sudo pacman-key --refresh-keys
lief das Update ohne weitere Fehlermeldung durch.

Beim Erstellen der Grub-Konfiguration dauerte es bei

Code: Alles auswählen

Found initrd fallback image: /boot/initramfs-4.19-x86_64-fallback.img
ziemlich lange. Ist das normal, bin ich von Void schon etwas verwöhnt?

Benutzeravatar

m-bostaurus
Forum Kenner
Forum Kenner
Beiträge: 207
Registriert: Mittwoch 18. Mai 2016, 19:44
Wohnort: Nürnberg
CPU: i5-6500 / i5
GPU: nVidia GTX 1070Ti / nVidia
Kernel: 501/419
DE: stable (LXQt, Mate, KDE, XFCE)
GPU Treiber: nVidia - proprietär auf beiden Rechnern
Hat sich bedankt: 10 Mal
Danksagung erhalten: 5 Mal

Re: 2019-03-29 - Kernels, Gnome, LibreOffice, Mesa, Budgie, Browsers, Qt (Stable Update)

#6

#6 Beitrag von m-bostaurus » Montag 1. April 2019, 21:19

Josef_K hat geschrieben:
Samstag 30. März 2019, 19:07
Diesmal hatte ich etwas Trouble mit dem Update.
Als erstes kam bei etlichen Paketen die Meldung
Konnte Paket xx vom Server yy nicht übertragen...
Das Problem hatte ich bei einzelnen Paketen auch und zwar nur bei meinem Rechner mit XFCE-Oberfläche. Aber es war auch schon immer so, dass der sich updates mit maximal 900 bis 1000 k/sec holt, wo alle anderen Rechner mit ca. 6000 k/sec laden. Insgesamt aber ist alles bei mir gut gelaufen. Dieses Mal habe ich mich immer zunächst abgemeldet und dann die Updates in tty3 durchgeführt, also kein xchroot verwendet.

Benutzeravatar

ManjaroHans
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 25
Registriert: Dienstag 8. Januar 2019, 16:12
CPU: Intel Core i5-8600
GPU: Intel Onboard
Kernel: 4.19-62-1
DE: KDE Plasma
GPU Treiber: Intel Open Source Technology Center
Hat sich bedankt: 2 Mal

Re: 2019-03-29 - Kernels, Gnome, LibreOffice, Mesa, Budgie, Browsers, Qt (Stable Update)

#7

#7 Beitrag von ManjaroHans » Mittwoch 3. April 2019, 17:53

...bei mir alles bestens bisher :)
_______
Grüßle,
Hans

Antworten