System update geht nicht

Hilfe bei Updates und Installtion von neuen Paketen bzw. Programmen.
Antworten
Benutzeravatar

Themen Author
Peter
Forum Kenner
Forum Kenner
Beiträge: 186
Registriert: Donnerstag 3. November 2016, 22:14
Wohnort: Berlin
CPU: Intel Core i5-6200U
GPU: Card-1: Intel HD Graphics 520 Card-2: NVIDIA GM108M [GeForc
Kernel: 4.19.66-1-MANJARO x86_64
DE: KDE Plasma 5.16.4
GPU Treiber: video-hybrid-intel-nvidia-bumblebee
Hat sich bedankt: 5 Mal

System update geht nicht

#1

#1 Beitrag von Peter »

Fehlermeldung in octopi:

Code: Alles auswählen

Starte vollständiges System-Upgrade...

resolving dependencies...
looking for conflicting packages...
error: unresolvable package conflicts detected 
error: failed to prepare transaction (conflicting dependencies) 

Befehl endete mit FEHLERN !
Fehlermeldung bei # pacman -Syyu

Code: Alles auswählen

:: Starte vollständige Systemaktualisierung...
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...
:: xorg-server und xf86-input-acecad stehen miteinander in Konflikt (X-ABI-XINPUT_VERSION). xf86-input-acecad entfernen? [j/N]
Und nun?

Benutzeravatar

Blueriver
Moderator
Moderator
Beiträge: 2064
Registriert: Donnerstag 19. Mai 2016, 15:49
CPU: AMD Quad Core A8 3,6GHz
GPU: AMD/ATI Radeon R7
Kernel: 5.0
DE: LXQT und XFCE Stable, Testing, Unstable
GPU Treiber: Free
Hat sich bedankt: 9 Mal
Danksagung erhalten: 68 Mal

Re: System update geht nicht

#2

#2 Beitrag von Blueriver »

Mit j bestätigen.
Manjaro LXQT und XFCE Stable, Testing, Unstable
CPU: AMD Quad Core A8 3,6GHz
Graka: AMD/ATI Radeon R7
Treiber: Free
Kernel: 4.20

Benutzeravatar

Themen Author
Peter
Forum Kenner
Forum Kenner
Beiträge: 186
Registriert: Donnerstag 3. November 2016, 22:14
Wohnort: Berlin
CPU: Intel Core i5-6200U
GPU: Card-1: Intel HD Graphics 520 Card-2: NVIDIA GM108M [GeForc
Kernel: 4.19.66-1-MANJARO x86_64
DE: KDE Plasma 5.16.4
GPU Treiber: video-hybrid-intel-nvidia-bumblebee
Hat sich bedankt: 5 Mal

Re: System update geht nicht

#3

#3 Beitrag von Peter »

Hat erst mal funktioniert. Es wurde noch ein weiteres Paket mit Konflikt angezeigt xf86-input-joystick (oder so ähnlich) was ich auch löschen musste. Für dieses Paket hätte es allerdings ein Update im AUR gegeben, was sich jedoch vorher nicht aktualisieren ließ wegen der gleichen Abhängigkeitsprobleme.

Bin jetzt mal gespannt ob Skype und Teamviewer aus dem AUR noch weiter korrekt funktionieren... Mehr hatte ich aus dem AUR nicht installiert.

Benutzeravatar

inxi
Forum Kenner
Forum Kenner
Beiträge: 171
Registriert: Montag 22. August 2016, 21:23
GPU:
Kernel:
DE:
GPU Treiber:

Re: System update geht nicht

#4

#4 Beitrag von inxi »

[quote="Peter"]
Hat erst mal funktioniert. Es wurde noch ein weiteres Paket mit Konflikt angezeigt xf86-input-joystick (oder so ähnlich) was ich auch löschen musste.
[/quote]
Solche Meldungen bitte im Codeblock posten. Und zwar komplett von Prompt zu Prompt.
Was sagt:

Code: Alles auswählen

 sudo pacman -Syyu && yaourt -Syua
?

Benutzeravatar

Themen Author
Peter
Forum Kenner
Forum Kenner
Beiträge: 186
Registriert: Donnerstag 3. November 2016, 22:14
Wohnort: Berlin
CPU: Intel Core i5-6200U
GPU: Card-1: Intel HD Graphics 520 Card-2: NVIDIA GM108M [GeForc
Kernel: 4.19.66-1-MANJARO x86_64
DE: KDE Plasma 5.16.4
GPU Treiber: video-hybrid-intel-nvidia-bumblebee
Hat sich bedankt: 5 Mal

Re: System update geht nicht

#5

#5 Beitrag von Peter »

[quote="inxi"]
[quote="Peter"]
Hat erst mal funktioniert. Es wurde noch ein weiteres Paket mit Konflikt angezeigt xf86-input-joystick (oder so ähnlich) was ich auch löschen musste.
[/quote]
Solche Meldungen bitte im Codeblock posten. Und zwar komplett von Prompt zu Prompt.[/quote]
OK kann ich das nächste mal machen.

[quote="inxi"]
Was sagt:

Code: Alles auswählen

 sudo pacman -Syyu && yaourt -Syua
?
[/quote]
Nein, ich will kein Update von der Software aus dem AUR. Dort will sich seit einiger Zeit immer der Teamviewer updaten, der aber nicht zu funktionieren scheint. Siehe Kommentare: https://aur.archlinux.org/packages/team ... mments=all

Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 1151
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.19
DE: Openbox
GPU Treiber: i915
Hat sich bedankt: 6 Mal
Danksagung erhalten: 165 Mal

Re: System update geht nicht

#6

#6 Beitrag von gosia »

Hallo Peter,
[quote="Peter"]
Nein, ich will kein Update von der Software aus dem AUR. Dort will sich seit einiger Zeit immer der Teamviewer updaten, der aber nicht zu funktionieren scheint.
[/quote]
Nur am Rande, wenn dich Teamviewer so ärgert, warum deinstallierst Du ihn nicht einfach?

Viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung...

Benutzeravatar

inxi
Forum Kenner
Forum Kenner
Beiträge: 171
Registriert: Montag 22. August 2016, 21:23
GPU:
Kernel:
DE:
GPU Treiber:

Re: System update geht nicht

#7

#7 Beitrag von inxi »

Oder eben von der Aktualisierung ausschließen, bis der Fehler gefunden und behoben ist. Ansonsten erfährt auch Skype keine Updates, was nicht im Interesse der Sicherheit ist.

Benutzeravatar

Themen Author
Peter
Forum Kenner
Forum Kenner
Beiträge: 186
Registriert: Donnerstag 3. November 2016, 22:14
Wohnort: Berlin
CPU: Intel Core i5-6200U
GPU: Card-1: Intel HD Graphics 520 Card-2: NVIDIA GM108M [GeForc
Kernel: 4.19.66-1-MANJARO x86_64
DE: KDE Plasma 5.16.4
GPU Treiber: video-hybrid-intel-nvidia-bumblebee
Hat sich bedankt: 5 Mal

Re: System update geht nicht

#8

#8 Beitrag von Peter »

[quote="gosia"]
Hallo Peter,
[quote="Peter"]
Nein, ich will kein Update von der Software aus dem AUR. Dort will sich seit einiger Zeit immer der Teamviewer updaten, der aber nicht zu funktionieren scheint.
[/quote]
Nur am Rande, wenn dich Teamviewer so ärgert, warum deinstallierst Du ihn nicht einfach?

Viele Grüße gosia
[/quote]
Teamviewer brauche ich zur Wartung des WindowsPCs von meinem Vater.
Außerdem ärgert er mich ja nicht. Die Version 11 funktioniert doch. Ich will nur das Update nicht solange es nicht funktioniert. Ich verstehe es auch nicht, warum man es dort einstellt, wenn es noch nicht funktioniert.

Benutzeravatar

Themen Author
Peter
Forum Kenner
Forum Kenner
Beiträge: 186
Registriert: Donnerstag 3. November 2016, 22:14
Wohnort: Berlin
CPU: Intel Core i5-6200U
GPU: Card-1: Intel HD Graphics 520 Card-2: NVIDIA GM108M [GeForc
Kernel: 4.19.66-1-MANJARO x86_64
DE: KDE Plasma 5.16.4
GPU Treiber: video-hybrid-intel-nvidia-bumblebee
Hat sich bedankt: 5 Mal

Re: System update geht nicht

#9

#9 Beitrag von Peter »

[quote="inxi"]
Oder eben von der Aktualisierung ausschließen, bis der Fehler gefunden und behoben ist. Ansonsten erfährt auch Skype keine Updates, was nicht im Interesse der Sicherheit ist.
[/quote]
Skype wird dort schon seit Jahren nicht aktualisiert. Die Version ist uralt. Funktioniert aber. Ich glaube man baut gerade an einer aktuellen Version auch für Linux.

Außerdem würde ich die Aktualisierung trotzdem bekommen. On Oktopi werden dann 2 Pakete aus dem AUR zur Aktualisierung angezeigt, von denen ich aber auch nur eins aktualisieren kann, wenn ich möchte. Nur der Notifier blinkt halt seit Wochen.

Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 1151
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.19
DE: Openbox
GPU Treiber: i915
Hat sich bedankt: 6 Mal
Danksagung erhalten: 165 Mal

Re: System update geht nicht

#10

#10 Beitrag von gosia »

Hallo Peter,
[quote="Peter"]
Teamviewer brauche ich zur Wartung des WindowsPCs von meinem Vater.
Außerdem ärgert er mich ja nicht. Die Version 11 funktioniert doch.
[/quote]
Ok, da habe ich was falsch verstanden. Ich dachte, Teamviewer funktioniert gar nicht.

Viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung...

Benutzeravatar

inxi
Forum Kenner
Forum Kenner
Beiträge: 171
Registriert: Montag 22. August 2016, 21:23
GPU:
Kernel:
DE:
GPU Treiber:

Re: System update geht nicht

#11

#11 Beitrag von inxi »

gosia hat geschrieben:
Ok, da habe ich was falsch verstanden.
Dito.

Von Skype habe ich keine Ahnung, Peter. Allerdings ist es bedenklich, wenn es ungepflegt ist.
Ich verstehe es auch nicht, warum man es dort einstellt, wenn es noch nicht funktioniert.
Pakete im AUR werden nicht auf Inhalt geprüft. Ist halt eine Fremdquelle und kann unsicher, fehlerhaft oder einfach Nonsens sein.
Wenn du sicher bist, dass das Paket fehlerhaft ist, kannst du aber auch den Maintainer kontaktieren.

Benutzeravatar

Themen Author
Peter
Forum Kenner
Forum Kenner
Beiträge: 186
Registriert: Donnerstag 3. November 2016, 22:14
Wohnort: Berlin
CPU: Intel Core i5-6200U
GPU: Card-1: Intel HD Graphics 520 Card-2: NVIDIA GM108M [GeForc
Kernel: 4.19.66-1-MANJARO x86_64
DE: KDE Plasma 5.16.4
GPU Treiber: video-hybrid-intel-nvidia-bumblebee
Hat sich bedankt: 5 Mal

Re: System update geht nicht

#12

#12 Beitrag von Peter »

[quote="inxi"]
Pakete im AUR werden nicht auf Inhalt geprüft. Ist halt eine Fremdquelle und kann unsicher, fehlerhaft oder einfach Nonsens sein.
Wenn du sicher bist, dass das Paket fehlerhaft ist, kannst du aber auch den Maintainer kontaktieren.
[/quote]
Ich habe das Update gar nicht erst installiert, da bei der Installation lauter Hinweise standen, dass der Teamviewer nicht connecten kann: "Not Ready. Please check your connection. "
Dies kann man hier gut nachlesen:
https://aur.archlinux.org/packages/team ... mments=all

Ich gehe doch davon aus, dass der Maintainer dies liest oder?


Daemon

Re: System update geht nicht

#13

#13 Beitrag von Daemon »

Da steht aber auch dabei dass man es anmachen kann:

Code: Alles auswählen

$ sudo systemctl restart teamviewerd.service
Mal davon abgesehen, kannst du TeamViewer ignorieren und trotzdem die restlichen Updates aus dem AUR machen.

Antworten