startup script

Hilfe bei Updates und Installtion von neuen Paketen bzw. Programmen.
Antworten

Themen Author
manjaroneuling
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 23
Registriert: Dienstag 28. November 2017, 20:35
GPU:
Kernel:
DE:
GPU Treiber:

startup script

#1

#1 Beitrag von manjaroneuling »

Hi,

ich habe mir vnstat installiert und würde den deamon gern bei jedem Systemstart automatisch starten. Wenn ich richtig verstanden habe ist dafür systemd zuständig.

Also habe ich unter /etc/systemd/system die vorhanden Skripte angeguckt und auf doof Folgendes für vnstat erstellt:

Code: Alles auswählen

cat vnstatd.service 
[Unit]
Description=Vnstat Deamon


[Service]
ExecStart=/usr/bin/vnstatd -d
Restart=always
IgnoreSIGPIPE=no


[Install]
Alias=vnstatd.service

Leider ohne Erfolg. Was hab ich falsch gemacht?

Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 1151
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.19
DE: Openbox
GPU Treiber: i915
Hat sich bedankt: 6 Mal
Danksagung erhalten: 165 Mal

Re: startup script

#2

#2 Beitrag von gosia »

Hallo manjaroneuling,
[quote="manjaroneuling"]
ich habe mir vnstat installiert und würde den deamon gern bei jedem Systemstart automatisch starten. Wenn ich richtig verstanden habe ist dafür systemd zuständig.
[/quote]
Das ist wahr. Aber wenn ich das hier richtig verstehe
https://wiki.archlinux.org/index.php/vnStat
so hat doch vnstat schon einen Service an Bord, es wäre also unnötig, einen eigenen zu basteln.

Viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung...


Themen Author
manjaroneuling
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 23
Registriert: Dienstag 28. November 2017, 20:35
GPU:
Kernel:
DE:
GPU Treiber:

Re: startup script

#3

#3 Beitrag von manjaroneuling »

Hallo,

tatsächlich befand sich unter

/usr/lib/systemd/system/vnstat.service

eine entsprechende Datei. Ich kopierte sie nach /etc/systemd/system und machte sie ausführbar. Nach einem Neustart lief der deamon trotzdem nicht und musste wieder per Hand gestartet werden.


Der Inhalt der Datei ist:

Code: Alles auswählen

[Unit]
Description=vnStat network traffic monitor
Documentation=man:vnstatd(1) man:vnstat(1) man:vnstat.conf(5)
After=network.target

[Service]
ExecStart=/usr/sbin/vnstatd -n
ExecReload=/bin/kill -HUP $MAINPID

[Install]
WantedBy=multi-user.target

Benutzeravatar

Blueriver
Moderator
Moderator
Beiträge: 2064
Registriert: Donnerstag 19. Mai 2016, 15:49
CPU: AMD Quad Core A8 3,6GHz
GPU: AMD/ATI Radeon R7
Kernel: 5.0
DE: LXQT und XFCE Stable, Testing, Unstable
GPU Treiber: Free
Hat sich bedankt: 9 Mal
Danksagung erhalten: 68 Mal

Re: startup script

#4

#4 Beitrag von Blueriver »

Hallo manjaroneuling,

mach mal einen Terminal auf und gib folgendes ein.

Code: Alles auswählen

sudo systemctl enable vnstat.service
danach

Code: Alles auswählen

sudo systemctl start vnstat.service

Ist vielleicht noch interessant.
https://wiki.archlinux.de/title/Vnstat
Zuletzt geändert von Blueriver am Montag 11. Dezember 2017, 11:16, insgesamt 1-mal geändert.
Manjaro LXQT und XFCE Stable, Testing, Unstable
CPU: AMD Quad Core A8 3,6GHz
Graka: AMD/ATI Radeon R7
Treiber: Free
Kernel: 4.20

Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 1151
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.19
DE: Openbox
GPU Treiber: i915
Hat sich bedankt: 6 Mal
Danksagung erhalten: 165 Mal

Re: startup script

#5

#5 Beitrag von gosia »

Hallo manjaroneuling,
irgendwie stellst Du dir selbst ein Bein ;)
Du musst gar nichts irgendwohin kopieren (ist wahrscheinlich eher kontraproduktiv), sondern nur den von Blueriver beschriebenen Zweischritt ausfühhren. Und das gilt in der Regel für alle Dienste, die Du normal installiert hast.

Viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung...


Themen Author
manjaroneuling
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 23
Registriert: Dienstag 28. November 2017, 20:35
GPU:
Kernel:
DE:
GPU Treiber:

Re: startup script

#6

#6 Beitrag von manjaroneuling »

Vielen Dank euch :) Jetzt funktioniert es wie gewünscht und ich hab wieder was gelernt  O:-)

Antworten