gcc8 Libs werden nicht ordentlich aktualisiert

Hilfe bei Updates und Installtion von neuen Paketen bzw. Programmen.
Antworten

Themen Author
Fiolakais
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 1
Registriert: Donnerstag 9. September 2021, 12:15
CPU: Intel(R) Core(TM) i5-3320M CPU @ 2,.60GHZ; 2 cores; 4 thread
GPU: Intel 3rd Gen Core Graphics Controller 1366x768 The X.Org Fo
Kernel: Linux 5.4.142-1-MANJARO(x86_64)
Desktop-Variante: Manjaro 1# SMP PREEMPT Wed Aug 18 08:05:07 UTC 2021
GPU Treiber: The X.Org Foundation 1.20.13

gcc8 Libs werden nicht ordentlich aktualisiert

#1

Beitrag von Fiolakais »

sehr geehrte Damen und Herren,

da ich Manjaro noch nicht sehr lange benutze und immer wieder bei der Aktualisierung auf ein wiederkehrendes Problem stoße, werde ich mich freuen, wenn mir jemand einen Lösungsansatz präsentieren kann.

Code: Alles auswählen

Vorbereitung...
Überprüfe jdk-adoptopenjdk Abhängigkeiten...
Überprüfe gcc8-libs Abhängigkeiten...
Klone electron12-bin Build-Dateien...
Überprüfe electron12-bin Abhängigkeiten...
Überprüfe code-nautilus-git Abhängigkeiten...
Klone zoom Build-Dateien...
Überprüfe zoom Abhängigkeiten...
Klone skypeforlinux-stable-bin Build-Dateien...
Überprüfe skypeforlinux-stable-bin Abhängigkeiten...
Klone electron11-bin Build-Dateien...
Überprüfe electron11-bin Abhängigkeiten...
Klone vscodium-git Build-Dateien...
Überprüfe vscodium-git Abhängigkeiten...
Überprüfe processing-examples Abhängigkeiten...
Überprüfe wps-office Abhängigkeiten...
Synchronisiere Paketdatenbanken...
Warnung: manjaro-hello: Lokale Version (0.6.7-2) ist neuer als extra (0.6.6-9)
Warnung: whatsapp-for-linux: Lokale Version (1.1.5-1) ist neuer als community (1.1.2-0)
Warnung: jdk-adoptopenjdk-16.0.1.u9-1 ist aktuell -- Reinstalliere
Warnung: gcc8-libs-8.4.0-2 ist aktuell -- Reinstalliere
Fehler: Vorgang konnte nicht erfolgreich vorbereitet werden: Ziel nicht gefunden: gcc8



Build-Dateien bearbeiten : [e] 
Transaktion anwenden ? [e/j/N] 
Vorgang abgebrochen.
Benutzeravatar

LaGGGer
Forum Kenner
Forum Kenner
Beiträge: 238
Registriert: Freitag 26. Juni 2020, 18:53
CPU: AMD Ryzen 7 1700X
GPU: NVIDIA GP106 [GeForce GTX 1060 6GB]
Kernel: 5.10
Desktop-Variante: XFCE
GPU Treiber: Nvidia 460
Hat sich bedankt: 17 Mal
Danksagung erhalten: 34 Mal

Re: gcc8 Libs werden nicht ordentlich aktualisiert

#2

Beitrag von LaGGGer »

Hallo und willkommen im Forum

Mit was was du den Vorgang angestoßen? Wie lautet der Befehl?


PS.
In Zukunft den Befehl IMMER mit in die codebox packen. Danke.

PPS. sehr geehrte Damen und Herren sowas kannst du weglassen, hier wird sich geduzt :)
°°
MfG LaGGGer
Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 1598
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.19
Desktop-Variante: Openbox
GPU Treiber: i915
Hat sich bedankt: 8 Mal
Danksagung erhalten: 304 Mal

Re: gcc8 Libs werden nicht ordentlich aktualisiert

#3

Beitrag von gosia »

Hallo Fiolakais,
auch von mir ein herzliches Willkommen im Forum.
LaGGGer hat geschrieben: Freitag 10. September 2021, 12:03 den Befehl IMMER mit in die codebox packen
volle Zustimmung, das darf nie fehlen.
Aber was die gcc8 libs betrifft, wird es wohl schwierig.
Fiolakais hat geschrieben: Donnerstag 9. September 2021, 13:07

Code: Alles auswählen

Ziel nicht gefunden: gcc8
Da gcc8 zumindest bei mir nur im AUR existiert, könnte die einfachste Erklärung sein, dass das AUR nicht freigeschaltet war. Aber generell gibt es wohl Probleme mit gcc8 und gcc8-libs, die hier
https://aur.archlinux.org/packages/gcc8-libs/
ausführlich diskutiert werden. Leider zwar ausführlich, aber für meine Laienaugen auch etwas unklar. Es wird empfohlen, in der PKGBUILD die Flags (oder CFLAGS) zu bearbeiten, auf die neueren gcc11-libs zu setzen, da gcc8 schon sehr alt ist. Aber wie genau das zu tun ist, dazu bedarf es wohl eines tieferen Studiums ;) oder jemandem, der sich damit auskennt.

viele Grüße gosia
Antworten