Fehler beim Updaten...

Hilfe bei Updates und Installtion von neuen Paketen bzw. Programmen.
Antworten
Benutzeravatar

Themen Author
iNSANE
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 6
Registriert: Donnerstag 27. September 2018, 17:45
GPU:
Kernel:
DE:
GPU Treiber:

Fehler beim Updaten...

#1

#1 Beitrag von iNSANE » Sonntag 10. März 2019, 00:08

Hallo zusammen,

Laptop war 2 Wochen aus, wollte heute Updates durchführen und bekam folgenden Fehler:


:: Starte vollständige Systemaktualisierung...
Löse Abhängigkeiten auf...
Fehler: Konnte Datei /var/lib/pacman/local/x265-3.0-1/desc nicht öffnen: Datei oder Verzeichnis nicht gefunden
Suche nach in Konflikt stehenden Paketen...
Warnung: Konnte die Metadaten für Paket x265-3.0-1 nicht vollständig laden
Fehler: Konnte den Vorgang nicht vorbereiten (Ungültiges oder beschädigtes Paket)


Kann jemand bitte helfen? :)

Über Onkel google habe ich nicht wirklich was passendes gefunden.


Danke!

Benutzeravatar

nrde
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 32
Registriert: Samstag 2. März 2019, 17:47
Wohnort: Niedersachsen
CPU: Intel Core i7-7700K
GPU: AMD Radeon R9 380
Kernel: 5.0
DE: Cinnamon
GPU Treiber: amdgpu
Danksagung erhalten: 5 Mal

Re: Fehler beim Updaten...

#2

#2 Beitrag von nrde » Sonntag 10. März 2019, 07:22

Guten Morgen iNSANE,

dein Problem ist auch schon bei anderen Leuten aufgetreten.

forum.manjaro.org

Die Lösung sieht wohl so aus, dass du alle drei Dateien in

Code: Alles auswählen

/var/lib/pacman/local/x265-3.0-1
mit den Dateien eines anderen Paketes überschreiben musst.

Danach kann x265 neu installiert werden

Code: Alles auswählen

sudo pacman -Sy x265 
Viele Grüße

Benutzeravatar

Themen Author
iNSANE
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 6
Registriert: Donnerstag 27. September 2018, 17:45
GPU:
Kernel:
DE:
GPU Treiber:

Re: Fehler beim Updaten...

#3

#3 Beitrag von iNSANE » Sonntag 10. März 2019, 18:39

Vielen Dank für deine Antwort.

Hat aber leider nicht funktioniert :\


Code: Alles auswählen

sudo pacman -Sy x265

:: Synchronisiere Paketdatenbanken...
 core ist aktuell
 extra ist aktuell
 community ist aktuell
 multilib ist aktuell
Warnung: x265-3.0-1 ist aktuell -- Reinstalliere
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...
Fehler: Die Datenbank von local ist inkonsistent: Die Paketnamen für x265 stimmen nicht überein
Fehler: Die Datenbank von local ist inkonsistent: Die Versionsnummern für das Paket x265 stimmen nicht überein

Pakete (1) x265-3.0-1

Gesamtgröße der installierten Pakete:  19,56 MiB
Größendifferenz der Aktualisierung:  19,35 MiB

:: Installation fortsetzen? [J/n] J
(1/1) Prüfe Schlüssel im Schlüsselring             [######################] 100%
(1/1) Überprüfe Paket-Integrität                   [######################] 100%
(1/1) Lade Paket-Dateien                           [######################] 100%
(1/1) Prüfe auf Dateikonflikte                     [######################] 100%
Fehler: Konnte den Vorgang nicht durchführen (In Konflikt stehende Dateien)
x265: /usr/bin/x265 existiert im Dateisystem
x265: /usr/include/hdr10plus.h existiert im Dateisystem
x265: /usr/include/x265.h existiert im Dateisystem
x265: /usr/include/x265_config.h existiert im Dateisystem
x265: /usr/lib/libhdr10plus.so existiert im Dateisystem
x265: /usr/lib/libx265.so existiert im Dateisystem
x265: /usr/lib/libx265.so.169 existiert im Dateisystem
Fehler sind aufgetreten, keine Pakete wurden aktualisiert.

Benutzeravatar

nrde
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 32
Registriert: Samstag 2. März 2019, 17:47
Wohnort: Niedersachsen
CPU: Intel Core i7-7700K
GPU: AMD Radeon R9 380
Kernel: 5.0
DE: Cinnamon
GPU Treiber: amdgpu
Danksagung erhalten: 5 Mal

Re: Fehler beim Updaten...

#4

#4 Beitrag von nrde » Sonntag 10. März 2019, 19:52

Schau mal hier:

https://wiki.archlinux.org/index.php/pa ... 9.22_error
und hier
https://bbs.archlinux.org/viewtopic.php?id=242546

Ich glaube in dieser speziellen Situation darf man Pacman ausnahmsweise zwingen die Dateien zu überschreiben.

Code: Alles auswählen

pacman -S --overwrite /usr/bin/x265,/usr/include/hdr10plus.h,/usr/include/x265.h,/usr/include/x265_config.h,/usr/lib/libhdr10plus.so,/usr/lib/libx265.so,/usr/lib/libx265.so.169 x265
Ich hoffe es funktioniert.

Benutzeravatar

Themen Author
iNSANE
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 6
Registriert: Donnerstag 27. September 2018, 17:45
GPU:
Kernel:
DE:
GPU Treiber:

Re: Fehler beim Updaten...

#5

#5 Beitrag von iNSANE » Sonntag 10. März 2019, 21:22

Also ich habe es jetzt so gelöst, dass ich die Dateien von irgend einem anderen Ordner aus /var/lib/pacman/local/ kopiert habe, diese dann in meinen
"Problemordner" eingefügt habe und dann

sudo pacman -Syu --force

ausgeführt habe.

Gab -soweit ich das sehe- keine Fehler und keine Probleme nach einem Reboot.

Danke!

Antworten