VLC Player spielt nur noch Ton ab, kein Bild

Hilfe bei der Installation von Manjaro Linux!
Benutzeravatar

Themen Author
Jean-Paul
Forum Gott
Forum Gott
Beiträge: 378
Registriert: Sonntag 17. Dezember 2017, 18:19
Wohnort: Baden Württemberg
CPU: Intel Core i5-7400 - 4x 3.5GHz
GPU: AMD
Kernel: 5.4.150-1
Desktop-Variante: KDE 5.86.0 / Plasma 5.22.5
GPU Treiber: Non-Free
Hat sich bedankt: 42 Mal
Danksagung erhalten: 44 Mal

VLC Player spielt nur noch Ton ab, kein Bild

#1

Beitrag von Jean-Paul »

Wer hat einen Rat oder Tipp für mich? Spielt nur noch Ton ab, aber kein Bild mehr. Ist seit ein paar Tagen so, hatte damit noch nie Probleme. Alternative zum testen mit anderem Player, welchen nehmen?

Dankeschön
Freundliche Grüße
Jean-Paul

Why I use Manjaro Linux? Because my computer belongs to me and no company...
Benutzeravatar

Themen Author
Jean-Paul
Forum Gott
Forum Gott
Beiträge: 378
Registriert: Sonntag 17. Dezember 2017, 18:19
Wohnort: Baden Württemberg
CPU: Intel Core i5-7400 - 4x 3.5GHz
GPU: AMD
Kernel: 5.4.150-1
Desktop-Variante: KDE 5.86.0 / Plasma 5.22.5
GPU Treiber: Non-Free
Hat sich bedankt: 42 Mal
Danksagung erhalten: 44 Mal

Re: VLC Player spielt nur noch Ton ab, kein Bild

#2

Beitrag von Jean-Paul »

Ein Test gerade mit dem MPV Player war erfolgreich. Alles gut, Ton und Bild! :)
Beim VLC Player nur Ton..... Kein Bild???
Freundliche Grüße
Jean-Paul

Why I use Manjaro Linux? Because my computer belongs to me and no company...

Geraldo
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 2
Registriert: Samstag 24. April 2021, 12:14
CPU: i7-6800
GPU: GeForce GTX 750
Kernel: 5.11..16
Desktop-Variante: KDE-Plasma
GPU Treiber: Nvidia

Re: VLC Player spielt nur noch Ton ab, kein Bild

#3

Beitrag von Geraldo »

von Werniman (zu Kaffeine):

...... aribb24 nachinstalliert, schon war auch das Bild da….
LG

Werniman
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 24
Registriert: Samstag 2. Dezember 2017, 15:53
GPU:
Kernel:
Desktop-Variante:
GPU Treiber:

Re: VLC Player spielt nur noch Ton ab, kein Bild

#4

Beitrag von Werniman »

Geraldo hat geschrieben: Samstag 24. April 2021, 12:18 von Werniman (zu Kaffeine):

...... aribb24 nachinstalliert, schon war auch das Bild da….
LG
In dem Fall, den du da zitierst, funktionierte aber nur die Wiedergabe in Kaffeine nicht, während VLC-Player selbst die aufgenommenen Streams wiedergeben konnte,obwohl Kaffeine ja im Hintergrund auch nur den VLC-Player benutzt. Aber bekanntlich macht ja Versuch klug, insofern wäre es tatsächlich einen Versuch wert, ob die Nachinstallation von aribb24 auch in diesem Fall hier hilft.

Geraldo
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 2
Registriert: Samstag 24. April 2021, 12:14
CPU: i7-6800
GPU: GeForce GTX 750
Kernel: 5.11..16
Desktop-Variante: KDE-Plasma
GPU Treiber: Nvidia

Re: VLC Player spielt nur noch Ton ab, kein Bild

#5

Beitrag von Geraldo »

Werniman hat geschrieben: Samstag 24. April 2021, 20:55 insofern wäre es tatsächlich einen Versuch wert, ob die Nachinstallation von aribb24 auch in diesem Fall hier hilft.
… und auch bei mir hat es funktioniert - bei VLC und Kaffeine.

Viel Glück! :D
Benutzeravatar

Themen Author
Jean-Paul
Forum Gott
Forum Gott
Beiträge: 378
Registriert: Sonntag 17. Dezember 2017, 18:19
Wohnort: Baden Württemberg
CPU: Intel Core i5-7400 - 4x 3.5GHz
GPU: AMD
Kernel: 5.4.150-1
Desktop-Variante: KDE 5.86.0 / Plasma 5.22.5
GPU Treiber: Non-Free
Hat sich bedankt: 42 Mal
Danksagung erhalten: 44 Mal

Re: VLC Player spielt nur noch Ton ab, kein Bild

#6

Beitrag von Jean-Paul »

Habe aribb24 installiert. Kein Bild! Ton ja..... :( :(
Freundliche Grüße
Jean-Paul

Why I use Manjaro Linux? Because my computer belongs to me and no company...
Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 1629
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.19
Desktop-Variante: Openbox
GPU Treiber: i915
Hat sich bedankt: 8 Mal
Danksagung erhalten: 309 Mal

Re: VLC Player spielt nur noch Ton ab, kein Bild

#7

Beitrag von gosia »

Hallo Jean-Paul,
kann dir nicht helfen, aber vielleicht können es andere besser, wenn Du mehr lieferst als "kein Bild". Log- oder besser Fehlermeldungen könnten da schon hilfreicher sein.
VLC -> Einstellungen -> "alle" auswählen -> Logger -> Protokoll in Datei schreiben -> Qualität des Potokolls auswählen.
Ob da "Fehler" ausreicht oder besser "Fehlerdiagnose" kann ich nicht sagen, mal ausprobieren. Dann die Datei irgendwo hochladen, weil sie wahrscheinlich ziemlich gross ist. Vielleicht bringt das die Experten auf kluge Ideen.

viele Grüße gosia
Benutzeravatar

zompel
Forum Gott
Forum Gott
Beiträge: 267
Registriert: Montag 9. Dezember 2019, 19:52
Wohnort: Essen, NRW
CPU: Intel Core i9-9900KF
GPU: nVidia GeForce RTX 2070
Kernel: Linux 5.14
Desktop-Variante: Gnome
GPU Treiber: nVidia
Hat sich bedankt: 6 Mal
Danksagung erhalten: 46 Mal

Re: VLC Player spielt nur noch Ton ab, kein Bild

#8

Beitrag von zompel »

@Jean-Paul
Ich würde als erstes mal versuchen ob es hilft wenn man die Einstellungen komplett zurücksetzt.
Hierzu einfach den Ordner "vlc" im Ordner ".config" deines Home Verzeichnisses umbenennen (dann kannst du ihn später notfalls wiederherstellen).
Wenn das nichts bringt würde ich anschließend einfach alle optionalen Abhängigkeiten nachinstallieren.
Zudem könnte es hilfreich sein wenn du uns mitteilst ob es nur bestimmte Videos betrifft oder alle Formate.
Benutzeravatar

Themen Author
Jean-Paul
Forum Gott
Forum Gott
Beiträge: 378
Registriert: Sonntag 17. Dezember 2017, 18:19
Wohnort: Baden Württemberg
CPU: Intel Core i5-7400 - 4x 3.5GHz
GPU: AMD
Kernel: 5.4.150-1
Desktop-Variante: KDE 5.86.0 / Plasma 5.22.5
GPU Treiber: Non-Free
Hat sich bedankt: 42 Mal
Danksagung erhalten: 44 Mal

Re: VLC Player spielt nur noch Ton ab, kein Bild

#9

Beitrag von Jean-Paul »

zompel hat geschrieben: Sonntag 25. April 2021, 18:32 @Jean-Paul
Ich würde als erstes mal versuchen ob es hilft wenn man die Einstellungen komplett zurücksetzt.
Hierzu einfach den Ordner "vlc" im Ordner ".config" deines Home Verzeichnisses umbenennen (dann kannst du ihn später notfalls wiederherstellen).
Wenn das nichts bringt würde ich anschließend einfach alle optionalen Abhängigkeiten nachinstallieren.
Zudem könnte es hilfreich sein wenn du uns mitteilst ob es nur bestimmte Videos betrifft oder alle Formate.
Habe ich probiert, hilft alles nix. Es betrifft alle Formate. Auf meinem Zweit/Testrechner mit MX Linux und auf dem Notebook (Linux Mint) gibt es mit VLC Player keinerlei Probleme! Bei Manjaro hingegen mein genanntes Problem (Ton Ja, Bild Nein. Ich habe einiges ausprobiert. VLC gelöscht, neu installiert, Abhängigkeiten nachinstalliert, nichts half.

Der Vorschlag von @gosia ist mir ehrlich gesagt zu komplex. Zumal es ja bei anderen Linux Distris keine Probleme gibt. Alternativ nutze ich eben MPV-Player. Manjaro ist eben anders und ich denke, das es schon irgendwie mit dem System zusammenhängt. Keine Ahnung...

Danke für eure Unterstützung
Freundliche Grüße
Jean-Paul

Why I use Manjaro Linux? Because my computer belongs to me and no company...

Werniman
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 24
Registriert: Samstag 2. Dezember 2017, 15:53
GPU:
Kernel:
Desktop-Variante:
GPU Treiber:

Re: VLC Player spielt nur noch Ton ab, kein Bild

#10

Beitrag von Werniman »

Das Problem scheint wohl nur Arch-basierte Distributionen zu betreffen. Ich vermute, dass in den Paketquellen für VLC nicht alle Abhängigkeiten korrekt mit eingetragen sind.
Benutzeravatar

zompel
Forum Gott
Forum Gott
Beiträge: 267
Registriert: Montag 9. Dezember 2019, 19:52
Wohnort: Essen, NRW
CPU: Intel Core i9-9900KF
GPU: nVidia GeForce RTX 2070
Kernel: Linux 5.14
Desktop-Variante: Gnome
GPU Treiber: nVidia
Hat sich bedankt: 6 Mal
Danksagung erhalten: 46 Mal

Re: VLC Player spielt nur noch Ton ab, kein Bild

#11

Beitrag von zompel »

Ich vermute, dass es aktuell an KDE/Wayland liegt weshalb es nicht richtig rund läuft. Es wird sicher in einen der nächsten Updates wieder behoben.

Du kannst aber noch etwas probieren wenn du gerne bei VLC bleiben möchtest. Bin gerade nicht zu Hause und habe hier nur die Windows Variante.....

Entweder bei den Einstellungen unter Video die "Ausgabe" von Automatisch auf einen der verfügbaren Werte fest einstellen,
oder bei den Einstellungen unter Eingang/Codecs "Hardware-beschleunigte Dekodierung" von Automatisch auf einen Wert fest einstellen.
Ich weiß nicht welche von beiden Möglichkeiten es betrifft. Bei mir habe ich etwa VAAPI oder VDPAU zur Auswahl - könnte bei dir aber auch etwas anders aussehen.
Nach der Umstellung musst du aber VLC neu starten, damit es übernommen wird.
Benutzeravatar

zompel
Forum Gott
Forum Gott
Beiträge: 267
Registriert: Montag 9. Dezember 2019, 19:52
Wohnort: Essen, NRW
CPU: Intel Core i9-9900KF
GPU: nVidia GeForce RTX 2070
Kernel: Linux 5.14
Desktop-Variante: Gnome
GPU Treiber: nVidia
Hat sich bedankt: 6 Mal
Danksagung erhalten: 46 Mal

Re: VLC Player spielt nur noch Ton ab, kein Bild

#12

Beitrag von zompel »

Werniman hat geschrieben: Montag 26. April 2021, 12:49 Das Problem scheint wohl nur Arch-basierte Distributionen zu betreffen. Ich vermute, dass in den Paketquellen für VLC nicht alle Abhängigkeiten korrekt mit eingetragen sind.
An den Abhängigkeiten liegt es vermutlich eher nicht - bei mir funktioniert es Problemlos.
Ich denke aber das bei Arch/Manjaro manche Entwicklung einfach zu früh übernommen wird und sich so Fehler einschleichen welche aber nach gewisser Zeit wieder behoben werden. Deshalb ist es auch so wichtig Snapshots zu machen um notfalls auf eine vorherige Version zurückzuspringen.
Benutzeravatar

Themen Author
Jean-Paul
Forum Gott
Forum Gott
Beiträge: 378
Registriert: Sonntag 17. Dezember 2017, 18:19
Wohnort: Baden Württemberg
CPU: Intel Core i5-7400 - 4x 3.5GHz
GPU: AMD
Kernel: 5.4.150-1
Desktop-Variante: KDE 5.86.0 / Plasma 5.22.5
GPU Treiber: Non-Free
Hat sich bedankt: 42 Mal
Danksagung erhalten: 44 Mal

Re: VLC Player spielt nur noch Ton ab, kein Bild

#13

Beitrag von Jean-Paul »

zompel hat geschrieben: Montag 26. April 2021, 12:52 bei den Einstellungen unter Eingang/Codecs "Hardware-beschleunigte Dekodierung" von Automatisch auf einen Wert fest einstellen.
Ich habe jetzt unter: Eingang/Codecs bei "Hardware-accelerated decoding" auf: VA-API Videodekoder eingestellt. Und siehe da, Bild wieder da und alles gut.

Danke @zompel
Freundliche Grüße
Jean-Paul

Why I use Manjaro Linux? Because my computer belongs to me and no company...
Benutzeravatar

Themen Author
Jean-Paul
Forum Gott
Forum Gott
Beiträge: 378
Registriert: Sonntag 17. Dezember 2017, 18:19
Wohnort: Baden Württemberg
CPU: Intel Core i5-7400 - 4x 3.5GHz
GPU: AMD
Kernel: 5.4.150-1
Desktop-Variante: KDE 5.86.0 / Plasma 5.22.5
GPU Treiber: Non-Free
Hat sich bedankt: 42 Mal
Danksagung erhalten: 44 Mal

Re: VLC Player spielt nur noch Ton ab, kein Bild

#14

Beitrag von Jean-Paul »

Werniman hat geschrieben: Montag 26. April 2021, 12:49 Das Problem scheint wohl nur Arch-basierte Distributionen zu betreffen. Ich vermute, dass in den Paketquellen für VLC nicht alle Abhängigkeiten korrekt mit eingetragen sind.
Da könntest du richtig vermuten.... :-X ;)
Freundliche Grüße
Jean-Paul

Why I use Manjaro Linux? Because my computer belongs to me and no company...
Benutzeravatar

Themen Author
Jean-Paul
Forum Gott
Forum Gott
Beiträge: 378
Registriert: Sonntag 17. Dezember 2017, 18:19
Wohnort: Baden Württemberg
CPU: Intel Core i5-7400 - 4x 3.5GHz
GPU: AMD
Kernel: 5.4.150-1
Desktop-Variante: KDE 5.86.0 / Plasma 5.22.5
GPU Treiber: Non-Free
Hat sich bedankt: 42 Mal
Danksagung erhalten: 44 Mal

Re: VLC Player spielt nur noch Ton ab, kein Bild

#15

Beitrag von Jean-Paul »

Mal wieder der VLC Player... Ein Video abspielen damit geht gar nicht mehr. Er öffnet sich erst gar nicht. Habe mich zwar mittlerweile mit der Alternative: "mpv Media Player arrangiert (auch ein guter Player), aber warum reagiert der VLC überhaupt nicht mehr? Hat da noch jemand damit Probleme?
Freundliche Grüße
Jean-Paul

Why I use Manjaro Linux? Because my computer belongs to me and no company...
Antworten