Seite 1 von 1

CUPS-Update

Verfasst: Freitag 27. November 2020, 17:45
von kaf
Hallo,

heute kamen einige Updates, unter anderem wurde auch CUPS v2.3.3op1 - 2020-11-27 installiert. Seit dem komme ich nicht mehr auf das Webinterface und der Drucker druckt nicht mehr. Seitenladefehler wird im Firefox angezeigt. Vorher ging alles problemlos. Ist das bei anderen auch so? Neuinstallation hat nichts gebracht.

Gruß und danke.

Andreas

Re: CUPS-Update

Verfasst: Freitag 27. November 2020, 19:07
von Josef_K
Hallo Andreas,

guckst du hier:
https://forum.manjaro.org/t/stable-upda ... qt/39962/2

Bei mir haben die letzten 3 Zeilen genügt:

Code: Alles auswählen

sudo systemctl enable --now cups.service
sudo systemctl enable --now cups.socket
sudo systemctl enable --now cups.path
Grüße
Josef

Re: CUPS-Update

Verfasst: Freitag 27. November 2020, 21:33
von kaf
Hallo Josef,

danke für den Tip. Habe zwischenzeitlich das hier gefunden und das hat bei mir geholfen.

sudo systemctl start cups.service (to start the service once)
and
sudo systemctl enable cups.service (to permanently enable the service after reboot aka autostart)

Nochmals vielen Dank.

Gruß
Andreas

Re: CUPS-Update

Verfasst: Montag 14. Dezember 2020, 13:49
von Sachse
Hallo zusammen,

zu diesem Thema möchte ich auch noch etwas loswerden.

Bei mir handelt es sich um 2 Drucker die nicht / nicht richtig funktionieren.
Beides Epson.
Der eine druckt seit dem Update gar nichts mehr , und beim 2. Drucker , geht doppelseitiger Druck als auch mehrere Kopien
ausdrucken nicht mehr.

Die Treiber sind aktuell (epson-inkjet-printer-escpr & epson-inkjet-printer-escpr2) und einen reinstall habe ich ebenfalls schon durchgeführt.

Code: Alles auswählen

systemctl status cups.service
verrät mir das der Dienst aktiv ist und läuft.
Vom Smartphone aus klappt alles tadellos mit der Epson App, ebenso via Win10.

Hab ich irgendwas übersehen?

https://forum.manjaro.org/t/stable-upda ... qt/39962/2

Dieser Anleitung bin ich ebenfalls gefolgt , die auch problemlos durchgelaufen ist.
Die Firmware der Drucker ist ebenfalls aktuell.
Beide sind via WiFi im Heimnetz und über die IP über das Webinterface erreichbar.

Dann bin ich mit meinem Latein am Ende - vielleicht hat von euch noch jemand eine Idee.
Danke im Vorraus für eure Tipps.

LG Sachse

Re: CUPS-Update

Verfasst: Montag 14. Dezember 2020, 20:50
von jolic
Hi, nur eine Idee. Sind deine Drucker so erreichbar und was sagt der Status?

http://localhost:631/printers/

jolic

Re: CUPS-Update

Verfasst: Dienstag 15. Dezember 2020, 11:04
von Sachse
Danke jolic,

der Tipp hat geholfen über das Cups-Webinterface , zumindest bei einem der Kandidaten. (Epson XP 245)
Habe dort den Drucker gelöscht und neu hinzu gefügt , tataaa jetzt druckt er wieder (das war der, welcher gar nichts mehr gedruckt hat via Manjaro)


Den anderen Drucker kann ich mir erst am Wochenende vorknöpfen - aber die Vermutung liegt nah, das es das gleiche Spiel sein wird.

Manjaro ist alledem nicht schuldig an der Misere, hier liegt meiner Meinung nach das Hauptaugenmerk an den Cups-Entwicklern.
Ich kann mich noch dunkel erinnern das (vielleicht 2 Jahre her) der systemd service für Cups schon einmal geändert wurde...aus welchen Gründen auch immer.
Gut belassen wir es dabei - ärgerlich ist es trotzdem weil man die "Nichtfunktion" auch fast 70-jährigen erklären muss und man da sehr leicht Unverständnis erntet weil da, Update=Verbesserung bedeutet.

Fassen wir kurz zusammen , Linux ist nicht Rentnerfreundlich <-- kleiner Spaß am Rande :D

Ich werde berichten was es sich mit dem anderen Gerät auf sich hat.

Bis dahin erstmal dickes Danke für den Tipp.

LG Sachse

Re: CUPS-Update

Verfasst: Samstag 6. Februar 2021, 12:24
von LaGGGer
Ist schon ne Weile her, aber ich hatte auch ein Problem mit Cups, kam über den Browser nicht rein, und die Druckerverwaltung (system-config-printer) zeigte kein Drucker an, keine Konfigurierung möglich.

Gefunden habe ich das hier: https://forum.manjaro.org/t/nach-cups-p ... nden/40699

Zitat Oldtuxie, von ihm kommt auch die Lösung:
Ursache war das letzte Update, was eine Namensänderung der Cups-Dateien mit sich brachte.
Hat bei mir geholfen, alles funktioniert wieder wie es soll. Ich habe einfach die beiden Befehle aus dem oben genanntem Beitrag ausgeführt, das wars:

Code: Alles auswählen

sudo systemctl disable org.cups.cupsd.path org.cups.cupsd.service org.cups.cupsd.socket
und
sudo systemctl enable --now cups.path cups.service cups.socket
EDIT
Leider grade erst gesehen, @Sachse hat einen Link gepostet wo ein ähnlicher Lösungsweg beschrieben wird.
Hatte ich leider übersehen.