Seite 1 von 1

XFCE-Installation mit Fehlermeldung abgebrochen

Verfasst: Donnerstag 30. Juli 2020, 18:48
von Borrtux
Hallo Manjaroaner,
Nachdem ich Manjaro KDE neben WIN10 und Linux Mint auf meinem Laptop installiert habe und damit sehr zufrieden bin, wollte ich nun Manjaro XFCE ebenso neben Linux Mint und WIN10 auf dem Desktop istallieren.
Leider bricht die Installation sowohl auf sda sowie auf sdb mit Fehlermeldung ab.
Irgendwas läuft da falsch. Für den Bootloader wurde mir nur sda2 und sdb angeboten.
Weiß jemand Rat?

Code: Alles auswählen

borrtux@borrtux-desktop:~$ inxi -Fz
System:    Kernel: 5.4.0-42-generic x86_64 bits: 64 Desktop: Cinnamon 4.6.6 Distro: Linux Mint 20 Ulyana 
Machine:   Type: Desktop Mobo: ASRock model: Q1900M serial: <filter> UEFI: American Megatrends v: P1.50 date: 10/31/2014 
CPU:       Topology: Quad Core model: Intel Celeron J1900 bits: 64 type: MCP L2 cache: 1024 KiB 
           Speed: 1333 MHz min/max: 1333/2416 MHz Core speeds (MHz): 1: 1333 2: 1333 3: 1333 4: 1333 
Graphics:  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display driver: i915 v: kernel 
           Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa resolution: 1600x900~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics (BYT) v: 4.2 Mesa 20.0.8 
Audio:     Device-1: Intel Atom Processor Z36xxx/Z37xxx Series High Definition Audio driver: snd_hda_intel 
           Device-2: Logitech HD Webcam C525 type: USB driver: snd-usb-audio,uvcvideo 
           Sound Server: ALSA v: k5.4.0-42-generic 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 
           IF: enp4s0 state: down mac: <filter> 
           Device-2: AVM FRITZ WLAN N v2 [RT5572/rt2870.bin] type: USB driver: rt2800usb 
           IF: wlx24651141f95f state: up mac: <filter> 
Drives:    Local Storage: total: 1.82 TiB used: 40.42 GiB (2.2%) 
           ID-1: /dev/sda model: TP00500GB size: 465.76 GiB 
           ID-2: /dev/sdb vendor: Samsung model: HD154UI size: 1.36 TiB 
Partition: ID-1: / size: 95.62 GiB used: 21.50 GiB (22.5%) fs: ext4 dev: /dev/sdb2 
Sensors:   System Temperatures: cpu: 39.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 207 Uptime: 2h 33m Memory: 7.49 GiB used: 3.10 GiB (41.3%) Shell: bash inxi: 3.0.38 
Hier die (abgetippte) Fehlermeldung (Foto war zu groß zum Hochladen)
Installation gescheitert
Boost.Python-Fehler in Job "Bootloader"
Command'grub-install--target=x86_64-efi --efi-directory=/boot/efi --bootloader-
id=Manjaro --force' returned non-zero exit status1.

Installing for x86_64-efi platform. Could not prepare Boot variable: Input/output error.
grub-install:error efibootmgr failed to register the boot entry:input/output error.

Traceback:

File "/usr/lib/calamares/modules/bootloader/main.py",line 485,in run
prepare_bootloader(fw_type)

File "/usr/lib/calamares/modules/bootloader/main.py",line 457, in prepare_bootloader
install_grub(efi_directory,fw_type)

File "/usr/lib/calamares/modules/bootloader/main.py",line 319, in install_grub
check_target_env_call([libcalamares.job.configuration["grubinstall"],

File "<string>",line6, in <modulle>

Schließen
Wäre schön, wenn ich Manjaro auch auf den Desktop installieren könnte.
Euch schon mal vielen Dank. :)
Edit: PS: das inxi Fz ist aus'm Linux Mint gemacht - nur zur Info für die Hardware.

Re: XFCE-Installation mit Fehlermeldung abgebrochen

Verfasst: Donnerstag 30. Juli 2020, 23:28
von gosia
Hallo Borrtux,
sieht so aus, als ob Du UEFI hast aber keine /boot/efi Partition.
https://wiki.manjaro.org/index.php?titl ... tall_Guide

viele Grüße gosia

Re: XFCE-Installation mit Fehlermeldung abgebrochen

Verfasst: Donnerstag 30. Juli 2020, 23:49
von Borrtux
Hallo Gosia,
erst mal vielen Dank - das schau ich mir morgen an.
Eine efi Partition ist schon da, von dort bootet ja WIN und Mint. aber wie gesagt geht morgen weiter. Jetzt macht mir auch noch mein Laptop Probleme. :-[
Laptopproblem
Erstmal gute Nacht.

Re: XFCE-Installation mit Fehlermeldung abgebrochen

Verfasst: Samstag 29. August 2020, 09:51
von Borrtux
Zwischenbericht - aktuelle Lage
Hier mal ein Zwischenbericht zu meiner XFCE-Installation auf meinem Desktop-PC
Die Installation war ja gescheitert (s. #1)
Später tauchte dann Manjaro im Grub auf (vielleicht nach Kernelupdate im Linux Mint?).
Jedenfalls habe ich gestern mal Manjaro ausgewählt und gestartet - und es lief :D
Es kam die Meldung mehrere hundert Aktualisierungen, fast 1 GB!
Habe ich vorher mit Timeshift eine Sicherung gemacht. Dann Update.
Kernel 5.6.19 wurde entfernt - 5.7.17 installiert - Neustart - nichts geht.
System per Timeshift von Mint aus wiederhergestellt.
Versucht Kernel und NVidia - Treiber bei Update auszuschließen - ging nicht. Er meldete immer Kernel 5.6 wird entfernt. - also erst mal sein gelassen.
Dann habe ich über GUI "Einstellungen" Kernel 5.4.60 installiert - Testlauf - OK
Jetzt 1GB Update durchgeführt.
Neustart Kernel 5.6 war entfernt - 5.7 startet nicht, aber der 5.4 startete.
Jetzt wieder 5.6 installiert, und 5.7 wollte ich deinstallieren, was nicht klappte.
Bei Start mit 5.6.19 kommt folgende Fehlermeldung 2x nacheinander:
mount: /sys/firmware/efi/evifars: unknown filesystem type "efivarfs"
Aber nach kurzer Zeit startet Manjaro
Meine Frage dazu
1. Wie kann ich Kernel 5.7 entfernen?
2. Was hat es mit der Fehlermeldung auf sich?

Erst mal vielen Dank für eure Mühe.

PS:Edit - habe dazu folgendes gefunden komme aber nicht ganz mit klar.
leider in englisch
Was bedeutet
outside the chroot
And in the chroot:

mount -t efivarfs efivarfs /sys/firmware/efi/efivars
Google-Übersetzer:
außerhalb der Chroot
Und in der Chroot:

mount -t efivarfs efivarfs / sys / firmware / efi / efivars
Wie muß ich da vorgehen - bzw. ist das der richtige Ansatz?

Re: XFCE-Installation mit Fehlermeldung abgebrochen

Verfasst: Samstag 29. August 2020, 10:10
von Blueriver
Borrtux hat geschrieben: Samstag 29. August 2020, 09:51 Jetzt wieder 5.6 installiert
Den Kernel 5.6 den du deinstalliert hast gibt es nicht mehr. Den kannst du somit gar nicht wieder installiert haben.
Du hast den Kernel 5.6.19_rt12 installiert.
Borrtux hat geschrieben: Samstag 29. August 2020, 09:51 und 5.7 wollte ich deinstallieren, was nicht klappte.
Probiere es mal mit

Code: Alles auswählen

sudo mhwd-kernel -r linux57
Wenn es Fehlermeldungen gibt poste sie bitte hier.

Re: XFCE-Installation mit Fehlermeldung abgebrochen

Verfasst: Samstag 29. August 2020, 10:28
von Borrtux
Hallo Blueriver,
ja, ich habe Kernel 5.6.19_rt12 - hatte nur abgekürzt - sorry
Fehlermeldung nach
sudo mhwd-kernel -r linux57
ist
[borrtux@borrtux-Manjaro ~]$ sudo mhwd-kernel -r linux57
[sudo] Passwort für borrtux:
Prüfe Abhängigkeiten...
Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: Entfernen von linux57 verletzt Abhängigkeit 'linux57', benötigt von linux-latest
[borrtux@borrtux-Manjaro ~]$

Re: XFCE-Installation mit Fehlermeldung abgebrochen

Verfasst: Samstag 29. August 2020, 12:03
von Blueriver
Probiere es mal mit

Code: Alles auswählen

sudo pacman -Rcsnu linux-latest

Code: Alles auswählen

sudo mhwd-kernel -r linux57

Falls es nicht geht schreib mal bitte ob du virtualbox nutzt und ob bzw. wenn ja welchen nvidia Treiber du nutzt.

Re: XFCE-Installation mit Fehlermeldung abgebrochen

Verfasst: Samstag 29. August 2020, 12:35
von Borrtux
Vielen Dank für deine Hilfe, Blueriver.
Das hat schon mal reibungslos geklappt.
Leider kommt immer noch die Meldung beim Starten:
mount: /sys/firmware/efi/evifars: unknown filesystem type "efivarfs"
Mal sehen, ob das auch noch gelöst werden kann. Ist ja nicht so schlimm, da es den Start nur etwas verzögert.

Vielen Dank.

Re: XFCE-Installation mit Fehlermeldung abgebrochen

Verfasst: Samstag 29. August 2020, 13:10
von Blueriver
Kann es sein das der Fehler nur beim Start des Kernels 5.6.19_rt12 kommt.
Probiere mal ob die Fehlermeldung auch beim Start des Kernel 5.4 kommt.

Re: XFCE-Installation mit Fehlermeldung abgebrochen

Verfasst: Samstag 29. August 2020, 13:19
von Borrtux
Also beim Kernel 5.4.60-2 kommt keine Fehlermeldung.
Sollte den vielleicht nehmen, der ist ja auch LTS
Den 5.6.19_rt12 würde ich dann als Reserve drauf behalten.
(Dann könnte ich eigentlich den Thread als gelöst markieren)

PS: Was ist eigentlich der Unterschied zwischen dem kleinen grünen Haken am Ende meines Themas, und dem großen grünen Haken am Anfang des Anderen Themas (siehe Anhang)?
Bildschirmfoto_2020-08-29_13-24-28.png
Bildschirmfoto_2020-08-29_13-24-28.png (159.3 KiB) 415 mal betrachtet

Re: XFCE-Installation mit Fehlermeldung abgebrochen

Verfasst: Samstag 29. August 2020, 14:14
von Blueriver
Borrtux hat geschrieben: Samstag 29. August 2020, 13:19 Den 5.6.19_rt12 würde ich dann als Reserve drauf behalten.
Nimm lieber einen anderen nicht RT Kernel als Reserve.
Man sollte keine RT-Kernel ohne besonderen Grund nutzen, Ausnahmen gibt es im Audiostudio oder es wird ausdrücklich vom Softwareentwickler verlangt sowie beruflich z.B. bei Elektronikingenieure im Bereich der Messtechnik.
Ich persönlich hab immer die beider letzten LTS Kernel und den neusten Kernel (kein rt).
Borrtux hat geschrieben: Samstag 29. August 2020, 13:19 PS: Was ist eigentlich der Unterschied zwischen dem kleinen grünen Haken am Ende meines Themas, und dem großen grünen Haken am Anfang des Anderen Themas (siehe Anhang)?Bildschirmfoto_2020-08-29_13-24-28.png
Den keinen grünen Haken können die Themenersteller machen, die großen grünen Haken nur die Moderatoren und Admins.

Re: XFCE-Installation mit Fehlermeldung abgebrochen

Verfasst: Samstag 29. August 2020, 18:18
von Borrtux
OK danke für die Antwort.
Zu 1. Das werde ich dann auch so handhaben (kein rt-Kernel)
Zu 2. Danke für die Info (bin hier noch nicht so ganz firm).