Seite 1 von 1

libreoffice startet nicht

Verfasst: Samstag 10. August 2019, 01:06
von die_schönheit
Liebe Leute,
wie im Betreff genannt startet libreoffice nicht.

Code: Alles auswählen

[martin@grosser ~]$ libreoffice --safe-mode

(soffice:11648): Gtk-WARNING **: 00:47:34.727: Could not load a pixbuf from icon theme.
This may indicate that pixbuf loaders or the mime database could not be found.
**
Gtk:ERROR:../gtk/gtk/gtkiconhelper.c:494:ensure_surface_for_gicon: assertion failed (error == NULL): Failed to load /home/martin/.local/share/icons/Adwaita-Blue-Folders/16x16/status/image-missing.png: Fehler beim Öffnen der Datei »/home/martin/.local/share/icons/Adwaita-Blue-Folders/16x16/status/image-missing.png«: Datei oder Verzeichnis nicht gefunden (g-io-error-quark, 1)
Application Error
Ich habe adwaita-icon-theme erneut installiert was aber nix geholfen hat.
Ich benutze KDE.
Hat jemand eine Idee?

Gruß
die_schönheit

Re: libreoffice startet nicht

Verfasst: Samstag 10. August 2019, 10:15
von ASch
Gibt es das Verzeichnis überhaupt?

Re: libreoffice startet nicht

Verfasst: Samstag 10. August 2019, 10:20
von ASch
Sieht für mich so aus als wenn es unter Arch in einem anderen Verzeichnis wäre

https://www.archlinux.org/packages/extr ... eme/files/

Schau mal ob es das Verzeichnis "usr/share/icons/Adwaita/" gibt.

Re: libreoffice startet nicht

Verfasst: Samstag 10. August 2019, 10:40
von ASch
Bei mir gibt es das Verzeichnis .local/share/icons auch nicht, aber mein LibreOffice funktioniert.
Bildschirmfoto_2019-08-10_10-33-29.png
Bildschirmfoto_2019-08-10_10-33-29.png (34.59 KiB) 1528 mal betrachtet

Ich vermute man muss dem LibreOffice nur sagen wo er nachschauen soll. Und zwar unter /usr/share/icons
Bildschirmfoto_2019-08-10_10-41-46.png
Bildschirmfoto_2019-08-10_10-41-46.png (37.09 KiB) 1527 mal betrachtet

Re: libreoffice startet nicht

Verfasst: Samstag 10. August 2019, 11:13
von ASch
Alternativ - bis Jemand die richtige Lösung hat die ich als Linuxneuling und Officemuffel nicht weiß - könntest du in deinem Homeverzeichnis unter ".local/share" ein Verzeichnis "icons" anlegen und dort dann den Ordner "Adwaita" aus dem Verzeichnis "/usr/share/icons" rein kopieren und ihn in "Adwaita-Blue-Folders" umbenennen. Wenn es nur die fehlenden Icons sind welche den Start verhindern, dann sollte es damit starten.

Re: libreoffice startet nicht

Verfasst: Samstag 10. August 2019, 11:37
von gosia
Hallo die_schönheit,
hast Du gdk-pixbuf2 installiert?

Code: Alles auswählen

sudo pacman -S gdk-pixbuf2
viele Grüße gosia

Re: libreoffice startet nicht

Verfasst: Samstag 10. August 2019, 12:47
von die_schönheit
Stimmt. Den Pfad gibt es nur bis:

/home/martin/.local/share/icons/Adwaita-Blue-Folders/16x16/

gdk-pixbuf2 ist installiert.

Nach einer erneuten Installation von adwaita-icon-theme
gibt es nun den fraglichen Ordner in /usr/share
Ich habe die Datei image-missing.png aus dem Ordner
/usr/share/icons/Adwaita/16x16/status/
nach
/home/martin/.local/share/icons/Adwaita-Blue-Folders/16x16/status/

kopiert. Nun startet der writer. Allerdings nur einmal.
Beim zweiten mal kommt:

Code: Alles auswählen

[martin@grosser ~]$ libreoffice --safe-mode

(soffice:3357): Gtk-WARNING **: 12:20:21.609: Could not load a pixbuf from icon theme.
This may indicate that pixbuf loaders or the mime database could not be found.
**
Gtk:ERROR:../gtk/gtk/gtkiconhelper.c:494:ensure_surface_for_gicon: assertion failed (error == NULL): Failed to load /home/martin/.local/share/icons/Adwaita-Blue-Folders/16x16/status/image-missing.png: Fehler beim Öffnen der Datei »/home/martin/.local/share/icons/Adwaita-Blue-Folders/16x16/status/image-missing.png«: Ist ein Verzeichnis (g-io-error-quark, 3)
Application Error
Nachdem ich dann bemängeltes Verzeichnis gelöscht und die Datei image-missing.png wiederhergestellt hatte läuft es wie es soll.
Für mich ist das einigermaßen verwirrend.
Aber egal. Ich bin froh das der writer wieder funktioniert.
Allerbesten Dank für die Hilfe!

Gruß
die_schönheit

Re: libreoffice startet nicht

Verfasst: Samstag 10. August 2019, 12:51
von ASch
Schön. Es ist aber mMn immer noch was nicht richtig. Aber ich hab zu wenig Ahnung was. Aber immerhin kannst du es benutzen.

Re: libreoffice startet nicht

Verfasst: Samstag 10. August 2019, 13:22
von Daemon
Dann mach halt mal das was dir vorgeschlagen wurde, und nicht nur wild irgendwelche Dateien hin und her kopieren bzw. löschen, usw.
gosia hat geschrieben:
Samstag 10. August 2019, 11:37
Hallo die_schönheit,
hast Du gdk-pixbuf2 installiert?

Code: Alles auswählen

sudo pacman -S gdk-pixbuf2
viele Grüße gosia

Re: libreoffice startet nicht

Verfasst: Samstag 10. August 2019, 13:26
von ASch
Hat sie doch
die_schönheit hat geschrieben:
Samstag 10. August 2019, 12:47
Stimmt. Den Pfad gibt es nur bis:

/home/martin/.local/share/icons/Adwaita-Blue-Folders/16x16/

gdk-pixbuf2 ist installiert.


Re: libreoffice startet nicht

Verfasst: Samstag 10. August 2019, 13:42
von Daemon
Hab ich in dem Geschreibsel nicht gesehen.

Gibt es eigentlich einen Grund für die unnötigen Zeilenumbrüche?

Aber, ich vermute mal, da KDE benutzt wird, das irgendwas von GTK fehlt.

Re: libreoffice startet nicht

Verfasst: Samstag 10. August 2019, 14:17
von ASch
Ich denke dass da die Standard Zuordnungen nicht stimmen. Oder die Version von LibreOffice nicht aktuell ist und noch nach nem alten Pfad sucht der so nicht mehr genutzt wird im OS.

Re: libreoffice startet nicht

Verfasst: Samstag 10. August 2019, 15:18
von gosia
Hallo die_schönheit,
es läuft, das ist aber keine Lösung. Kann sein, daß dir beim nächsten Update das ganze um die Ohren fliegt. Apropos Update, wann war dein letztes Update oder hast Du gar partielle Upgrades gemacht = Installation einzelner Pakete ohne vorherige komplette Aktualisierung des ganzen Systems mit

Code: Alles auswählen

sudo pacman -Syu
?
https://wiki.archlinux.de/title/Pacman# ... n_Upgrades

viele Grüße gosia